summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-08-04 01:24:10 +0000
committerStuart Herbert <stuart@gentoo.org>2003-08-04 01:24:10 +0000
commit3b6db407c9fb87f7cf84818149260bc125ddc37e (patch)
treee42c21a6f2a60b26cc660553b3f9f5af193666cf /net-www/phpmp/phpmp-0.8.2.ebuild
parentFix for installation problem when apache not yet installed (diff)
downloadgentoo-2-3b6db407c9fb87f7cf84818149260bc125ddc37e.tar.gz
gentoo-2-3b6db407c9fb87f7cf84818149260bc125ddc37e.tar.bz2
gentoo-2-3b6db407c9fb87f7cf84818149260bc125ddc37e.zip
Fix for installation problem when apache not yet installed
Diffstat (limited to 'net-www/phpmp/phpmp-0.8.2.ebuild')
-rw-r--r--net-www/phpmp/phpmp-0.8.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-www/phpmp/phpmp-0.8.2.ebuild b/net-www/phpmp/phpmp-0.8.2.ebuild
index ff70f88a27bb..6f5d8a2bbd96 100644
--- a/net-www/phpmp/phpmp-0.8.2.ebuild
+++ b/net-www/phpmp/phpmp-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpmp/phpmp-0.8.2.ebuild,v 1.2 2003/08/03 23:28:49 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpmp/phpmp-0.8.2.ebuild,v 1.3 2003/08/04 01:24:02 stuart Exp $
MY_P="phpMp-${PV}"
S=${WORKDIR}/${MY_P}
@@ -16,11 +16,14 @@ IUSE=""
DEPEND=">=net-www/apache-1.3.27-r1 >=mod_php-4.2.3-r2"
inherit webapp-apache
-webapp-determine-installowner
-webapp-determine-htdocsdir
+webapp-detect || NO_WEBSERVER=1
PHPMP_DIR="${HTTPD_ROOT}/phpMp"
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+}
+
src_compile() {
#we need to have this empty function ... default compile hangs
echo "Nothing to compile"