summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-02-18 14:20:12 +0000
committerMarinus Schraal <foser@gentoo.org>2004-02-18 14:20:12 +0000
commita9120f3f24888bd377a609c2d0c96c6bcacb4995 (patch)
tree63580c8809ed6e9c98202f44c82cad3e39f84aa3 /net-www/straw/straw-0.22.ebuild
parentucspi-tcp-0.88-r6.ebuild, ucspi-tcp-0.88-r7.ebuild, ucspi-tcp-0.88-r8.ebuild:... (diff)
downloadgentoo-2-a9120f3f24888bd377a609c2d0c96c6bcacb4995.tar.gz
gentoo-2-a9120f3f24888bd377a609c2d0c96c6bcacb4995.tar.bz2
gentoo-2-a9120f3f24888bd377a609c2d0c96c6bcacb4995.zip
New release
Diffstat (limited to 'net-www/straw/straw-0.22.ebuild')
-rw-r--r--net-www/straw/straw-0.22.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-www/straw/straw-0.22.ebuild b/net-www/straw/straw-0.22.ebuild
new file mode 100644
index 000000000000..9916a945ce8d
--- /dev/null
+++ b/net-www/straw/straw-0.22.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.22.ebuild,v 1.1 2004/02/18 14:20:12 foser Exp $
+
+inherit gnome2 python distutils
+
+DESCRIPTION="RSS/RDF News Aggregator"
+HOMEPAGE="http://www.nongnu.org/straw/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2.3-r3"
+
+RDEPEND="${DEPEND}
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2.0.1
+ >=dev-python/gnome-python-1.99.13
+ >=dev-python/pygtk-1.99.13-r1
+ >=dev-python/bsddb3-3.4.0
+ >=dev-python/egenix-mx-base-2
+ >=dev-python/adns-python-1.0.0"
+# REMIND : egenix-mx-base is only needed for the conversion of
+# pre 0.22 straw databases. It should be removed at some point.
+# foser <foser@gentoo.org> 18 Feb 2004
+
+
+src_install() {
+
+ distutils_src_install \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-schemas-install
+
+}
+
+pkg_postinst() {
+
+ distutils_pkg_postinst
+ gnome2_pkg_postinst # need this for gconf schemas
+
+ echo
+ einfo "Consult the README if you have database conversion problems on startup."
+ echo
+
+}
+
+pkg_postrm() {
+
+ distutils_pkg_postrm
+ gnome2_pkg_postrm
+
+}