summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2002-08-27 16:15:55 +0000
committerAchim Gottinger <achim@gentoo.org>2002-08-27 16:15:55 +0000
commit25a664a6776eefdb04a01231f3a733c44e1d6d33 (patch)
tree594d6ec916e9b68c3150af47732c32807b0eccdc /net-www
parentMarking blender as an x86 *only* ebuild for the time being. (diff)
downloadgentoo-2-25a664a6776eefdb04a01231f3a733c44e1d6d33.tar.gz
gentoo-2-25a664a6776eefdb04a01231f3a733c44e1d6d33.tar.bz2
gentoo-2-25a664a6776eefdb04a01231f3a733c44e1d6d33.zip
Added mysql support
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_mp3/ChangeLog8
-rw-r--r--net-www/mod_mp3/files/digest-mod_mp3-0.35-r21
-rw-r--r--net-www/mod_mp3/mod_mp3-0.35-r2.ebuild52
3 files changed, 60 insertions, 1 deletions
diff --git a/net-www/mod_mp3/ChangeLog b/net-www/mod_mp3/ChangeLog
index 9743043b56af..27464cc0f6f2 100644
--- a/net-www/mod_mp3/ChangeLog
+++ b/net-www/mod_mp3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_mp3
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.3 2002/07/14 20:25:23 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.4 2002/08/27 16:15:55 achim Exp $
+
+*mod_mp3-0.35-r2 (27 Aug 2002)
+
+ 27 Aug 2002; Achim Gottinger <achim@gentoo.org> mod_mp3-0.35-r1.ebuild :
+
+ Added mysql support
*mod_mp3-0.35-r1 (4 May 2002)
diff --git a/net-www/mod_mp3/files/digest-mod_mp3-0.35-r2 b/net-www/mod_mp3/files/digest-mod_mp3-0.35-r2
new file mode 100644
index 000000000000..5754bce8c732
--- /dev/null
+++ b/net-www/mod_mp3/files/digest-mod_mp3-0.35-r2
@@ -0,0 +1 @@
+MD5 cad75f267767127b829ac73a809a2954 mod_mp3-0.35.tar.gz 43694
diff --git a/net-www/mod_mp3/mod_mp3-0.35-r2.ebuild b/net-www/mod_mp3/mod_mp3-0.35-r2.ebuild
new file mode 100644
index 000000000000..35b5512b6c28
--- /dev/null
+++ b/net-www/mod_mp3/mod_mp3-0.35-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.35-r2.ebuild,v 1.1 2002/08/27 16:15:55 achim Exp $
+
+DESCRIPTION="Module for turning Apache into an MP3 or Ogg streaming server"
+HOMEPAGE="http://media.tangent.org/"
+KEYWORDS="x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+
+DEPEND="virtual/glibc >=net-www/apache-1.3.24 sys-devel/perl
+ mysql? ( >=dev-db/mysql-3.23.26 )"
+
+LICENSE="as-is"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use mysql && myconf="${myconf} --with-mysql"
+ ./configure ${myconf} || die
+ make clean
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe src/mod_mp3.so
+
+ dodoc CONTRIBUTORS MANIFEST TODO ChangeLog LICENSE README VERSION
+ dodoc support/{faq.pod,mp3_with_mysql.conf,mysql_schema,pgsql_schema}
+ dohtml faq.html
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_mp3.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_mp3.so mod_mp3.c mp3_module \
+ define=MP3 addconf=conf/addon-modules/mod_mp3.conf
+ :;
+}