summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-04-07 04:13:52 +0000
committerBrad Laue <brad@gentoo.org>2004-04-07 04:13:52 +0000
commit849a0eec5ccc4272d11438330d42b88a7a4f6ed4 (patch)
tree9de7912ca0fc836ecb6f4480bb2fa2380752c5a4 /net-www
parentoggvorbis is a requirement, not optional. See bug #46963 (Manifest recommit) (diff)
downloadgentoo-2-849a0eec5ccc4272d11438330d42b88a7a4f6ed4.tar.gz
gentoo-2-849a0eec5ccc4272d11438330d42b88a7a4f6ed4.tar.bz2
gentoo-2-849a0eec5ccc4272d11438330d42b88a7a4f6ed4.zip
GCC 2.95.3 fixes
Diffstat (limited to 'net-www')
-rw-r--r--net-www/kazehakase/ChangeLog6
-rw-r--r--net-www/kazehakase/files/kz-scrap-bookmark-action.gcc2.patch19
-rw-r--r--net-www/kazehakase/files/kz-tab-label.gcc2.patch19
-rw-r--r--net-www/kazehakase/kazehakase-0.1.4.ebuild5
4 files changed, 47 insertions, 2 deletions
diff --git a/net-www/kazehakase/ChangeLog b/net-www/kazehakase/ChangeLog
index e7314136bd15..940b129b2407 100644
--- a/net-www/kazehakase/ChangeLog
+++ b/net-www/kazehakase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/kazehakase
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/kazehakase/ChangeLog,v 1.4 2004/04/06 12:13:08 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/kazehakase/ChangeLog,v 1.5 2004/04/07 04:13:52 brad Exp $
+
+ 07 Apr 2004; Brad Laue <brad@gentoo.org> kazehakase-0.1.4.ebuild,
+ files/kz-scrap-bookmark-action.gcc2.patch, files/kz-tab-label.gcc2.patch:
+ GCC 2.95.3 compile fixes, devised in cooperation with the FreeBSD maintainer.
06 Apr 2004; David Holm <dholm@gentoo.org> kazehakase-0.1.4.ebuild:
Added to ~ppc.
diff --git a/net-www/kazehakase/files/kz-scrap-bookmark-action.gcc2.patch b/net-www/kazehakase/files/kz-scrap-bookmark-action.gcc2.patch
new file mode 100644
index 000000000000..25a64aa6f689
--- /dev/null
+++ b/net-www/kazehakase/files/kz-scrap-bookmark-action.gcc2.patch
@@ -0,0 +1,19 @@
+--- src/actions/kz-scrap-bookmark-action.c.orig Fri Mar 26 09:26:09 2004
++++ src/actions/kz-scrap-bookmark-action.c Tue Apr 6 06:27:14 2004
+@@ -213,6 +213,7 @@
+ {
+ KzBookmark *scrap;
+ KzWindow *kz;
++ const gchar *uri;
+
+ scrap = KZ_SCRAP_BOOKMARK_ACTION(action)->scrap;
+ g_return_if_fail(KZ_IS_BOOKMARK(scrap));
+@@ -220,7 +221,7 @@
+ kz = KZ_SCRAP_BOOKMARK_ACTION(action)->kz;
+ if (!KZ_IS_WINDOW(kz)) return;
+
+- const gchar *uri = kz_bookmark_get_link(scrap);
++ uri = kz_bookmark_get_link(scrap);
+
+ kz_window_load_url(kz, uri);
+ }
diff --git a/net-www/kazehakase/files/kz-tab-label.gcc2.patch b/net-www/kazehakase/files/kz-tab-label.gcc2.patch
new file mode 100644
index 000000000000..574fc267afe8
--- /dev/null
+++ b/net-www/kazehakase/files/kz-tab-label.gcc2.patch
@@ -0,0 +1,19 @@
+--- src/kz-tab-label.c.orig 2004-04-06 23:58:19.413616920 -0400
++++ src/kz-tab-label.c 2004-04-06 23:58:24.880785784 -0400
+@@ -1170,6 +1170,7 @@
+ gint state, gint status,
+ KzTabLabel *kztab)
+ {
++ GdkGC *gc;
+ gdouble progress;
+ GtkWidget *widget;
+
+@@ -1186,7 +1187,7 @@
+
+ mask = gdk_pixmap_new(widget->window,
+ width, height, 1);
+- GdkGC *gc = gdk_gc_new(mask);
++ gc = gdk_gc_new(mask);
+ gdk_draw_rectangle(mask,
+ gc,
+ TRUE,
diff --git a/net-www/kazehakase/kazehakase-0.1.4.ebuild b/net-www/kazehakase/kazehakase-0.1.4.ebuild
index 35533e1287ee..bbad44bbab89 100644
--- a/net-www/kazehakase/kazehakase-0.1.4.ebuild
+++ b/net-www/kazehakase/kazehakase-0.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/kazehakase/kazehakase-0.1.4.ebuild,v 1.2 2004/04/06 12:13:08 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/kazehakase/kazehakase-0.1.4.ebuild,v 1.3 2004/04/07 04:13:52 brad Exp $
IUSE=""
@@ -40,6 +40,9 @@ src_compile(){
export WANT_AUTOCONF=2.5
export WANT_AUTOMAKE=1.6
+ epatch ${FILESDIR}/kz-scrap-bookmark-action.gcc2.patch
+ epatch ${FILESDIR}/kz-tab-label.gcc2.patch
+
./autogen.sh || die
econf || die
emake || die