summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-07-16 18:56:44 +0000
committerDon Seiler <rizzo@gentoo.org>2003-07-16 18:56:44 +0000
commit96c02034d7fc2016aef47c19a9da6fa61cdcc4b9 (patch)
tree672c2784b42ddc9277076237c202d576912324d5 /net-www
parentInitial Commit (diff)
downloadgentoo-2-96c02034d7fc2016aef47c19a9da6fa61cdcc4b9.tar.gz
gentoo-2-96c02034d7fc2016aef47c19a9da6fa61cdcc4b9.tar.bz2
gentoo-2-96c02034d7fc2016aef47c19a9da6fa61cdcc4b9.zip
Initial Commit
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phpwebsite/ChangeLog8
-rw-r--r--net-www/phpwebsite/Manifest1
-rw-r--r--net-www/phpwebsite/files/digest-phpwebsite-0.9.2_p11
-rw-r--r--net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild52
4 files changed, 62 insertions, 0 deletions
diff --git a/net-www/phpwebsite/ChangeLog b/net-www/phpwebsite/ChangeLog
new file mode 100644
index 000000000000..9a50fdd93af7
--- /dev/null
+++ b/net-www/phpwebsite/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/phpwebsite
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpwebsite/ChangeLog,v 1.1 2003/07/16 18:52:27 rizzo Exp $
+
+*phpwebsite-0.9.2_p1 (16 Jul 2003)
+
+ 16 Jul 2003; Don Seiler <rizzo@gentoo.org>:
+ Initial import. Ebuild submitted by me.
diff --git a/net-www/phpwebsite/Manifest b/net-www/phpwebsite/Manifest
index e2354f673fa5..37da4844923c 100644
--- a/net-www/phpwebsite/Manifest
+++ b/net-www/phpwebsite/Manifest
@@ -1,2 +1,3 @@
MD5 ed106055f87ad7eed82bb0bbbea8617d ChangeLog 340
MD5 d6224574a4b4b23d9b826bc54ca43050 phpwebsite-0.9.2_p1.ebuild 1587
+MD5 f0ab7279c69a8f1522e8a4eb3ac7cc18 files/digest-phpwebsite-0.9.2_p1 76
diff --git a/net-www/phpwebsite/files/digest-phpwebsite-0.9.2_p1 b/net-www/phpwebsite/files/digest-phpwebsite-0.9.2_p1
new file mode 100644
index 000000000000..fc6e3206729a
--- /dev/null
+++ b/net-www/phpwebsite/files/digest-phpwebsite-0.9.2_p1
@@ -0,0 +1 @@
+MD5 152e61e6a8cff3dc7a13e0d8a3bda306 phpwebsite-0.9.2-1-full.tar.gz 1616766
diff --git a/net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild b/net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild
new file mode 100644
index 000000000000..fc1a6896e32f
--- /dev/null
+++ b/net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Don Seiler <rizzo@gentoo.org>
+# $Header $
+
+
+HOSTNAME=`hostname`
+DESCRIPTION="phpWebSite provides a complete web site content management system. Web-based administration allows for easy maintenance of interactive, community-driven web sites."
+HOMEPAGE="http://phpwebsite.appstate.edu"
+MY_PV="${PV/_p/-}"
+S="${WORKDIR}/${PN}-${MY_PV}-full"
+SRC_URI="mirror://sourceforge/phpwebsite/${PN}-${MY_PV}-full.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/php"
+
+HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache2/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install() {
+ cd ${S}
+ dodir ${HTTPD_ROOT}/phpwebsite
+ cp -r * ${D}/${HTTPD_ROOT}/phpwebsite
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You will need to create a database for phpWebSite"
+ einfo "on your own before starting setup. You will also need"
+ einfo "to run:"
+ einfo
+ einfo "${HTTPD_ROOT}/phpwebsite/setup/secure_setup.sh setup"
+ einfo
+ einfo "Once you have a database ready proceed to"
+ einfo "http://$HOSTNAME/phpwebsite to continue installation."
+ einfo
+ einfo "Once you are done with installation you need to run"
+ einfo
+ einfo "${HTTPD_ROOT}/phpwebsite/setup/secure_phpws.sh run apache users"
+ einfo
+}