summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-09 19:06:09 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-09 19:06:09 +0000
commitc69d6f3c5badd68934e4f697957f292d5e12f002 (patch)
tree4bd6206c2374fbe08dcbe1025283e1eb795230f8 /net-www
parentNew package (diff)
downloadgentoo-2-c69d6f3c5badd68934e4f697957f292d5e12f002.tar.gz
gentoo-2-c69d6f3c5badd68934e4f697957f292d5e12f002.tar.bz2
gentoo-2-c69d6f3c5badd68934e4f697957f292d5e12f002.zip
remove unneeded stuff in patch
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/files/mozilla-1.0-abi-compat-wrappers.patch49
1 files changed, 1 insertions, 48 deletions
diff --git a/net-www/mozilla/files/mozilla-1.0-abi-compat-wrappers.patch b/net-www/mozilla/files/mozilla-1.0-abi-compat-wrappers.patch
index e43373915a8b..5c44d23dfede 100644
--- a/net-www/mozilla/files/mozilla-1.0-abi-compat-wrappers.patch
+++ b/net-www/mozilla/files/mozilla-1.0-abi-compat-wrappers.patch
@@ -1,49 +1,3 @@
-Index: configure.in
-===================================================================
-RCS file: /cvsroot/mozilla/configure.in,v
-retrieving revision 1.1056
-diff -u -r1.1056 configure.in
---- configure.in 2 Jul 2002 20:26:10 -0000 1.1056
-+++ configure.in 3 Jul 2002 22:46:49 -0000
-@@ -883,6 +883,7 @@
- ;;
- i?86)
- USE_ELF_DYNSTR_GC=1
-+ MOZ_ENABLE_OLD_ABI_COMPAT_WRAPPERS=1
- ;;
- mips*)
- CFLAGS="$CFLAGS -Wa,-xgot"
-@@ -3652,6 +3653,30 @@
- [ --enable-elf-dynstr-gc Enable elf dynstr garbage collector (opt builds only)],
- USE_ELF_DYNSTR_GC=1,
- USE_ELF_DYNSTR_GC= )
-+
-+dnl ========================================================
-+dnl = --enable-old-abi-compat-wrappers
-+dnl ========================================================
-+dnl on x86 linux, the current builds of some popular plugins (notably
-+dnl flashplayer and real) expect a few builtin symbols from libgcc
-+dnl which were available in some older versions of gcc. However,
-+dnl they're _NOT_ available in newer versions of gcc (eg 3.1), so if
-+dnl we want those plugin to work with a gcc-3.1 built binary, we need
-+dnl to provide these symbols. MOZ_ENABLE_OLD_ABI_COMPAT_WRAPPERS defaults
-+dnl to true on x86 linux, and false everywhere else.
-+dnl
-+
-+MOZ_ARG_ENABLE_BOOL(old-abi-compat-wrappers
-+[ --old-abi-compat-wrappers, Support old GCC ABI symbols to ease the pain of the linux compiler change],
-+ MOZ_ENABLE_OLD_ABI_COMPAT_WRAPPERS=1,
-+ MOZ_ENABLE_OLD_ABI_COMPAT_WRAPPERS= )
-+if test "$MOZ_ENABLE_OLD_ABI_COMPAT_WRAPPERS"; then
-+ AC_LANG_SAVE
-+ AC_LANG_CPLUSPLUS
-+ AC_CHECK_FUNCS(__builtin_vec_new __builtin_vec_delete __builtin_new __builtin_delete __pure_virtual)
-+ AC_LANG_RESTORE
-+ AC_DEFINE(MOZ_ENABLE_OLD_ABI_COMPAT_WRAPPERS)
-+fi
-
- dnl ========================================================
- dnl = --enable-prebinding
Index: xpfe/bootstrap/nsAppRunner.cpp
===================================================================
RCS file: /cvsroot/mozilla/xpfe/bootstrap/nsAppRunner.cpp,v
@@ -51,7 +5,7 @@ retrieving revision 1.353
diff -u -r1.353 nsAppRunner.cpp
--- xpfe/bootstrap/nsAppRunner.cpp 16 May 2002 01:02:12 -0000 1.353
+++ xpfe/bootstrap/nsAppRunner.cpp 3 Jul 2002 22:46:49 -0000
-@@ -134,6 +134,58 @@
+@@ -134,6 +134,57 @@
#include "jprof.h"
#endif
@@ -66,7 +20,6 @@ diff -u -r1.353 nsAppRunner.cpp
+// The fact that the new and free operators are mismatched
+// mirrors the way the original functions in egcs 1.1.2 worked.
+
-+
+extern "C" {
+
+# ifndef HAVE___builtin_vec_new