summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 08:57:39 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 08:57:39 +0000
commitd4596233d63e9ae58db5f81f6bfbb6a492e34a4b (patch)
tree6e338dcee87c28d4d2421e9b029a2df85ed3f694 /net-www
parent*** empty log message *** (diff)
downloadgentoo-2-d4596233d63e9ae58db5f81f6bfbb6a492e34a4b.tar.gz
gentoo-2-d4596233d63e9ae58db5f81f6bfbb6a492e34a4b.tar.bz2
gentoo-2-d4596233d63e9ae58db5f81f6bfbb6a492e34a4b.zip
*** empty log message ***
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon/galeon-0.11.0.ebuild39
-rw-r--r--net-www/mozilla/mozilla-0.9.1.ebuild67
2 files changed, 106 insertions, 0 deletions
diff --git a/net-www/galeon/galeon-0.11.0.ebuild b/net-www/galeon/galeon-0.11.0.ebuild
new file mode 100644
index 000000000000..e22ee218d54f
--- /dev/null
+++ b/net-www/galeon/galeon-0.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-0.11.0.ebuild,v 1.1 2001/06/09 08:57:39 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A small webbrowser for gnome that uses mozillas render engine"
+SRC_URI="http://prdownloads.sourceforge.net/galeon/${A}"
+HOMEPAGE="http://galeon.sourceforge.net"
+
+DEPEND=">=net-www/mozilla-0.9.1
+ >=gnome-apps/glade-0.6.2
+ >=gnome-base/gnome-core-1.4.0
+ >=dev-util/xml-i18n-tools-0.8.4
+ nls? ( sys-devel/gettext )"
+
+RDEPEND=">=net-www/mozilla-0.9
+ >=gnome-apps/glade-0.6.2
+ >=gnome-base/gnome-core-1.4.0"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome --host=${CHOST} \
+ --with-mozilla-libs=/opt/mozilla \
+ --with-mozilla-includes=/opt/mozilla/include $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS ChangeLog COPYING* FAQ NEWS README TODO THANKS
+}
+
diff --git a/net-www/mozilla/mozilla-0.9.1.ebuild b/net-www/mozilla/mozilla-0.9.1.ebuild
new file mode 100644
index 000000000000..a0d9d5bd82c4
--- /dev/null
+++ b/net-www/mozilla/mozilla-0.9.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/net-www/mozilla/mozilla-0.9.ebuild,v 1.4 2001/06/07 01:45:52 achim Exp
+
+A=mozilla-source-${PV}.tar.gz
+S=${WORKDIR}/mozilla
+DESCRIPTION=""
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla${PV}/src/${A}"
+HOMEPAGE="http://www.mozilla.org"
+PROVIDE="virtual/x11-web-browser"
+
+DEPEND="sys-devel/perl >=gnome-base/ORBit-0.5.7
+ >=x11-libs/gtk+-1.2.9
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.9
+ app-arch/zip
+ app-arch/unzip"
+RDEPEND=">=gnome-base/ORBit-0.5.7
+ >=x11-libs/gtk+-1.2.9
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.9
+ app-arch/zip
+ app-arch/unzip"
+
+src_compile() {
+
+ try ./configure --prefix=/opt/mozilla --host=${CHOST} \
+ --with-gtk --disable-tests --disable-debug
+ try make
+ try ./configure --prefix=/opt/mozilla --host=${CHOST} \
+ --with-gtk --disable-tests --disable-debug
+ try make BUILD_MODULES=psm
+ try ./configure --prefix=/opt/mozilla --host=${CHOST} \
+ --with-gtk --disable-tests --disable-debug \
+ --with-extensions=default,irc
+ cd extensions/irc
+ try make
+}
+
+src_install () {
+
+ dodir /opt/mozilla/include/nspr/{private,obsolete,md}
+ cd dist/include
+ cp -f *.h ${D}/opt/mozilla/include
+ cp -f nspr/*.h ${D}/opt/mozilla/include/nspr
+ cp -f nspr/obsolete/*.h ${D}/opt/mozilla/include/nspr/obsolete
+ cp -f nspr/private/*.h ${D}/opt/mozilla/include/nspr/private
+ cp -f nspr/md/*.h ${D}/opt/mozilla/include/nspr/md
+
+ export MOZILLA_OFFICIAL=1
+ export BUILD_OFFICIAL=1
+ cd ${S}/xpinstall/packager
+ try make
+ dodir /opt
+ tar xzf ${S}/dist/mozilla-i686-pc-linux-gnu.tar.gz -C ${D}/opt
+ mv ${D}/opt/package ${D}/opt/mozilla
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/mozilla
+ insinto /etc/env.d
+ doins ${FILESDIR}/10mozilla
+ dodoc LEGAL LICENSE README/mozilla/README*
+
+
+}
+