summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJodok Batlogg <batlogg@gentoo.org>2004-10-25 07:27:13 +0000
committerJodok Batlogg <batlogg@gentoo.org>2004-10-25 07:27:13 +0000
commit6b71ef59746cc0a4cb5b2b2f181f3083e38c4375 (patch)
tree137bdff17239cb5ad81677d172ed0cae6338bd34 /net-zope
parentAdded checks for null pointers in charset.c to prevent segfaulting (Manifest ... (diff)
downloadgentoo-2-6b71ef59746cc0a4cb5b2b2f181f3083e38c4375.tar.gz
gentoo-2-6b71ef59746cc0a4cb5b2b2f181f3083e38c4375.tar.bz2
gentoo-2-6b71ef59746cc0a4cb5b2b2f181f3083e38c4375.zip
version bump
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog8
-rw-r--r--net-zope/zope/Manifest4
-rw-r--r--net-zope/zope/files/2.7.3/gid.patch18
-rw-r--r--net-zope/zope/files/2.7.3/zope.initd53
-rw-r--r--net-zope/zope/files/digest-zope-2.7.31
-rw-r--r--net-zope/zope/zope-2.7.3.ebuild106
6 files changed, 189 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 0a8a72ce28c6..4626bc33d6c6 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.52 2004/10/18 18:31:20 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.53 2004/10/25 07:27:13 batlogg Exp $
+
+*zope-2.7.3 (24 Oct 2004)
+
+ 24 Oct 2004; Jodok Batlogg <batlogg@gentoo.org>; +files/2.7.3/gid.patch,
+ +files/2.7.3/zope.initd, +zope-2.7.3.ebuild:
+ version bump, unstable on all platforms
18 Oct 2004; Radoslaw Stachowiak <radek@gentoo.org> -zope-2.7.2-r1.ebuild,
-zope-2.7.2.ebuild:
diff --git a/net-zope/zope/Manifest b/net-zope/zope/Manifest
index acb089e4a91f..fe085cb19190 100644
--- a/net-zope/zope/Manifest
+++ b/net-zope/zope/Manifest
@@ -1,4 +1,5 @@
MD5 6649fe5786ca04047e024eff6ea386ad zope-2.7.1.ebuild 3816
+MD5 9c3cd78e98230af1ff6b3f33e91162a7 zope-2.7.3.ebuild 3222
MD5 ff3f3ff791f9c791bb13d1276ce98de3 zope-2.6.4-r1.ebuild 5622
MD5 6d39bd0ff034f2d0eeb6877fa6b4b28f ChangeLog 9312
MD5 7890d88c5c6d189fbe6b187a3ebb6532 metadata.xml 161
@@ -6,6 +7,7 @@ MD5 06308d0d91be80561036160135ea2eea zope-2.7.2-r2.ebuild 3219
MD5 ddddbf81a9803fef7474cb22df00a924 files/digest-zope-2.6.4-r1 64
MD5 c8b31c146de4f24ffcb5442630034d50 files/digest-zope-2.7.2-r2 62
MD5 ae93e53addb8b829a0c097a3b3d9ddf4 files/digest-zope-2.7.1 60
+MD5 5bed447c71046c9266eb31ec4781b314 files/digest-zope-2.7.3 62
MD5 037cf91a5b4d60efe166f90210c837ed files/i18n-1.0.0.patch 8080
MD5 a18ddd3f2cdcb815cf86f4b9c4bdd6fe files/2.6.4/zope.confd 950
MD5 4d278d26bb7be7693f7213861a9d3805 files/2.6.4/zope.initd 3791
@@ -14,3 +16,5 @@ MD5 8eed6ba044039a495f48e42555ee0893 files/2.7.1/zope.initd 1030
MD5 68ed65ed913618858b8c3e298fbdf5a7 files/2.7.1/zdctl.patch 570
MD5 a74f0aad59406bb1afe880b5a8816ab2 files/2.7.2/zope.initd 1320
MD5 bce3b7d98963ff6f3e3d53557f3b4912 files/2.7.2/gid.patch 460
+MD5 ab44d80222c234653ed4caf478ed219c files/2.7.3/zope.initd 1165
+MD5 bce3b7d98963ff6f3e3d53557f3b4912 files/2.7.3/gid.patch 460
diff --git a/net-zope/zope/files/2.7.3/gid.patch b/net-zope/zope/files/2.7.3/gid.patch
new file mode 100644
index 000000000000..bdfe2b81aa30
--- /dev/null
+++ b/net-zope/zope/files/2.7.3/gid.patch
@@ -0,0 +1,18 @@
+--- lib/Components/initgroups/initgroups.c
++++ lib/Components/initgroups/initgroups.c
+@@ -23,11 +23,14 @@
+ initgroups_initgroups(PyObject *self, PyObject *args)
+ {
+ char *username;
++ int igid;
+ gid_t gid;
+
+- if (!PyArg_ParseTuple(args, "sl:initgroups", &username, &gid))
++ if (!PyArg_ParseTuple(args, "si:initgroups", &username, &igid))
+ return NULL;
+
++ gid = igid;
++
+ if (initgroups(username, gid) == -1)
+ return PyErr_SetFromErrno(PyExc_OSError);
+
diff --git a/net-zope/zope/files/2.7.3/zope.initd b/net-zope/zope/files/2.7.3/zope.initd
new file mode 100644
index 000000000000..3df94f0e19bf
--- /dev/null
+++ b/net-zope/zope/files/2.7.3/zope.initd
@@ -0,0 +1,53 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/files/2.7.3/zope.initd,v 1.1 2004/10/25 07:27:13 batlogg Exp $
+
+opts="start stop restart kill quit status help"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Zope in INSTANCE_HOME"
+ INSTANCE_HOME/bin/zopectl start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Zope in INSTANCE_HOME"
+ INSTANCE_HOME/bin/zopectl stop
+ eend $?
+}
+
+restart() {
+ ebegin "Restarting Zope in INSTANCE_HOME"
+ INSTANCE_HOME/bin/zopectl restart
+ eend $?
+}
+
+kill() {
+ ebegin "Killing Zope in INSTANCE_HOME"
+ INSTANCE_HOME/bin/zopectl kill
+ eend $?
+}
+
+quit() {
+ ebegin "Quitting Zope Daemon Manager INSTANCE_HOME"
+ INSTANCE_HOME/bin/zopectl quit
+ eend $?
+}
+
+status() {
+ ebegin "Status of Zope in INSTANCE_HOME"
+ INSTANCE_HOME/bin/zopectl status
+ eend $?
+}
+
+help() {
+ ebegin "Help for Zope Daemon Manager in INSTANCE_HOME"
+ INSTANCE_HOME/bin/zopectl help
+ eend $?
+}
+
diff --git a/net-zope/zope/files/digest-zope-2.7.3 b/net-zope/zope/files/digest-zope-2.7.3
new file mode 100644
index 000000000000..8cba22bbfe34
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.7.3
@@ -0,0 +1 @@
+MD5 15001ab6d429dc80b1f49735e8d2ee10 Zope-2.7.3-0.tgz 2778293
diff --git a/net-zope/zope/zope-2.7.3.ebuild b/net-zope/zope/zope-2.7.3.ebuild
new file mode 100644
index 000000000000..5b0e804a397b
--- /dev/null
+++ b/net-zope/zope/zope-2.7.3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.7.3.ebuild,v 1.1 2004/10/25 07:27:13 batlogg Exp $
+
+inherit eutils
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites."
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-0.tgz"
+LICENSE="ZPL"
+SLOT="${PV}"
+
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+IUSE="unicode"
+
+RDEPEND="=dev-lang/python-2.3*"
+python='python2.3'
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-0"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/lib
+ZSERVDIR=${ZS_DIR}/${PN}-${PV}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use amd64 \
+ && epatch ${FILESDIR}/2.7.3/gid.patch
+}
+
+src_compile() {
+ ./configure --ignore-largefile --prefix=. || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc doc/*.txt
+ docinto PLATFORMS ; dodoc doc/PLATFORMS/*
+
+ # Patched StructuredText will accept source text formatted in utf-8 encoding,
+ # apply all formattings and output utf-8 encoded text.
+ # if you want to use this option you need to set your
+ # system python encoding to utf-8 (create the file sitecustomize.py inside
+ # your site-packages, add the following lines
+ # import sys
+ # sys.setdefaultencoding('utf-8')
+ # If this is a problem, let me know right away. --batlogg@gentoo.org
+ # I wondering if we need a USE flag for this and wheter we can set the
+ # sys.encoding automtically
+ # so i defined a use flag
+
+ if use unicode; then
+ einfo "Patching structured text"
+ einfo "make sure you have set the system python encoding to utf-8"
+ einfo "create the file sitecustomize.py inside your site-packages"
+ einfo "import sys"
+ einfo "sys.setdefaultencoding('utf8')"
+ cd ${S}/lib/python/StructuredText/
+ epatch ${FILESDIR}/i18n-1.0.0.patch
+ cd ${S}
+ fi
+
+ make install PREFIX=${D}${ZSERVDIR}
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+ # copy the init script skeleton to skel directory of our installation
+ skel=${D}${ZSERVDIR}/skel
+ cp ${FILESDIR}/${PV}/zope.initd ${skel}/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 /bin/false /var/lib/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+
+ rm ${ZSERVDIR}/bin/python
+}
+