summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-02 11:22:26 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-02 11:22:26 +0000
commitd06e7802b88503450b66f73e4c9f0cc88edaaa54 (patch)
tree372b76ec75015f034efcf04c51f13f34f92e3584 /sci-astronomy/galaxy
parentNew maintainer: Igor Testen. Version bump. (diff)
downloadgentoo-2-d06e7802b88503450b66f73e4c9f0cc88edaaa54.tar.gz
gentoo-2-d06e7802b88503450b66f73e4c9f0cc88edaaa54.tar.bz2
gentoo-2-d06e7802b88503450b66f73e4c9f0cc88edaaa54.zip
Adding new version that works only with gtk+:3
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/galaxy')
-rw-r--r--sci-astronomy/galaxy/ChangeLog9
-rw-r--r--sci-astronomy/galaxy/galaxy-2.1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/sci-astronomy/galaxy/ChangeLog b/sci-astronomy/galaxy/ChangeLog
index b788c444a67f..6b064dcc6a4a 100644
--- a/sci-astronomy/galaxy/ChangeLog
+++ b/sci-astronomy/galaxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/galaxy
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/ChangeLog,v 1.5 2011/12/28 12:21:18 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/ChangeLog,v 1.6 2012/02/02 11:22:26 xarthisius Exp $
+
+*galaxy-2.1 (02 Feb 2012)
+
+ 02 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> +galaxy-2.1.ebuild:
+ Adding new version that works only with gtk+:3
28 Dec 2011; Kacper Kowalik <xarthisius@gentoo.org> galaxy-2.0.ebuild:
Fix deps, use fdo-mime for desktop update
diff --git a/sci-astronomy/galaxy/galaxy-2.1.ebuild b/sci-astronomy/galaxy/galaxy-2.1.ebuild
new file mode 100644
index 000000000000..1a5c1c658422
--- /dev/null
+++ b/sci-astronomy/galaxy/galaxy-2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/galaxy-2.1.ebuild,v 1.1 2012/02/02 11:22:26 xarthisius Exp $
+
+EAPI=4
+
+inherit fdo-mime toolchain-funcs
+
+DESCRIPTION="stellar simulation program"
+HOMEPAGE="http://kornelix.squarespace.com/galaxy/"
+SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/gtk+:3"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils"
+
+pkg_setup() {
+ tc-export CXX
+}
+
+src_prepare() {
+ sed -e '/DOCDIR/ s/PROGRAM)/&-\$(VERSION)/g' \
+ -e '/xdg-desktop-menu/d' \
+ -i Makefile || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}