summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-05-05 08:00:05 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-05-05 08:00:05 +0000
commitebc13a60e0db9b8f9ffe850a4aa6ebc3eaad9f4c (patch)
treeb8a4030e09f7e88a25ddcc716a046cf5f9b0df01 /sci-biology/mira
parentversion bump (diff)
downloadgentoo-2-ebc13a60e0db9b8f9ffe850a4aa6ebc3eaad9f4c.tar.gz
gentoo-2-ebc13a60e0db9b8f9ffe850a4aa6ebc3eaad9f4c.tar.bz2
gentoo-2-ebc13a60e0db9b8f9ffe850a4aa6ebc3eaad9f4c.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/mira')
-rw-r--r--sci-biology/mira/ChangeLog7
-rw-r--r--sci-biology/mira/mira-3.0.5.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sci-biology/mira/ChangeLog b/sci-biology/mira/ChangeLog
index 5d66fdb70cc9..294e9c88c85b 100644
--- a/sci-biology/mira/ChangeLog
+++ b/sci-biology/mira/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/mira
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.7 2010/03/18 15:32:24 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.8 2010/05/05 08:00:05 weaver Exp $
+
+*mira-3.0.5 (05 May 2010)
+
+ 05 May 2010; Andrey Kislyuk <weaver@gentoo.org> +mira-3.0.5.ebuild:
+ Version bump
*mira-3.0.3 (18 Mar 2010)
diff --git a/sci-biology/mira/mira-3.0.5.ebuild b/sci-biology/mira/mira-3.0.5.ebuild
new file mode 100644
index 000000000000..00d6e0a564f6
--- /dev/null
+++ b/sci-biology/mira/mira-3.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.5.ebuild,v 1.1 2010/05/05 08:00:05 weaver Exp $
+
+EAPI="2"
+
+MIRA_3RDPARTY_PV="17-04-2010"
+
+inherit base autotools
+
+DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
+HOMEPAGE="http://www.chevreux.org/projects_mira.html"
+SRC_URI="mirror://sourceforge/mira-assembler/${P}.tar.bz2
+ mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND=">=dev-libs/boost-1.35.0"
+DEPEND="${CDEPEND}
+ dev-libs/expat
+ doc? ( >=app-text/texlive-core-2009 )"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
+ epatch "${FILESDIR}"/${PN}-3.0.0-asneeded.patch
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_compile() {
+ base_src_compile
+ if use doc; then emake -C doc clean docs || die; fi
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS GETTING_STARTED NEWS README* HELP_WANTED THANKS INSTALL
+ find doc/docs/man -type f | xargs doman
+ find doc/docs/texinfo -type f | xargs doinfo
+ dobin "${WORKDIR}"/3rdparty/{sff_extract,qual2ball,*.pl}
+}