summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-24 16:47:47 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-24 16:47:47 +0000
commit58c8ccade9239c3e95930df386eec8407f597cfe (patch)
tree87ccf6a432e8c81711cf777ac255a85f80e313c8 /sci-biology/seqan
parentinitial commit (diff)
downloadgentoo-2-58c8ccade9239c3e95930df386eec8407f597cfe.tar.gz
gentoo-2-58c8ccade9239c3e95930df386eec8407f597cfe.tar.bz2
gentoo-2-58c8ccade9239c3e95930df386eec8407f597cfe.zip
Version Bump, #540692
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/seqan')
-rw-r--r--sci-biology/seqan/ChangeLog8
-rw-r--r--sci-biology/seqan/files/seqan-2.0.0-zlib.patch15
-rw-r--r--sci-biology/seqan/seqan-2.0.0.ebuild51
3 files changed, 73 insertions, 1 deletions
diff --git a/sci-biology/seqan/ChangeLog b/sci-biology/seqan/ChangeLog
index 8061f95ad69e..deae422eb74f 100644
--- a/sci-biology/seqan/ChangeLog
+++ b/sci-biology/seqan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/seqan
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/ChangeLog,v 1.8 2015/02/19 22:03:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/ChangeLog,v 1.9 2015/02/24 16:47:47 jlec Exp $
+
+*seqan-2.0.0 (24 Feb 2015)
+
+ 24 Feb 2015; Justin Lecher <jlec@gentoo.org> +files/seqan-2.0.0-zlib.patch,
+ +seqan-2.0.0.ebuild:
+ Version Bump, #540692
19 Feb 2015; Justin Lecher <jlec@gentoo.org> seqan-1.4.2.ebuild:
Prefix love, #540690; thanks Michael Schubert for the patch
diff --git a/sci-biology/seqan/files/seqan-2.0.0-zlib.patch b/sci-biology/seqan/files/seqan-2.0.0-zlib.patch
new file mode 100644
index 000000000000..de14e9d58b8e
--- /dev/null
+++ b/sci-biology/seqan/files/seqan-2.0.0-zlib.patch
@@ -0,0 +1,15 @@
+ include/seqan/stream/zipstream/zutil.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/seqan/stream/zipstream/zutil.h b/include/seqan/stream/zipstream/zutil.h
+index 2806344..f8b41e6 100644
+--- a/include/seqan/stream/zipstream/zutil.h
++++ b/include/seqan/stream/zipstream/zutil.h
+@@ -152,6 +152,7 @@ extern const char *z_errmsg[10]; /* indexed by 2-zlib_error */
+
+ /* functions */
+
++#define OF(x) x
+ #ifdef HAVE_STRERROR
+ extern char *strerror OF((int));
+ # define zstrerror(errnum) strerror(errnum)
diff --git a/sci-biology/seqan/seqan-2.0.0.ebuild b/sci-biology/seqan/seqan-2.0.0.ebuild
new file mode 100644
index 000000000000..9ad67243c17f
--- /dev/null
+++ b/sci-biology/seqan/seqan-2.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/seqan-2.0.0.ebuild,v 1.1 2015/02/24 16:47:47 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils flag-o-matic python-single-r1
+
+DESCRIPTION="C++ Sequence Analysis Library"
+HOMEPAGE="http://www.seqan.de/"
+SRC_URI="http://packages.${PN}.de/${PN}-src/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_sse4_1"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} cpu_flags_x86_sse4_1"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/boost:=
+ sci-biology/samtools"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-${PN}-v${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-zlib.patch
+)
+
+src_prepare() {
+ rm -f \
+ util/cmake/FindZLIB.cmake \
+ || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBoost_NO_BOOST_CMAKE=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ mkdir -p "${BUILD_DIR}"/docs/html || die
+ cmake-utils_src_install
+ chmod 755 "${ED}"/usr/bin/*sh || die
+}