summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-02-08 10:03:50 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-02-08 10:03:50 +0000
commiteb8076f489966c263c7b1020578d908cb12920e4 (patch)
tree9b2d3678d62873647e02275df0ff248924234887 /sci-biology
parentVersion bump, closing bug 500650. (diff)
downloadgentoo-2-eb8076f489966c263c7b1020578d908cb12920e4.tar.gz
gentoo-2-eb8076f489966c263c7b1020578d908cb12920e4.tar.bz2
gentoo-2-eb8076f489966c263c7b1020578d908cb12920e4.zip
Dropped unneeded patch files and dropped unneeded dependencies (bug #500488 and #239161)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/readseq/ChangeLog14
-rw-r--r--sci-biology/readseq/files/19930201-buffer.patch13
-rw-r--r--sci-biology/readseq/files/19930201-getline.patch260
-rw-r--r--sci-biology/readseq/files/19930201-impl-dec.patch24
-rw-r--r--sci-biology/readseq/files/19930201-ldflags.patch13
-rw-r--r--sci-biology/readseq/files/20080420-no-bundling.patch14
-rw-r--r--sci-biology/readseq/readseq-20080420-r1.ebuild (renamed from sci-biology/readseq/readseq-20080420.ebuild)26
7 files changed, 35 insertions, 329 deletions
diff --git a/sci-biology/readseq/ChangeLog b/sci-biology/readseq/ChangeLog
index 748097ff38db..bb09b77767d3 100644
--- a/sci-biology/readseq/ChangeLog
+++ b/sci-biology/readseq/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-biology/readseq
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/readseq/ChangeLog,v 1.10 2013/02/01 14:55:17 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/readseq/ChangeLog,v 1.11 2014/02/08 10:03:50 ercpe Exp $
+
+*readseq-20080420-r1 (08 Feb 2014)
+
+ 08 Feb 2014; Johann Schmitz <ercpe@gentoo.org>
+ +files/20080420-no-bundling.patch, +readseq-20080420-r1.ebuild,
+ -files/19930201-buffer.patch, -files/19930201-getline.patch,
+ -files/19930201-impl-dec.patch, -files/19930201-ldflags.patch,
+ -readseq-20080420.ebuild:
+ Dropped unneeded patch files and dropped unneeded dependencies (bug #500488
+ and #239161)
01 Feb 2013; Justin Lecher <jlec@gentoo.org> -readseq-19930201.ebuild,
-readseq-19930201-r1.ebuild, readseq-20080420.ebuild, metadata.xml:
diff --git a/sci-biology/readseq/files/19930201-buffer.patch b/sci-biology/readseq/files/19930201-buffer.patch
deleted file mode 100644
index 8229074dbbc3..000000000000
--- a/sci-biology/readseq/files/19930201-buffer.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/ureadseq.c b/ureadseq.c
-index 337b16f..3f8e7f6 100644
---- a/ureadseq.c
-+++ b/ureadseq.c
-@@ -1578,7 +1578,7 @@ short writeSeq(FILE *outf, const char *seq, const long seqlen,
-
- short linesout = 0, seqtype = kNucleic;
- long i, j, l, l1, ibase;
-- char idword[31], endstr[10];
-+ char idword[31], endstr[32];
- char seqnamestore[128], *seqname = seqnamestore;
- char s[kMaxseqwidth], *cp;
- char nameform[10], numform[10], nocountsymbols[10];
diff --git a/sci-biology/readseq/files/19930201-getline.patch b/sci-biology/readseq/files/19930201-getline.patch
deleted file mode 100644
index 34f6339209de..000000000000
--- a/sci-biology/readseq/files/19930201-getline.patch
+++ /dev/null
@@ -1,260 +0,0 @@
-diff --git a/ureadseq.c b/ureadseq.c
-index b11115d..337b16f 100644
---- a/ureadseq.c
-+++ b/ureadseq.c
-@@ -136,7 +136,7 @@ Local void readline(FILE *f, char *s, long *linestart)
- }
- }
-
--Local void getline(struct ReadSeqVars *V)
-+Local void ghettoline(struct ReadSeqVars *V)
- {
- readline(V->f, V->s, &V->linestart);
- }
-@@ -215,7 +215,7 @@ Local void readLoop(short margin, boolean addfirst,
-
- if (addfirst) addseq(V->s, V);
- do {
-- getline(V);
-+ ghettoline(V);
- V->done = feof(V->f);
- V->done |= (*endTest)( &addend, &ungetend, V);
- if (V->addit && (addend || !V->done) && (strlen(V->s) > margin)) {
-@@ -246,7 +246,7 @@ Local void readIG(struct ReadSeqVars *V)
-
- while (!V->allDone) {
- do {
-- getline(V);
-+ ghettoline(V);
- for (si= V->s; *si != 0 && *si < ' '; si++) *si= ' '; /* drop controls */
- if (*si == 0) *V->s= 0; /* chop line to empty */
- } while (! (feof(V->f) || ((*V->s != 0) && (*V->s != ';') ) ));
-@@ -272,13 +272,13 @@ Local void readStrider(struct ReadSeqVars *V)
- { /* ? only 1 seq/file ? */
-
- while (!V->allDone) {
-- getline(V);
-+ ghettoline(V);
- if (strstr(V->s,"; DNA sequence ") == V->s)
- strcpy(V->seqid, (V->s)+16);
- else
- strcpy(V->seqid, (V->s)+1);
- while ((!feof(V->f)) && (*V->s == ';')) {
-- getline(V);
-+ ghettoline(V);
- }
- if (feof(V->f)) V->allDone = true;
- else readLoop(0, true, endStrider, V);
-@@ -298,16 +298,16 @@ Local void readPIR(struct ReadSeqVars *V)
-
- while (!V->allDone) {
- while (! (feof(V->f) || strstr(V->s,"ENTRY") || strstr(V->s,"SEQUENCE")) )
-- getline(V);
-+ ghettoline(V);
- strcpy(V->seqid, (V->s)+16);
- while (! (feof(V->f) || strstr(V->s,"SEQUENCE") == V->s))
-- getline(V);
-+ ghettoline(V);
- readLoop(0, false, endPIR, V);
-
- if (!V->allDone) {
- while (! (feof(V->f) || ((*V->s != 0)
- && (strstr( V->s,"ENTRY") == V->s))))
-- getline(V);
-+ ghettoline(V);
- }
- if (feof(V->f)) V->allDone = true;
- }
-@@ -327,13 +327,13 @@ Local void readGenBank(struct ReadSeqVars *V)
- while (!V->allDone) {
- strcpy(V->seqid, (V->s)+12);
- while (! (feof(V->f) || strstr(V->s,"ORIGIN") == V->s))
-- getline(V);
-+ ghettoline(V);
- readLoop(0, false, endGB, V);
-
- if (!V->allDone) {
- while (! (feof(V->f) || ((*V->s != 0)
- && (strstr( V->s,"LOCUS") == V->s))))
-- getline(V);
-+ ghettoline(V);
- }
- if (feof(V->f)) V->allDone = true;
- }
-@@ -364,11 +364,11 @@ Local void readNBRF(struct ReadSeqVars *V)
- {
- while (!V->allDone) {
- strcpy(V->seqid, (V->s)+4);
-- getline(V); /*skip title-junk line*/
-+ ghettoline(V); /*skip title-junk line*/
- readLoop(0, false, endNBRF, V);
- if (!V->allDone) {
- while (!(feof(V->f) || (*V->s != 0 && *V->s == '>')))
-- getline(V);
-+ ghettoline(V);
- }
- if (feof(V->f)) V->allDone = true;
- }
-@@ -390,7 +390,7 @@ Local void readPearson(struct ReadSeqVars *V)
- readLoop(0, false, endPearson, V);
- if (!V->allDone) {
- while (!(feof(V->f) || ((*V->s != 0) && (*V->s == '>'))))
-- getline(V);
-+ ghettoline(V);
- }
- if (feof(V->f)) V->allDone = true;
- }
-@@ -410,14 +410,14 @@ Local void readEMBL(struct ReadSeqVars *V)
- while (!V->allDone) {
- strcpy(V->seqid, (V->s)+5);
- do {
-- getline(V);
-+ ghettoline(V);
- } while (!(feof(V->f) | (strstr(V->s,"SQ ") == V->s)));
-
- readLoop(0, false, endEMBL, V);
- if (!V->allDone) {
- while (!(feof(V->f) |
- ((*V->s != '\0') & (strstr(V->s,"ID ") == V->s))))
-- getline(V);
-+ ghettoline(V);
- }
- if (feof(V->f)) V->allDone = true;
- }
-@@ -437,13 +437,13 @@ Local void readZuker(struct ReadSeqVars *V)
- /*! 1st string is Zuker's Fortran format */
-
- while (!V->allDone) {
-- getline(V); /*s == "seqLen seqid string..."*/
-+ ghettoline(V); /*s == "seqLen seqid string..."*/
- strcpy(V->seqid, (V->s)+6);
- readLoop(0, false, endZuker, V);
- if (!V->allDone) {
- while (!(feof(V->f) |
- ((*V->s != '\0') & (*V->s == '('))))
-- getline(V);
-+ ghettoline(V);
- }
- if (feof(V->f)) V->allDone = true;
- }
-@@ -486,7 +486,7 @@ Local void readPlain(struct ReadSeqVars *V)
- do {
- addseq(V->s, V);
- V->done = feof(V->f);
-- getline(V);
-+ ghettoline(V);
- } while (!V->done);
- if (V->choice == kListSequences) addinfo(V->seqid, V);
- V->allDone = true;
-@@ -498,7 +498,7 @@ Local void readUWGCG(struct ReadSeqVars *V)
- /*
- 10nov91: Reading GCG files casued duplication of last line when
- EOF followed that line !!!
-- fix: getline now sets *V->s = 0
-+ fix: ghettoline now sets *V->s = 0
- */
- char *si;
-
-@@ -512,7 +512,7 @@ Local void readUWGCG(struct ReadSeqVars *V)
- else if (si = strstr(V->seqid,"..")) *si = 0;
- do {
- V->done = feof(V->f);
-- getline(V);
-+ ghettoline(V);
- if (!V->done) addseq((V->s), V);
- } while (!V->done);
- if (V->choice == kListSequences) addinfo(V->seqid, V);
-@@ -531,7 +531,7 @@ Local void readOlsen(struct ReadSeqVars *V)
- if (V->addit) V->seqlen = 0;
- rewind(V->f); V->nseq= 0;
- do {
-- getline(V);
-+ ghettoline(V);
- V->done = feof(V->f);
-
- if (V->done && !(*V->s)) break;
-@@ -614,7 +614,7 @@ Local void readMSF(struct ReadSeqVars *V)
- if (V->addit) V->seqlen = 0;
- rewind(V->f); V->nseq= 0;
- do {
-- getline(V);
-+ ghettoline(V);
- V->done = feof(V->f);
-
- if (V->done && !(*V->s)) break;
-@@ -685,7 +685,7 @@ Local void readPAUPinterleaved(struct ReadSeqVars *V)
- domatch= (V->matchchar > 0);
-
- do {
-- getline(V);
-+ ghettoline(V);
- V->done = feof(V->f);
-
- if (V->done && !(*V->s)) break;
-@@ -766,7 +766,7 @@ Local void readPAUPsequential(struct ReadSeqVars *V)
- /* rewind(V->f); V->nseq= 0; << do in caller !*/
- indata= true; /* call here after we find "matrix" */
- do {
-- getline(V);
-+ ghettoline(V);
- V->done = feof(V->f);
-
- if (V->done && !(*V->s)) break;
-@@ -851,7 +851,7 @@ Local void readPhylipInterleaved(struct ReadSeqVars *V)
- /* fprintf(stderr,"Phylip-ileaf: topnseq=%d topseqlen=%d\n",V->topnseq, V->topseqlen); */
-
- do {
-- getline(V);
-+ ghettoline(V);
- V->done = feof(V->f);
-
- if (V->done && !(*V->s)) break;
-@@ -904,7 +904,7 @@ Local void readPhylipSequential(struct ReadSeqVars *V)
- while (isdigit(*si)) si++;
- skipwhitespace(si);
- V->topseqlen= atol(si);
-- getline(V);
-+ ghettoline(V);
- while (!V->allDone) {
- V->seqlencount= 0;
- strncpy(V->seqid, (V->s), 10);
-@@ -935,10 +935,10 @@ Local void readSeqMain(
- V->err = eFileNotFound;
- else {
-
-- for (l = skiplines_; l > 0; l--) getline( V);
-+ for (l = skiplines_; l > 0; l--) ghettoline( V);
-
- do {
-- getline( V);
-+ ghettoline( V);
- for (l= strlen(V->s); (l > 0) && (V->s[l] == ' '); l--) ;
- } while ((l == 0) && !feof(V->f));
-
-@@ -963,7 +963,7 @@ Local void readSeqMain(
- char *cp;
- /* rewind(V->f); V->nseq= 0; ?? assume it is at top ?? skiplines ... */
- while (!done) {
-- getline( V);
-+ ghettoline( V);
- tolowerstr( V->s);
- if (strstr( V->s, "matrix")) done= true;
- if (strstr( V->s, "interleav")) interleaved= true;
-@@ -995,7 +995,7 @@ Local void readSeqMain(
- break;
-
- case kFitch :
-- strcpy(V->seqid, V->s); getline(V);
-+ strcpy(V->seqid, V->s); ghettoline(V);
- readFitch(V);
- break;
-
-@@ -1003,7 +1003,7 @@ Local void readSeqMain(
- do {
- gotuw = (strstr(V->s,"..") != NULL);
- if (gotuw) readUWGCG(V);
-- getline(V);
-+ ghettoline(V);
- } while (!(feof(V->f) || V->allDone));
- break;
- }
diff --git a/sci-biology/readseq/files/19930201-impl-dec.patch b/sci-biology/readseq/files/19930201-impl-dec.patch
deleted file mode 100644
index 8e9448224e2c..000000000000
--- a/sci-biology/readseq/files/19930201-impl-dec.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/readseq.c b/readseq.c
-index 305d23a..9b02a17 100644
---- a/readseq.c
-+++ b/readseq.c
-@@ -171,6 +171,7 @@ link -w -o readseq -t MPST -c 'MPS ' 
- #include <stdio.h>
- #include <string.h>
- #include <ctype.h>
-+#include <stdlib.h>
-
- #include "ureadseq.h"
-
-diff --git a/ureadseq.c b/ureadseq.c
-index 3f8e7f6..799b315 100644
---- a/ureadseq.c
-+++ b/ureadseq.c
-@@ -20,6 +20,7 @@
- #include <stdio.h>
- #include <ctype.h>
- #include <string.h>
-+#include <stdlib.h>
-
- #define UREADSEQ_G
- #include "ureadseq.h"
diff --git a/sci-biology/readseq/files/19930201-ldflags.patch b/sci-biology/readseq/files/19930201-ldflags.patch
deleted file mode 100644
index e1929c634479..000000000000
--- a/sci-biology/readseq/files/19930201-ldflags.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 40a5a92..f073aaa 100644
---- a/Makefile
-+++ b/Makefile
-@@ -40,7 +40,7 @@ all: build test
-
- build: $(SOURCES)
- @echo "Compiling readseq..."
-- $(CC) $(CFLAGS) -o readseq readseq.c ureadseq.c
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o readseq readseq.c ureadseq.c
-
- # if using NCBI, uncomment these lines in place of build: above
- #build: $(SOURCES)
diff --git a/sci-biology/readseq/files/20080420-no-bundling.patch b/sci-biology/readseq/files/20080420-no-bundling.patch
new file mode 100644
index 000000000000..f2e1708f8821
--- /dev/null
+++ b/sci-biology/readseq/files/20080420-no-bundling.patch
@@ -0,0 +1,14 @@
+diff --git a/build.xml b/build.xml
+index e3d723c..4b44d6f 100644
+--- a/build.xml
++++ b/build.xml
+@@ -229,9 +229,6 @@
+
+ <!-- for now, unjar xml classes into build/classes and rejar in readseq.jar -->
+
+- <unjar overwrite="false" src="${orgxml.jar}" dest="${build.home}/classes" />
+- <unjar overwrite="false" src="${xml.jar}" dest="${build.home}/classes" />
+-
+ <!-- <copy todir="${build.home}/classes""> -->
+ <!-- <src dir="${basedir}/META-INF"/> -->
+ <!-- </copy> -->
diff --git a/sci-biology/readseq/readseq-20080420.ebuild b/sci-biology/readseq/readseq-20080420-r1.ebuild
index 173fc172da18..442e15c71396 100644
--- a/sci-biology/readseq/readseq-20080420.ebuild
+++ b/sci-biology/readseq/readseq-20080420-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/readseq/readseq-20080420.ebuild,v 1.4 2013/02/01 14:55:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/readseq/readseq-20080420-r1.ebuild,v 1.1 2014/02/08 10:03:50 ercpe Exp $
-EAPI=1
+EAPI=5
inherit java-pkg-2 java-ant-2
@@ -13,34 +13,26 @@ HOMEPAGE="http://iubio.bio.indiana.edu/soft/molbio/readseq/"
# http://iubio.bio.indiana.edu/soft/molbio/readseq/java/readseq-source.zip.
# Renamed to the date of the modification and mirrored
SRC_URI="http://dev.gentoo.org/~dberkholz/distfiles/${MY_P}.zip"
-#SRC_URI="mirror://gentoo/${MY_P}.zip"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-COMMON="
- dev-java/jaxp
- dev-java/xerces:2"
-RDEPEND="${COMMON}
- !=sci-biology/meme-4.8.1
+RDEPEND="!=sci-biology/meme-4.8.1
>=virtual/jre-1.4"
-DEPEND="${COMMON}
- >=virtual/jdk-1.4
+DEPEND=">=virtual/jdk-1.4
app-arch/unzip"
+
S=${WORKDIR}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- java-pkg_jar-from xerces-2 xercesImpl.jar lib/ibm-xml4j-min.jar
- java-pkg_jar-from jaxp jaxp-ri.jar lib/orgxml.jar
+java_prepare() {
+ rm "${S}"/lib/* || die
+ epatch "${FILESDIR}"/${PV}-*
}
src_install() {
java-pkg_dojar build/readseq.jar
-
java-pkg_dolauncher
}