summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-26 08:37:31 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-26 08:37:31 +0000
commit3a40f27c57a7f2c5de40d4445e3c9d7647c7467a (patch)
tree2bfba12e75b5f0fb551b335d06b48d23fec94800 /sci-libs/starparse
parentdev-scheme/guile-cairo: Version Bump (diff)
downloadgentoo-2-3a40f27c57a7f2c5de40d4445e3c9d7647c7467a.tar.gz
gentoo-2-3a40f27c57a7f2c5de40d4445e3c9d7647c7467a.tar.bz2
gentoo-2-3a40f27c57a7f2c5de40d4445e3c9d7647c7467a.zip
sci-libs/starparse: Bump EAPI to4, use autotools-utils.eclass, handle static-libs
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/starparse')
-rw-r--r--sci-libs/starparse/ChangeLog5
-rw-r--r--sci-libs/starparse/starparse-1.0-r1.ebuild24
2 files changed, 14 insertions, 15 deletions
diff --git a/sci-libs/starparse/ChangeLog b/sci-libs/starparse/ChangeLog
index f85c31c6d76a..e3fb7ac97428 100644
--- a/sci-libs/starparse/ChangeLog
+++ b/sci-libs/starparse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/starparse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/starparse/ChangeLog,v 1.6 2012/05/04 08:22:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/starparse/ChangeLog,v 1.7 2012/07/26 08:37:31 jlec Exp $
+
+ 26 Jul 2012; Justin Lecher <jlec@gentoo.org> starparse-1.0-r1.ebuild:
+ Bump EAPI to4, use autotools-utils.eclass, handle static-libs
04 May 2012; Jeff Horelick <jdhore@gentoo.org> starparse-1.0-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-libs/starparse/starparse-1.0-r1.ebuild b/sci-libs/starparse/starparse-1.0-r1.ebuild
index 9d0ad50ffd94..5d949f94c21e 100644
--- a/sci-libs/starparse/starparse-1.0-r1.ebuild
+++ b/sci-libs/starparse/starparse-1.0-r1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/starparse/starparse-1.0-r1.ebuild,v 1.2 2012/05/04 08:22:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/starparse/starparse-1.0-r1.ebuild,v 1.3 2012/07/26 08:37:31 jlec Exp $
-EAPI="2"
+EAPI=4
-inherit autotools eutils
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
HOMEPAGE="http://burrow-owl.sourceforge.net/"
@@ -15,28 +17,22 @@ SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="guile"
+IUSE="guile static-libs"
RDEPEND="guile? ( dev-scheme/guile )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-guile1.8.patch
- eautoreconf
-}
+PATCHES=( "${FILESDIR}"/${P}-guile1.8.patch )
src_configure() {
- econf $(use_enable guile)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ local myeconfargs=( $(use_enable guile) )
+ autotools-utils_src_configure
}
src_test() {
if use guile; then
- emake check || die
+ autotools-utils_src_test
else
ewarn "Skipping tests because USE guile is disabled"
fi