summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-02-10 16:59:02 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-02-10 16:59:02 +0000
commit195367b204561cdc736d18710f3361b39e6d1fc7 (patch)
tree5a377e463a7c42ed201118d4f0532e53f260e075 /sci-mathematics/genius
parentUpdate poppler dependency for #304319. (diff)
downloadgentoo-2-195367b204561cdc736d18710f3361b39e6d1fc7.tar.gz
gentoo-2-195367b204561cdc736d18710f3361b39e6d1fc7.tar.bz2
gentoo-2-195367b204561cdc736d18710f3361b39e6d1fc7.zip
Initial import, thanks to Joe Sapp <nixphoeni@gentoo.org>, closing bug #61143
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/genius')
-rw-r--r--sci-mathematics/genius/ChangeLog11
-rw-r--r--sci-mathematics/genius/genius-1.0.9.ebuild50
-rw-r--r--sci-mathematics/genius/metadata.xml19
3 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/genius/ChangeLog b/sci-mathematics/genius/ChangeLog
new file mode 100644
index 000000000000..48ac07a3bc24
--- /dev/null
+++ b/sci-mathematics/genius/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/genius
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.1 2010/02/10 16:59:02 grozin Exp $
+
+*genius-1.0.9 (10 Feb 2010)
+
+ 10 Feb 2010; Andrey Grozin <grozin@gentoo.org> +genius-1.0.9.ebuild,
+ +metadata.xml:
+ Initial import, thanks to Joe Sapp <nixphoeni@gentoo.org>, closing bug
+ #61143
+
diff --git a/sci-mathematics/genius/genius-1.0.9.ebuild b/sci-mathematics/genius/genius-1.0.9.ebuild
new file mode 100644
index 000000000000..12533aff70e6
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.9.ebuild,v 1.1 2010/02/10 16:59:02 grozin Exp $
+
+EAPI=2
+inherit gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="http://www.jirka.org/${PN}.html"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc gnome nls"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/${PN}/1.0/${P}.tar.bz2
+ doc? ( http://www.jirka.org/${PN}-reference.pdf )"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/mpfr
+ dev-libs/popt
+ sys-libs/ncurses
+ sys-libs/readline
+ gnome? ( x11-libs/gtk+:2
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libglade
+ x11-libs/gtksourceview
+ x11-libs/vte )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ || ( sys-devel/bison
+ dev-util/yacc )
+ sys-devel/flex
+ app-text/scrollkeeper
+ nls? ( sys-devel/gettext )"
+
+G2CONF="${G2CONF} $(use_enable gnome) $(use_enable nls) \
+ --disable-update-mimedb --disable-scrollkeeper \
+ --disable-extra-gcc-optimization"
+GCONF_DEBUG="no"
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+USE_DESTDIR="1"
+
+src_install() {
+ gnome2_src_install
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-reference.pdf
+ fi
+}
diff --git a/sci-mathematics/genius/metadata.xml b/sci-mathematics/genius/metadata.xml
new file mode 100644
index 000000000000..cbdd7f0a35a2
--- /dev/null
+++ b/sci-mathematics/genius/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Genius is a calculator program which can work
+ with arbitrary precision integers, multiple precision floats,
+ rational numbers, complex numbers, linear algebra, number theory,
+ numerical calculus, statistics, numerical equation solving,
+ combinatorics, elementary functions, modular arithmetic.
+ It has a programming language with automatic typing.
+ It can do various 2D and 3D plots, with possibility
+ to export to eps or png. Genius has a GUI IDE.
+ It can output matrices in LaTeX, Troff (eqn) or MathML.
+ </longdescription>
+</pkgmetadata>