summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-04-03 15:09:07 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-04-03 15:09:07 +0000
commit7f450635428b6b5e63553c0cd1e9fc34f7b8bb35 (patch)
treeed822707816ec58c58b7b8a52479c745769ae71a /sci-mathematics/pari/pari-2.1.6.ebuild
parentFixed ebuild requires X connection. Bug 66030. (diff)
downloadgentoo-2-7f450635428b6b5e63553c0cd1e9fc34f7b8bb35.tar.gz
gentoo-2-7f450635428b6b5e63553c0cd1e9fc34f7b8bb35.tar.bz2
gentoo-2-7f450635428b6b5e63553c0cd1e9fc34f7b8bb35.zip
Fixed toolchaun usage.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-mathematics/pari/pari-2.1.6.ebuild')
-rw-r--r--sci-mathematics/pari/pari-2.1.6.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-mathematics/pari/pari-2.1.6.ebuild b/sci-mathematics/pari/pari-2.1.6.ebuild
index 01b6ff2d296b..d03e2250ff4d 100644
--- a/sci-mathematics/pari/pari-2.1.6.ebuild
+++ b/sci-mathematics/pari/pari-2.1.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.4 2005/04/03 12:40:00 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.5 2005/04/03 15:09:07 kugelfang Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
HOMEPAGE="http://pari.math.u-bordeaux.fr/"
@@ -23,11 +23,14 @@ src_unpack() {
}
src_compile() {
+ # Fix usage of toolchain
+ tc-getAS; tc-getLD; tc-getCC; tc-getCXX
./Configure \
--host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
--prefix=/usr \
--miscdir=/usr/share/doc/${PF} \
--datadir=/usr/share/${P} \
+ --libdir=/usr/$(get_libdir) \
--mandir=/usr/share/man/man1 || die "./configure failed"
addwrite "/var/lib/texmf"
addwrite "/usr/share/texmf"
@@ -46,7 +49,14 @@ src_compile() {
use doc && emake doc
}
-src_install () {
+src_test() {
+ cd ${S}
+ ebegin "Testing pari kernel"
+ make CFLAGS="-Wl,-lpari" test-kernel > /dev/null
+ eend $?
+}
+
+src_install() {
make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || die
if use emacs; then
insinto /usr/share/emacs/site-lisp