summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-17 22:36:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-17 22:36:07 +0000
commit070e580ea7f3d551b066f5f1a0dff666bf67645f (patch)
treee6af2730f3fd23824cec2f337814528ee413edb4 /sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
parentForce ignoring of -w in MAKEOPTS #338970 by Drake Wyrm. (diff)
downloadgentoo-2-070e580ea7f3d551b066f5f1a0dff666bf67645f.tar.gz
gentoo-2-070e580ea7f3d551b066f5f1a0dff666bf67645f.tar.bz2
gentoo-2-070e580ea7f3d551b066f5f1a0dff666bf67645f.zip
moved to the main tree
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild')
-rw-r--r--sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
new file mode 100644
index 000000000000..d23c084fedaf
--- /dev/null
+++ b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild,v 1.1 2010/12/17 22:36:07 bicatali Exp $
+
+EAPI=2
+
+DESCRIPTION="Multiple independent streams of pseudo-random numbers"
+HOMEPAGE="http://statmath.wu.ac.at/software/RngStreams/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-3"
+
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ dohtml -r doc/rngstreams.html/* || die
+ doins doc/${PN}.pdf || die
+ fi
+ if use examples; then
+ emake distclean -C examples
+ rm -f examples/Makefile*
+ doins -r examples
+ fi
+}