summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-08-08 13:41:14 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-08-08 13:41:14 +0000
commit0cd1a56c34290908fed26c203fd50b0ecc8cac7e (patch)
tree9f5f30324d92f8f5cc3aca13990adcb90a82e836 /sci-mathematics
parentalpha stable (diff)
downloadgentoo-2-0cd1a56c34290908fed26c203fd50b0ecc8cac7e.tar.gz
gentoo-2-0cd1a56c34290908fed26c203fd50b0ecc8cac7e.tar.bz2
gentoo-2-0cd1a56c34290908fed26c203fd50b0ecc8cac7e.zip
Version bump (fixes bug #234155). Added patch to fix unrespected LDFLAGS.
(Portage version: 2.2_rc5/cvs/Linux 2.6.26-SENTINEL-1 i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gretl/ChangeLog9
-rw-r--r--sci-mathematics/gretl/files/gretl-1.7.6-ldflags.patch80
-rw-r--r--sci-mathematics/gretl/gretl-1.7.6.ebuild117
3 files changed, 205 insertions, 1 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index 18d40d2e414d..8b46de7d58e5 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.12 2008/08/06 20:35:56 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.13 2008/08/08 13:41:13 markusle Exp $
+
+*gretl-1.7.6 (08 Aug 2008)
+
+ 08 Aug 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/gretl-1.7.6-ldflags.patch, +gretl-1.7.6.ebuild:
+ Version bump (fixes bug #234155). Added patch to fix unrespected
+ LDFLAGS.
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-mathematics/gretl/files/gretl-1.7.6-ldflags.patch b/sci-mathematics/gretl/files/gretl-1.7.6-ldflags.patch
new file mode 100644
index 000000000000..a136b206c087
--- /dev/null
+++ b/sci-mathematics/gretl/files/gretl-1.7.6-ldflags.patch
@@ -0,0 +1,80 @@
+diff -Naur gretl-1.7.6/cli/Makefile.in gretl-1.7.6.new/cli/Makefile.in
+--- gretl-1.7.6/cli/Makefile.in 2008-03-24 08:46:11.000000000 -0400
++++ gretl-1.7.6.new/cli/Makefile.in 2008-08-08 09:18:44.000000000 -0400
+@@ -3,6 +3,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+
+@@ -51,7 +52,7 @@
+ $(CC) $(CFLAGS) -MM $< > .deps/$*.d
+
+ $(CLI): .deps $(OBJS)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS) $(GRETLLIB) $(READLINE_LIBS)
++ $(LDFLAGS) $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS) $(GRETLLIB) $(READLINE_LIBS)
+
+ .deps:
+ mkdir $@
+diff -Naur gretl-1.7.6/gui2/Makefile.in gretl-1.7.6.new/gui2/Makefile.in
+--- gretl-1.7.6/gui2/Makefile.in 2008-07-29 13:58:41.000000000 -0400
++++ gretl-1.7.6.new/gui2/Makefile.in 2008-08-08 09:17:52.000000000 -0400
+@@ -7,6 +7,7 @@
+ libdir = @libdir@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @CFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+ LN = @LN_S@
+@@ -175,7 +176,7 @@
+ $(CC) $(CFLAGS) -MM $< > .deps/$*.d
+
+ $(PROG): .deps $(OBJS) $(HACK_OBJ) $(GTKEXTRA_LITE) $(GTKSOURCEVIEW_LITE)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS) $(HACK_OBJ) $(LIBS) $(INETLIB) $(CARBONLIB)
++ $(LDFLAGS) $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS) $(HACK_OBJ) $(LIBS) $(INETLIB) $(CARBONLIB)
+
+ $(HACK_OBJ): $(HACK_SRC) $(HACK_HDR)
+ $(CC) $(CFLAGS) $(GTK_CFLAGS) -c $<
+diff -Naur gretl-1.7.6/lib/Makefile.in gretl-1.7.6.new/lib/Makefile.in
+--- gretl-1.7.6/lib/Makefile.in 2008-05-24 21:40:28.000000000 -0400
++++ gretl-1.7.6.new/lib/Makefile.in 2008-08-08 09:16:48.000000000 -0400
+@@ -6,6 +6,7 @@
+ bindir = @bindir@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+ LN = @LN_S@
+@@ -227,7 +228,7 @@
+ $(CC) $(CFLAGS) -MM -MT $*.lo $< > .deps/$*.d
+
+ $(LIBGRETL): .deps $(LOBJS) $(AUX_LOBJ)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(LOBJS) $(AUX_LOBJ) \
++ $(LDFLAGS) $(LIBTOOL) --mode=link $(CC) -o $@ $(LOBJS) $(AUX_LOBJ) \
+ -rpath $(prefix)/lib $(LIBS) \
+ -version-info $(CURRENT):$(REVISION):$(AGE)
+
+diff -Naur gretl-1.7.6/plugin/Makefile.in gretl-1.7.6.new/plugin/Makefile.in
+--- gretl-1.7.6/plugin/Makefile.in 2008-05-26 12:47:52.000000000 -0400
++++ gretl-1.7.6.new/plugin/Makefile.in 2008-08-08 09:13:25.000000000 -0400
+@@ -7,6 +7,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+ LN = @LN_S@
+@@ -47,7 +48,7 @@
+
+ LIBTOOL = ../libtool
+ COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
+-LINK = $(LIBTOOL) --mode=link $(CC) -module -avoid-version -rpath $(plugindir)
++LINK = $(LDFLAGS) $(LIBTOOL) --mode=link $(CC) -module -avoid-version -rpath $(plugindir)
+
+ GRETLINC = -I$(topsrc)/lib/src
+ GRETLLIB = ../lib/libgretl-1.0.la
diff --git a/sci-mathematics/gretl/gretl-1.7.6.ebuild b/sci-mathematics/gretl/gretl-1.7.6.ebuild
new file mode 100644
index 000000000000..0439a47be0f9
--- /dev/null
+++ b/sci-mathematics/gretl/gretl-1.7.6.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.7.6.ebuild,v 1.1 2008/08/08 13:41:13 markusle Exp $
+
+USE_EINSTALL=true
+EAPI=1
+inherit eutils gnome2 elisp-common
+
+DESCRIPTION="Regression, econometrics and time-series library"
+HOMEPAGE="http://gretl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="accessibility emacs gmp gnome gtk nls odbc readline sourceview"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/glib:2
+ sci-visualization/gnuplot
+ virtual/lapack
+ virtual/latex-base
+ sci-libs/fftw:3.0
+ dev-libs/mpfr
+ readline? ( sys-libs/readline )
+ gmp? ( dev-libs/gmp )
+ accessibility? ( app-accessibility/flite )
+ gtk? ( >=x11-libs/gtk+-2.10:2 )
+ gnome? ( gnome-base/libgnomeui
+ gnome-base/libgnomeprint:2.2
+ gnome-base/libgnomeprintui:2.2
+ gnome-base/gconf:2 )
+ sourceview? ( x11-libs/gtksourceview )
+ odbc? ( dev-db/unixODBC )
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+SITEFILE=50${PN}-gentoo.el
+
+pkg_setup() {
+ if use gtk && ! built_with_use sci-visualization/gnuplot gd; then
+ eerror "gretl gtk GUI needs gnuplot with gd and gd with png"
+ die "Please install gnuplot with gd and png use flags enabled"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.7.5-locale.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+
+ local myconf
+ if use gtk; then
+ myconf="--enable-gui"
+ myconf="${myconf} $(use_with sourceview gtksourceview)"
+ myconf="${myconf} $(use_with gnome)"
+ else
+ myconf="--disable-gui --without-gnome --without-gtksourceview"
+ fi
+
+ econf \
+ --with-mpfr \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_with gmp) \
+ $(use_with odbc) \
+ $(use_with accessibility audio) \
+ ${myconf} \
+ LAPACK_LIBS="$(pkg-config --libs lapack)" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+ if use emacs; then
+ elisp-compile utils/emacs/gretl.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ if use gnome; then
+ gnome2_src_install gnome_prefix="${D}"/usr
+ else
+ einstall || die "einstall failed"
+ fi
+ if use gtk && ! use gnome; then
+ doicon gnome/gretl.png
+ make_desktop_entry gretlx11 gretl
+ fi
+ if use emacs; then
+ elisp-install ${PN} utils/emacs/gretl.{el,elc} \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+ dodoc README README.audio ChangeLog CompatLog TODO \
+ || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "To begin using gretl-mode for all \".inp\" files that you edit,"
+ elog "add the following line to your \"~/.emacs\" file:"
+ elog " (add-to-list 'auto-mode-alist '(\"\\\\.inp\\\\'\" . gretl-mode))"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}