summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-07-15 20:31:13 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-07-15 20:31:13 +0000
commit3e78b05ebadce0cd47a1bc5a568932d983b3bf74 (patch)
treef336e0cc6fa2f731b36a509686a41cce26897a1f /sci-misc
parentglibc-2.4 profile for sh (diff)
downloadgentoo-2-3e78b05ebadce0cd47a1bc5a568932d983b3bf74.tar.gz
gentoo-2-3e78b05ebadce0cd47a1bc5a568932d983b3bf74.tar.bz2
gentoo-2-3e78b05ebadce0cd47a1bc5a568932d983b3bf74.zip
Added unicode USE flag, should fix bug 135306.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog6
-rw-r--r--sci-misc/boinc/boinc-5.2.14.ebuild5
-rw-r--r--sci-misc/boinc/boinc-5.5.6.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 7ab95725f1a4..18d7b88d34d6 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.23 2006/07/11 12:06:04 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.24 2006/07/15 20:31:13 cryos Exp $
+
+ 15 Jul 2006; Marcus D. Hanwell <cryos@gentoo.org> boinc-5.2.14.ebuild,
+ boinc-5.5.6.ebuild:
+ Added unicode USE flag, should fix bug 135306.
11 Jul 2006; Marcus D. Hanwell <cryos@gentoo.org> boinc-5.5.6.ebuild:
Updated to call the necessary autotools directly, should fix bug 139923.
diff --git a/sci-misc/boinc/boinc-5.2.14.ebuild b/sci-misc/boinc/boinc-5.2.14.ebuild
index 497a55284855..eebceade24ad 100644
--- a/sci-misc/boinc/boinc-5.2.14.ebuild
+++ b/sci-misc/boinc/boinc-5.2.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.5 2006/04/14 19:14:47 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.6 2006/07/15 20:31:13 cryos Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo//${P}.tar.bz2
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="server X"
+IUSE="server X unicode"
RDEPEND="sys-libs/zlib
>=net-misc/curl-7.15.0
@@ -55,6 +55,7 @@ src_compile() {
--enable-client \
--disable-static-client \
--with-wx-config=$(which wx-config-2.6) \
+ $(use_enable unicode) \
$(use_enable server) \
$(use_with X x) || die "econf failed"
emake || die "emake failed"
diff --git a/sci-misc/boinc/boinc-5.5.6.ebuild b/sci-misc/boinc/boinc-5.5.6.ebuild
index 42cc58ceaec6..4fc1ffa66f8b 100644
--- a/sci-misc/boinc/boinc-5.5.6.ebuild
+++ b/sci-misc/boinc/boinc-5.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.2 2006/07/11 12:06:04 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.3 2006/07/15 20:31:13 cryos Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://gentoo//${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="server X"
+IUSE="server X unicode"
RDEPEND="sys-libs/zlib
>=net-misc/curl-7.15.0
@@ -57,6 +57,7 @@ src_compile() {
--enable-client \
--disable-static-client \
--with-wx-config=$(which wx-config-2.6) \
+ $(use_enable unicode) \
$(use_enable server) \
$(use_with X x) || die "econf failed"
# Make it link to the compiled libs, not the installed ones