summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2002-03-19 04:38:39 +0000
committerChad Huneycutt <chadh@gentoo.org>2002-03-19 04:38:39 +0000
commitca56aeb3828acb3b32232cb3d909d6e0de12876a (patch)
treef9d2044b4a79668e1068ec68e74165fd1fc11fea /sys-apps/at/at-3.1.8-r8.ebuild
parentA new bison with gcc3 compatibility, closing bug #1210 (diff)
downloadgentoo-2-ca56aeb3828acb3b32232cb3d909d6e0de12876a.tar.gz
gentoo-2-ca56aeb3828acb3b32232cb3d909d6e0de12876a.tar.bz2
gentoo-2-ca56aeb3828acb3b32232cb3d909d6e0de12876a.zip
added virtual/mta as RDEPEND
Diffstat (limited to 'sys-apps/at/at-3.1.8-r8.ebuild')
-rw-r--r--sys-apps/at/at-3.1.8-r8.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/at/at-3.1.8-r8.ebuild b/sys-apps/at/at-3.1.8-r8.ebuild
new file mode 100644
index 000000000000..7f5e909e647f
--- /dev/null
+++ b/sys-apps/at/at-3.1.8-r8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Ferry Meyndert <m0rpheus@poseidon.mine.nu>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/at/at-3.1.8-r8.ebuild,v 1.1 2002/03/19 04:38:39 chadh Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Queues jobs for later execution"
+SRC_URI="http://ftp.debian.org/debian/pool/main/a/at/at_${PV}-11.tar.gz"
+HOMEPAGE=""
+
+DEPEND="virtual/glibc >=sys-devel/flex-2.5.4a"
+RDEPEND="virtual/glibc virtual/mta"
+
+src_compile() {
+
+ ./configure --host=${CHOST/-pc/} --sysconfdir=/etc/at \
+ --with-jobdir=/var/cron/atjobs \
+ --with-atspool=/var/cron/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at || die
+ emake || die
+}
+
+src_install() {
+
+ into /usr
+ chmod 755 batch
+ chmod 755 atrun
+ dobin at batch
+ fperms 4755 /usr/bin/at
+ dosym at /usr/bin/atrm
+ dosym at /usr/bin/atq
+ dosbin atd atrun
+
+ for i in atjobs atspool
+ do
+ dodir /var/cron/${i}
+ fperms 700 /var/cron/${i}
+ fowners at.at /var/cron/${i}
+ touch ${D}/var/cron/${i}/.SEQ
+ done
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/atd.rc6 atd
+ insinto /etc/at
+ insopts -m 0644
+ doins ${FILESDIR}/at.deny
+ doman at.1 at_allow.5 atd.8 atrun.8
+ dodoc COPYING ChangeLog Copyright Problems README
+}