summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-13 08:37:36 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-13 08:37:36 +0000
commitcd2b4fc8c7e24786c369256815ae1c6ea109a7dc (patch)
tree2af0f816e293c73e2f5eb89928568149c3c75fe2 /sys-apps/busybox/busybox-0.60.5-r1.ebuild
parentfilter -fomit-frame-pointer; fixes bug #13471 (diff)
downloadgentoo-2-cd2b4fc8c7e24786c369256815ae1c6ea109a7dc.tar.gz
gentoo-2-cd2b4fc8c7e24786c369256815ae1c6ea109a7dc.tar.bz2
gentoo-2-cd2b4fc8c7e24786c369256815ae1c6ea109a7dc.zip
set LINK_LIBC="uclibc" to link against uclibc
Diffstat (limited to 'sys-apps/busybox/busybox-0.60.5-r1.ebuild')
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r1.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/sys-apps/busybox/busybox-0.60.5-r1.ebuild b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
index b32f00fdb5b5..b87196f79ffd 100644
--- a/sys-apps/busybox/busybox-0.60.5-r1.ebuild
+++ b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.1 2003/01/13 07:54:53 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.2 2003/01/13 08:37:36 raker Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Utilities for rescue and embedded systems"
@@ -25,9 +25,7 @@ src_unpack() {
src_compile() {
local myconf
use static && myconf="${myconf} DOSTATIC=true"
- INSTLIBC="`best_version virtual/glibc`"
- UCLIBC="dev-libs/uclibc"
- if [ ${INSTLIBC:0:${#UCLIBC}} = $UCLIBC ]; then
+ if [ "$LINK_LIBC" = "uclibc" ]; then
myconf="${myconf} \
CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
USE_SYSTEM_PWD=false"