summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2003-11-19 06:41:09 +0000
committerPreston A. Elder <prez@gentoo.org>2003-11-19 06:41:09 +0000
commitbf9c18f7b8decc8229ef2da46cdc96ea6b4734da (patch)
tree7205bf48b8ab08672680300e5d0bb472c621b97d /sys-apps/dcron
parentUpdated run-crons to stop multiple instances executing at once. (diff)
downloadgentoo-2-bf9c18f7b8decc8229ef2da46cdc96ea6b4734da.tar.gz
gentoo-2-bf9c18f7b8decc8229ef2da46cdc96ea6b4734da.tar.bz2
gentoo-2-bf9c18f7b8decc8229ef2da46cdc96ea6b4734da.zip
Changed crontab to exec run-crons every minute, only works right with
newer cronbase
Diffstat (limited to 'sys-apps/dcron')
-rw-r--r--sys-apps/dcron/ChangeLog12
-rw-r--r--sys-apps/dcron/dcron-2.9-r1.ebuild68
-rw-r--r--sys-apps/dcron/files/crontab-2.9-r119
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.9-r11
4 files changed, 97 insertions, 3 deletions
diff --git a/sys-apps/dcron/ChangeLog b/sys-apps/dcron/ChangeLog
index e18829234174..14ae558dcedb 100644
--- a/sys-apps/dcron/ChangeLog
+++ b/sys-apps/dcron/ChangeLog
@@ -1,12 +1,18 @@
# ChangeLog for sys-apps/dcron
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.19 2003/07/25 05:05:33 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.20 2003/11/19 06:41:09 prez Exp $
- 15 Jul 2003; Martin Holzer <mholzer@gentoo.org> dcron-2.9.ebuild:
- Marked x86 stable
+*dcron-2.9-r1 (19 Nov 2003)
+
+ 19 Nov 2003; Preston A. Elder <prez@gentoo.org> dcron-2.9-r1.ebuild:
+ Changed so run-crons is run every minute. This will only work right
+ with the newer cronbase.
*dcron-2.9 (19 Mar 2003)
+ 15 Jul 2003; Martin Holzer <mholzer@gentoo.org> dcron-2.9.ebuild:
+ Marked x86 stable
+
25 Jul 2003; Guy Martin <gmsoft@gentoo.org> dcron-2.9.ebuild :
Marked stable on hppa.
diff --git a/sys-apps/dcron/dcron-2.9-r1.ebuild b/sys-apps/dcron/dcron-2.9-r1.ebuild
new file mode 100644
index 000000000000..06c938eb32d7
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.9-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r1.ebuild,v 1.1 2003/11/19 06:41:09 prez Exp $
+
+# to use this, you must be part of the "cron" group
+
+MY_PV=29
+S=${WORKDIR}/${PN}
+DESCRIPTION="A cute little cron from Matt Dillon"
+SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
+HOMEPAGE="http://apollo.backplane.com/"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa ~alpha ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ >=sys-apps/cronbase-0.2.1-r3
+ virtual/mta"
+
+PROVIDE="virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/dcron-2.7-Makefile-gentoo.diff || die
+ # fix 'crontab -e' to look at $EDITOR and not $VISUAL
+ cp ${S}/crontab.c ${S}/crontab.c.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.c.orig > ${S}/crontab.c
+ cp ${S}/crontab.1 ${S}/crontab.1.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.1.orig > ${S}/crontab.1
+ # remove gcc hardcode
+ cp ${S}/Makefile ${S}/Makefile.orig
+ sed -e "s:\(CC = \)gcc:\1${CC:-gcc}:" ${S}/Makefile.orig > ${S}/Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ #this does not work if the directory already exists
+ diropts -m 0750 -o root -g cron
+ dodir /var/spool/cron/crontabs
+
+ dodir /usr/{sbin,bin}
+ install -o root -g wheel -m 0700 crond ${D}/usr/sbin
+ install -o root -g cron -m 4750 crontab ${D}/usr/bin
+
+ dodoc CHANGELOG README ${FILESDIR}/crontab
+ doman crontab.1 crond.8
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dcron.rc6 dcron
+
+ dodir /etc
+ install -o root -g root -m 0644 ${FILESDIR}/crontab-2.9-r1 ${D}/etc/crontab
+}
+
+
+pkg_postinst() {
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+}
diff --git a/sys-apps/dcron/files/crontab-2.9-r1 b/sys-apps/dcron/files/crontab-2.9-r1
new file mode 100644
index 000000000000..aeed0484ad32
--- /dev/null
+++ b/sys-apps/dcron/files/crontab-2.9-r1
@@ -0,0 +1,19 @@
+# /etc/crontab
+# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/files/crontab-2.9-r1,v 1.1 2003/11/19 06:41:09 prez Exp $
+
+# fcron || dcron:
+# This is NOT the system crontab! fcron and dcron do not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# crontab /etc/crontab
+# as root.
+# NOTE: This will REPLACE root's current crontab!!
+
+
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+
+0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+0 0 * * * rm -f /var/spool/cron/lastrun/cron.daily
+0 0 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+0 0 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+* * * * * test -x /usr/sbin/run-crons && /usr/sbin/run-crons
diff --git a/sys-apps/dcron/files/digest-dcron-2.9-r1 b/sys-apps/dcron/files/digest-dcron-2.9-r1
new file mode 100644
index 000000000000..bf4decff8ad3
--- /dev/null
+++ b/sys-apps/dcron/files/digest-dcron-2.9-r1
@@ -0,0 +1 @@
+MD5 120fb2ca3d91496b32df0ab01dcaec5e dcron29.tgz 15608