summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-10 04:19:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-10 04:19:21 +0000
commitf558532318148bc7a2e82f93463347030f6fd3dd (patch)
treee6d53a2d349bdc06b53e49b5fc9f5788bb3c5c6b /sys-apps/dcron
parentold (diff)
downloadgentoo-2-f558532318148bc7a2e82f93463347030f6fd3dd.tar.gz
gentoo-2-f558532318148bc7a2e82f93463347030f6fd3dd.tar.bz2
gentoo-2-f558532318148bc7a2e82f93463347030f6fd3dd.zip
Add support for cron.eclass by Aaron Walker #78077.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps/dcron')
-rw-r--r--sys-apps/dcron/ChangeLog7
-rw-r--r--sys-apps/dcron/dcron-2.9-r3.ebuild67
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.9-r31
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-apps/dcron/ChangeLog b/sys-apps/dcron/ChangeLog
index 304c704aa1f0..334df64e809a 100644
--- a/sys-apps/dcron/ChangeLog
+++ b/sys-apps/dcron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dcron
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.39 2005/01/10 06:49:36 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.40 2005/02/10 04:19:21 vapier Exp $
+
+*dcron-2.9-r3 (09 Feb 2005)
+
+ 09 Feb 2005; Mike Frysinger <vapier@gentoo.org> +dcron-2.9-r3.ebuild:
+ Add support for cron.eclass by Aaron Walker #78077.
10 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> dcron-2.9-r2.ebuild:
Added in a message with a link to the Cron Guide, bug #77320
diff --git a/sys-apps/dcron/dcron-2.9-r3.ebuild b/sys-apps/dcron/dcron-2.9-r3.ebuild
new file mode 100644
index 000000000000..8e8efb2575a0
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.9-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r3.ebuild,v 1.1 2005/02/10 04:19:21 vapier Exp $
+
+inherit cron toolchain-funcs
+
+MY_PV=29
+DESCRIPTION="A cute little cron from Matt Dillon"
+HOMEPAGE="http://apollo.backplane.com/"
+SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/portage-2.0.51"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/dcron-2.7-Makefile-gentoo.diff
+ epatch ${FILESDIR}/dcron-2.9-ldflags.patch
+
+ # fix 'crontab -e' to look at $EDITOR and not $VISUAL
+ sed -i 's:VISUAL:EDITOR:g' crontab.{c,1}
+
+ # remove gcc hardcode
+ sed -i "s:\(CC = \)gcc:\1$(tc-getCC):" Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ #this does not work if the directory already exists
+ docrondir
+ docron crond -m0700 -o root -g wheel
+ docrontab
+
+ dodoc CHANGELOG README ${FILESDIR}/crontab
+ doman crontab.1 crond.8
+
+ doinitd ${FILESDIR}/dcron
+
+ insinto /etc/logrotate.d
+ newins ${FILESDIR}/dcron.logrotate dcron
+
+ insopts -o root -g root -m 0644
+ insinto /etc
+ doins ${FILESDIR}/crontab
+}
+
+pkg_postinst() {
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+ einfo "You may wish to read the Gentoo Linux Cron Guide, which can be"
+ einfo "found online at:"
+ einfo " http://www.gentoo.org/doc/en/cron-guide.xml"
+ echo
+}
diff --git a/sys-apps/dcron/files/digest-dcron-2.9-r3 b/sys-apps/dcron/files/digest-dcron-2.9-r3
new file mode 100644
index 000000000000..bf4decff8ad3
--- /dev/null
+++ b/sys-apps/dcron/files/digest-dcron-2.9-r3
@@ -0,0 +1 @@
+MD5 120fb2ca3d91496b32df0ab01dcaec5e dcron29.tgz 15608