summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-03-04 23:15:26 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-03-04 23:15:26 +0000
commit2854b6383c53e0bee91bc866c7c70c6f02973ffc (patch)
treea240bb9f9ea5ee14763b75d09961b51fe3d42f92 /sys-apps/dstat
parentkeyworded ~arch for ppc64, bug 210769 (diff)
downloadgentoo-2-2854b6383c53e0bee91bc866c7c70c6f02973ffc.tar.gz
gentoo-2-2854b6383c53e0bee91bc866c7c70c6f02973ffc.tar.bz2
gentoo-2-2854b6383c53e0bee91bc866c7c70c6f02973ffc.zip
version bump
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps/dstat')
-rw-r--r--sys-apps/dstat/ChangeLog9
-rw-r--r--sys-apps/dstat/dstat-0.6.7.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-apps/dstat/ChangeLog b/sys-apps/dstat/ChangeLog
index 71421d46439e..3194476890be 100644
--- a/sys-apps/dstat/ChangeLog
+++ b/sys-apps/dstat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dstat
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.22 2007/12/13 20:13:23 cardoe Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.23 2008/03/04 23:15:26 wschlich Exp $
+
+*dstat-0.6.7 (04 Mar 2008)
+
+ 04 Mar 2008; Wolfram Schlich <wschlich@gentoo.org> +dstat-0.6.7.ebuild:
+ version bump
13 Dec 2007; Doug Klima <cardoe@gentoo.org> -dstat-0.6.0-r1.ebuild,
-dstat-0.6.1.ebuild, -dstat-0.6.3.ebuild, -dstat-0.6.4.ebuild:
diff --git a/sys-apps/dstat/dstat-0.6.7.ebuild b/sys-apps/dstat/dstat-0.6.7.ebuild
new file mode 100644
index 000000000000..9a5399a1df60
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.6.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.6.7.ebuild,v 1.1 2008/03/04 23:15:26 wschlich Exp $
+
+inherit python
+
+DESCRIPTION="Dstat is a versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/python"
+DEPEND=""
+
+src_compile() {
+ true
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+
+ dodoc \
+ AUTHORS ChangeLog README TODO dstat.conf \
+ examples/{mstat,read}.py docs/*.txt \
+ || die "dodoc failed"
+ dohtml docs/*.html || die "dohtml failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/dstat
+
+ einfo
+ einfo "See the included dstat.conf in the doc directory for"
+ einfo "an example on how to setup a custom /etc/dstat.conf"
+ einfo
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/dstat
+}