summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-03 18:04:19 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-03 18:04:19 +0000
commita54e7fb08abc0ea1fb936dd337ec3f6dd9b5b253 (patch)
tree0199c463d5c092092fb7100a07332ca704d423b1 /sys-apps/file
parentversion bumped. (diff)
downloadgentoo-2-a54e7fb08abc0ea1fb936dd337ec3f6dd9b5b253.tar.gz
gentoo-2-a54e7fb08abc0ea1fb936dd337ec3f6dd9b5b253.tar.bz2
gentoo-2-a54e7fb08abc0ea1fb936dd337ec3f6dd9b5b253.zip
version bumped.
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest2
-rw-r--r--sys-apps/file/file-4.03.ebuild41
-rw-r--r--sys-apps/file/files/digest-file-4.031
3 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 4b55d2aa6c25..090dee233264 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -4,7 +4,7 @@ MD5 11c4331cb3a68b4bd5250959127e31c0 file-3.39.ebuild 1008
MD5 864d9d78ae48573d790cc598fcc4bc40 file-3.41.ebuild 1025
MD5 20dd962c51a7b039d867a7a99645fbb5 file-4.01.ebuild 936
MD5 e593a4a7dea3146bb413dea1737d48b6 file-4.02.ebuild 1093
-MD5 6e07f31ae04c047cf06aedd0717cf449 file-4.03.ebuild 1097
+MD5 039265293ed955591797adeb653bb9c3 file-4.03.ebuild 1099
MD5 8a94349d0574b8fdb31ba08f31c8f5a7 files/digest-file-4.03 61
MD5 3a18c97dfcc727e6c1b701cc8c03af47 files/digest-file-3.37 267
MD5 950dd57055e8275bd852869557035f42 files/digest-file-3.39 268
diff --git a/sys-apps/file/file-4.03.ebuild b/sys-apps/file/file-4.03.ebuild
new file mode 100644
index 000000000000..69ecc8810c42
--- /dev/null
+++ b/sys-apps/file/file-4.03.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.03.ebuild,v 1.1 2003/09/03 18:04:13 mholzer Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~alpha ~hppa"
+SLOT="0"
+LICENSE="as-is"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ # file command segfaults on hppa - reported by gustavo@zacarias.com.ar
+ [ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/misc \
+ --host=${CHOST} || die
+
+ #unfortunately, parallel make doesn't work with 4.01
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if [ -z "`use build`" ] ; then
+ dodoc LEGAL.NOTICE MAINT README || die
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
diff --git a/sys-apps/file/files/digest-file-4.03 b/sys-apps/file/files/digest-file-4.03
new file mode 100644
index 000000000000..a5dc17283d1a
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.03
@@ -0,0 +1 @@
+MD5 679d8982035167160c2d7bd2112fdf85 file-4.03.tar.gz 342596