summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-25 18:06:59 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-25 18:06:59 +0000
commit535b05368ad6eb01b64d0c555f34402cfc8aa332 (patch)
tree044e04f3eeada4eaa777f6d64151a5224625958e /sys-apps/gawk/files
parentmask versions of gawk that borks baselayout (diff)
downloadgentoo-2-535b05368ad6eb01b64d0c555f34402cfc8aa332.tar.gz
gentoo-2-535b05368ad6eb01b64d0c555f34402cfc8aa332.tar.bz2
gentoo-2-535b05368ad6eb01b64d0c555f34402cfc8aa332.zip
moved filefuncs.so from baselayout.
Diffstat (limited to 'sys-apps/gawk/files')
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.1.2-r11
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.1.2-r2 (renamed from sys-apps/gawk/files/digest-gawk-3.1.2)0
-rw-r--r--sys-apps/gawk/files/filefuncs/Makefile7
3 files changed, 5 insertions, 3 deletions
diff --git a/sys-apps/gawk/files/digest-gawk-3.1.2-r1 b/sys-apps/gawk/files/digest-gawk-3.1.2-r1
deleted file mode 100644
index d002b5ee0638..000000000000
--- a/sys-apps/gawk/files/digest-gawk-3.1.2-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 6d14f3c95669ace8c6aee2a96ba4eed7 gawk-3.1.2.tar.gz 2003860
diff --git a/sys-apps/gawk/files/digest-gawk-3.1.2 b/sys-apps/gawk/files/digest-gawk-3.1.2-r2
index d002b5ee0638..d002b5ee0638 100644
--- a/sys-apps/gawk/files/digest-gawk-3.1.2
+++ b/sys-apps/gawk/files/digest-gawk-3.1.2-r2
diff --git a/sys-apps/gawk/files/filefuncs/Makefile b/sys-apps/gawk/files/filefuncs/Makefile
index 80ac0e9d92fa..1668f3bbffde 100644
--- a/sys-apps/gawk/files/filefuncs/Makefile
+++ b/sys-apps/gawk/files/filefuncs/Makefile
@@ -1,12 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.1 2003/03/25 15:27:34 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.2 2003/03/25 18:06:59 azarah Exp $
CC = gcc
LD = gcc
+
MAJORVER = 0
MINORVER = 0.1
+
+AWKINCDIR = /usr/include/awk
DESTDIR =
TARGET = filefuncs.so.$(MAJORVER).$(MINORVER)
@@ -14,7 +17,7 @@ TARGET = filefuncs.so.$(MAJORVER).$(MINORVER)
all: $(TARGET)
filefuncs.o: filefuncs.c
- $(CC) -shared -Wall -DHAVE_CONFIG_H -c -O2 -fPIC -I/usr/include/awk $^
+ $(CC) -shared -Wall -DHAVE_CONFIG_H -c -O2 -fPIC -I$(AWKINCDIR) $^
filefuncs.so.$(MAJORVER).$(MINORVER): filefuncs.o
$(LD) -o $@ -shared -Wl,-soname -Wl,filefuncs.so.$(MAJORVER) $^