summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-12-30 04:35:09 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-12-30 04:35:09 +0000
commitdab77db04ad3406da08ade9cd89727ccaa0f4177 (patch)
tree15dfbf007f7428d3cf507629c746b53fc8a018a2 /sys-apps/groff
parentfinishing up xmltex->passivetex changes... (diff)
downloadgentoo-2-dab77db04ad3406da08ade9cd89727ccaa0f4177.tar.gz
gentoo-2-dab77db04ad3406da08ade9cd89727ccaa0f4177.tar.bz2
gentoo-2-dab77db04ad3406da08ade9cd89727ccaa0f4177.zip
new masked groff (for now)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/files/digest-groff-1.18.11
-rw-r--r--sys-apps/groff/groff-1.18.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/groff/files/digest-groff-1.18.1 b/sys-apps/groff/files/digest-groff-1.18.1
new file mode 100644
index 000000000000..94400bd5b25d
--- /dev/null
+++ b/sys-apps/groff/files/digest-groff-1.18.1
@@ -0,0 +1 @@
+MD5 4c7a1b478d230696f14743772f31639f groff-1.18.1.tar.gz 2250463
diff --git a/sys-apps/groff/groff-1.18.1.ebuild b/sys-apps/groff/groff-1.18.1.ebuild
new file mode 100644
index 000000000000..87e8cf6363f1
--- /dev/null
+++ b/sys-apps/groff/groff-1.18.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.18.1.ebuild,v 1.1 2002/12/30 04:35:08 drobbins Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Text formatter used for man pages"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/groff/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch ${FILESDIR}/groff-1.18-infoext.patch
+
+ # Do not generate example files that require us to
+ # depend on netpbm.
+ epatch ${FILESDIR}/groff-1.18-no-netpbm-depend.patch
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+ [ -z "${CC}" ] && export CC="gcc"
+ [ -z "${CXX}" ] && export CXX="g++"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=\${inforoot} || die
+
+ # emake doesn't work
+ make || die
+
+ # Only build X stuff if we have X installed, but do
+ # not depend on it, else we get circular deps.
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ xmkmf || die
+ make depend all || die
+ fi
+}
+
+src_install() {
+ dodir /usr /usr/share/doc/${PF}/{examples,html}
+ make prefix=${D}/usr \
+ manroot=${D}/usr/share/man \
+ inforoot=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ make DESTDIR=${D} \
+ BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ install \
+ install.man || die
+ fi
+
+ #the following links are required for xman
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+ dosym soelim /usr/bin/zsoelim
+
+ cd ${S}
+ dodoc BUG-REPORT COPYING ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}
+