summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-07-31 02:23:51 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-07-31 02:23:51 +0000
commit892ef4107678fbfc1646b8950d4239698b9a472a (patch)
tree2e60694938a8c9a74628136ec9a710866fb2d79b /sys-apps/gzip
parentAdded this to rc.d/init.d/mountall (diff)
downloadgentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.tar.gz
gentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.tar.bz2
gentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.zip
Finally getting around to committing some ebuilds I have been working on.
My first 2 ebuilds: freeciv and lrzsz gzip and gdbm just have small fixes to fix the info dir entry problem.
Diffstat (limited to 'sys-apps/gzip')
-rw-r--r--sys-apps/gzip/files/digest-gzip-1.2.4a-r51
-rw-r--r--sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff15
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r5.ebuild80
3 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/gzip/files/digest-gzip-1.2.4a-r5 b/sys-apps/gzip/files/digest-gzip-1.2.4a-r5
new file mode 100644
index 000000000000..60ae475bc42e
--- /dev/null
+++ b/sys-apps/gzip/files/digest-gzip-1.2.4a-r5
@@ -0,0 +1 @@
+MD5 39053e044b18ecd0627f80fbe7cfeaad gzip-1.2.4a.tar.gz
diff --git a/sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff b/sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff
new file mode 100644
index 000000000000..863117e69f93
--- /dev/null
+++ b/sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff
@@ -0,0 +1,15 @@
+diff -r -C2 -P gzip-1.2.4a.orig/gzip.texi gzip-1.2.4a/gzip.texi
+*** gzip-1.2.4a.orig/gzip.texi Tue Feb 2 18:51:38 1999
+--- gzip-1.2.4a/gzip.texi Thu Jul 26 23:33:25 2001
+***************
+*** 8,11 ****
+--- 8,16 ----
+
+ @ifinfo
++
++ @dircategory Utilities
++ @direntry
++ * gzip: (gzip). The GNU compression utility.
++ @end direntry
+ This file documents the the GNU @code{gzip} command for compressing files.
+
diff --git a/sys-apps/gzip/gzip-1.2.4a-r5.ebuild b/sys-apps/gzip/gzip-1.2.4a-r5.ebuild
new file mode 100644
index 000000000000..db89644a7309
--- /dev/null
+++ b/sys-apps/gzip/gzip-1.2.4a-r5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# Chad Huneycutt <chad.huneycutt@acm.org>
+# /home/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r3.ebuild,v 1.1 2001/02/27 16:44:48 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU compressor"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
+ ftp://prep.ai.mit.edu/gnu/gzip/${A}"
+HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
+ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static ${MAKEOPTS}
+ fi
+}
+
+src_install() {
+
+ dodir /usr/bin /usr/share/man/man1
+ try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
+
+ cd ${D}/bin
+ for i in gzexe zforce zgrep zmore znew zcmp
+ do
+ cp ${i} ${i}.orig
+ sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
+ rm ${i}.orig
+ chmod 755 ${i}
+ done
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ cd ${D}/usr/share/man/man1
+
+ for i in gzexe gzip zcat zcmp zdiff zforce \
+ zgrep zmore znew
+ do
+ rm ${i}.1
+ ln -s gunzip.1.gz ${i}.1.gz
+ done
+
+ cd ${S}
+ rm -rf ${D}/usr/man ${D}/usr/lib
+
+ dodoc ChangeLog COPYING NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+ else
+ rm -rf ${D}/usr
+ fi
+}
+
+
+
+