summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-13 04:35:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-13 04:35:36 +0000
commitb80ecec81ebe2e796cd261aa9bb5e65877093f78 (patch)
tree4c5f4d49b9c984430f30f5c4f719ee8df04443de /sys-apps/iproute2
parentworks ok here (Manifest recommit) (diff)
downloadgentoo-2-b80ecec81ebe2e796cd261aa9bb5e65877093f78.tar.gz
gentoo-2-b80ecec81ebe2e796cd261aa9bb5e65877093f78.tar.bz2
gentoo-2-b80ecec81ebe2e796cd261aa9bb5e65877093f78.zip
Version bump.
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/ChangeLog8
-rw-r--r--sys-apps/iproute2/files/digest-iproute2-2.6.10.200501121
-rw-r--r--sys-apps/iproute2/iproute2-2.6.10.20050112.ebuild66
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 865defbf6061..497a880c4b95 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/iproute2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.21 2005/01/02 23:24:33 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.22 2005/01/13 04:35:36 vapier Exp $
+
+*iproute2-2.6.10.20050112 (12 Jan 2005)
+
+ 12 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ +iproute2-2.6.10.20050112.ebuild:
+ Version bump.
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/sys-apps/iproute2/files/digest-iproute2-2.6.10.20050112 b/sys-apps/iproute2/files/digest-iproute2-2.6.10.20050112
new file mode 100644
index 000000000000..230bc8fcdb9b
--- /dev/null
+++ b/sys-apps/iproute2/files/digest-iproute2-2.6.10.20050112
@@ -0,0 +1 @@
+MD5 43b454cfa0948e234f128cce41db4911 iproute2-2.6.10-ss050112.tar.gz 307663
diff --git a/sys-apps/iproute2/iproute2-2.6.10.20050112.ebuild b/sys-apps/iproute2/iproute2-2.6.10.20050112.ebuild
new file mode 100644
index 000000000000..2ca6a3a32729
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-2.6.10.20050112.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.10.20050112.ebuild,v 1.1 2005/01/13 04:35:36 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV%.*}
+SNAP=${PV##*.}
+SNAP=ss${SNAP:2}
+DESCRIPTION="kernel routing and traffic control utilities"
+HOMEPAGE="http://developer.osdl.org/dev/iproute2/"
+SRC_URI="http://developer.osdl.org/dev/iproute2/download/${PN}-${MY_PV}-${SNAP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="atm minimal"
+
+RDEPEND="virtual/libc
+ !minimal? ( sys-libs/db )
+ atm? ( net-dialup/linux-atm )"
+DEPEND="${RDEPEND}
+ >=virtual/os-headers-2.4.21
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}-${MY_PV}-${SNAP}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2:${CFLAGS}:" Makefile || die "sed Makefile failed"
+ #68948 - esqf/wrr patches
+ epatch \
+ ${FILESDIR}/2.6.9.20041019-esqf.patch \
+ ${FILESDIR}/2.6.9.20041019-wrr.patch
+}
+
+src_compile() {
+ echo -n 'TC_CONFIG_ATM:=' > Config
+ use atm \
+ && echo 'y' >> Config \
+ || echo 'n' >> Config
+
+ local SUBDIRS="lib ip tc misc"
+ use minimal && SUBDIRS="lib tc"
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ SUBDIRS="${SUBDIRS}" \
+ || die "make"
+}
+
+src_install() {
+ if use minimal; then
+ into /
+ dosbin tc/tc || die "minimal"
+ return 0
+ fi
+
+ make \
+ DESTDIR="${D}" \
+ SBINDIR=/sbin \
+ DOCDIR=/usr/share/doc/${PF} \
+ install \
+ || die "make install failed"
+}