summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-04-24 00:16:44 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-04-24 00:16:44 +0000
commitb11414082164647d240d5bccd95995a95a4097f0 (patch)
tree7b2b43118f27d0b6066a6ff2949f945cc0a19d61 /sys-apps/iptables
parent*** empty log message *** (diff)
downloadgentoo-2-b11414082164647d240d5bccd95995a95a4097f0.tar.gz
gentoo-2-b11414082164647d240d5bccd95995a95a4097f0.tar.bz2
gentoo-2-b11414082164647d240d5bccd95995a95a4097f0.zip
new iptables package, new download location
Diffstat (limited to 'sys-apps/iptables')
-rw-r--r--sys-apps/iptables/iptables-1.2.1a.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/iptables/iptables-1.2.1a.ebuild b/sys-apps/iptables/iptables-1.2.1a.ebuild
new file mode 100644
index 000000000000..b4d237b35c3a
--- /dev/null
+++ b/sys-apps/iptables/iptables-1.2.1a.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.1a.ebuild,v 1.1 2001/04/24 00:16:44 drobbins Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
+SRC_URI="http://netfilter.samba.org/${A}"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local:/usr:g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ #I had a problem with pmake - DR
+ try make
+}
+
+
+src_install() {
+ dodir /usr/lib /usr/share/man/man8 /usr/sbin
+ try make LIBDIR=${D}/usr/lib BINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man install
+ dodoc COPYING KNOWN_BUGS
+}
+
+