summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-11 04:47:14 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-11 04:47:14 +0000
commitba59665201bdff0a0a22e7404a6fab32d343199d (patch)
tree5b640b647ec0a17967c633dfea296b75aca45e6e /sys-apps/linux-ntfs
parentadded two new functions (diff)
downloadgentoo-2-ba59665201bdff0a0a22e7404a6fab32d343199d.tar.gz
gentoo-2-ba59665201bdff0a0a22e7404a6fab32d343199d.tar.bz2
gentoo-2-ba59665201bdff0a0a22e7404a6fab32d343199d.zip
new package to access ntfs partitions in linux. this is a binary package!
Diffstat (limited to 'sys-apps/linux-ntfs')
-rw-r--r--sys-apps/linux-ntfs/files/50ntfs4
-rw-r--r--sys-apps/linux-ntfs/files/digest-linux-ntfs-1.5.0-r12
-rw-r--r--sys-apps/linux-ntfs/linux-ntfs-1.5.0-r1.ebuild49
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/linux-ntfs/files/50ntfs b/sys-apps/linux-ntfs/files/50ntfs
new file mode 100644
index 000000000000..277b52fda452
--- /dev/null
+++ b/sys-apps/linux-ntfs/files/50ntfs
@@ -0,0 +1,4 @@
+PATH=/opt/linux-ntfs/bin
+ROOTPATH=/opt/linux-ntfs/bin
+LDPATH=/opt/linux-ntfs/lib
+MANPATH=/opt/linux-ntfs/share/man
diff --git a/sys-apps/linux-ntfs/files/digest-linux-ntfs-1.5.0-r1 b/sys-apps/linux-ntfs/files/digest-linux-ntfs-1.5.0-r1
new file mode 100644
index 000000000000..128cc2dc066b
--- /dev/null
+++ b/sys-apps/linux-ntfs/files/digest-linux-ntfs-1.5.0-r1
@@ -0,0 +1,2 @@
+MD5 85fbcbe76c254c8af8571f2eb9ca15c2 linux-ntfs-1.5.0-1.i386.rpm 86016
+MD5 74a5e18b484c22bdab6d51961a349e86 linux-ntfs-devel-1.5.0-1.i386.rpm 73728
diff --git a/sys-apps/linux-ntfs/linux-ntfs-1.5.0-r1.ebuild b/sys-apps/linux-ntfs/linux-ntfs-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..903aab5adc3b
--- /dev/null
+++ b/sys-apps/linux-ntfs/linux-ntfs-1.5.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Donny Davies <woodchip@gentoo.rg>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-ntfs/linux-ntfs-1.5.0-r1.ebuild,v 1.1 2002/01/11 04:47:14 woodchip Exp $
+
+# NB: This project actually requires >=gcc.2.96! This ebuild installs an
+# rpm binary package into /opt. Eventually we'll compile it ourselves..
+
+DESCRIPTION="Utilities and library for accessing NTFS filesystems"
+HOMEPAGE="http://linux-ntfs.sourceforge.net/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${PN}-${PV}-${PR/r/}.i386.rpm
+ http://prdownloads.sourceforge.net/${PN}/${PN}-devel-${PV}-${PR/r/}.i386.rpm"
+DEPEND="virtual/glibc app-arch/rpm2targz"
+
+src_unpack() {
+
+ local i
+ for i in ${A}
+ do
+ rpm2targz ${DISTDIR}/${i}
+ tar zxf ${i/rpm/tar.gz}
+ rm -f ${i/rpm/tar.gz}
+ done
+}
+
+src_compile() { :; }
+
+
+src_install() {
+
+ cd ${D}
+ mkdir -p opt/${PN}
+ mv ${WORKDIR}/usr/* opt/${PN}
+ cd opt/${PN}
+
+ mv sbin/mkntfs bin
+ rm -rf sbin
+
+ mkdir -p ${D}/usr/share/doc ${D}/usr/include
+ mv share/doc/${PN}-${PV} ${D}/usr/share/doc/${PF}
+ rm -rf share/doc
+ dosym /opt/${PN}/include/ntfs /usr/include/ntfs
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/50ntfs
+}