summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-07-21 09:45:34 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-07-21 09:45:34 +0000
commit21961c8d17407f82e16b75a066a92dc1ee4b9f86 (patch)
tree3d5d749ef7ce96078478836abc0a88626c98b650 /sys-apps/lm_sensors
parentAdding request for ANSI Color Escapes into the ebuild (diff)
downloadgentoo-2-21961c8d17407f82e16b75a066a92dc1ee4b9f86.tar.gz
gentoo-2-21961c8d17407f82e16b75a066a92dc1ee4b9f86.tar.bz2
gentoo-2-21961c8d17407f82e16b75a066a92dc1ee4b9f86.zip
Bumped ebuild to the newest release
Diffstat (limited to 'sys-apps/lm_sensors')
-rw-r--r--sys-apps/lm_sensors/ChangeLog5
-rw-r--r--sys-apps/lm_sensors/files/digest-lm_sensors-2.6.41
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild50
3 files changed, 55 insertions, 1 deletions
diff --git a/sys-apps/lm_sensors/ChangeLog b/sys-apps/lm_sensors/ChangeLog
index b79d21bc3f9f..be8a6027a3ff 100644
--- a/sys-apps/lm_sensors/ChangeLog
+++ b/sys-apps/lm_sensors/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sys-apps/lm_sensors
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.4 2002/07/20 19:03:59 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.5 2002/07/21 09:45:34 naz Exp $
+ 26 May 2002; Michael Nazaroff <naz@gentoo.org> lm_sensors-2.6.4.ebuild:
+ Ebuild bumped to the newest release.
+
26 May 2002; Seemant Kulleen <seemant@gentoo.org> lm_sensors-2.6.3.ebuild:
15 Jul 2002; Mark Guertin <gerk@gentoo.org>
diff --git a/sys-apps/lm_sensors/files/digest-lm_sensors-2.6.4 b/sys-apps/lm_sensors/files/digest-lm_sensors-2.6.4
new file mode 100644
index 000000000000..d1adee014eed
--- /dev/null
+++ b/sys-apps/lm_sensors/files/digest-lm_sensors-2.6.4
@@ -0,0 +1 @@
+MD5 87bffc3f808e08bb8824576a9407618a lm_sensors-2.6.4.tar.gz 493768
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild
new file mode 100644
index 000000000000..84885ef3d0ea
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.4.ebuild,v 1.1 2002/07/21 09:45:34 naz Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile () {
+
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+
+}
+
+src_install () {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+}
+
+pkg_postinst() {
+
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+
+}