summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
commit6958fd94660a6f75a8de8b52b4f994965b22573c (patch)
tree1fc05a3b3717559d2787ef0c8284e2eb26a87775 /sys-apps/man
parentlots of cleanup. jpeg,zlib,libpng should now extract in the correct dirs (diff)
downloadgentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.gz
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.bz2
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.zip
header, tab fixes
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/man-1.5i-r1.ebuild39
1 files changed, 24 insertions, 15 deletions
diff --git a/sys-apps/man/man-1.5i-r1.ebuild b/sys-apps/man/man-1.5i-r1.ebuild
index 58d7cc49aab7..f27427cc21f1 100644
--- a/sys-apps/man/man-1.5i-r1.ebuild
+++ b/sys-apps/man/man-1.5i-r1.ebuild
@@ -1,34 +1,43 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: System Team <system@gentoo.org>
-# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5i-r1.ebuild,v 1.4 2001/12/27 05:05:12 karltk Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5i-r1.ebuild,v 1.5 2002/01/01 22:35:51 azarah Exp $
NV=1.5i2
S=${WORKDIR}/${PN}-${NV}
DESCRIPTION="Standard commands to read man pages"
-SRC_URI="http://www.kernel.org/pub/linux/utils/man/man-1.5i2.tar.bz2"
+SRC_URI="http://www.kernel.org/pub/linux/utils/man/man-${NV}.tar.bz2"
DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc sys-apps/groff"
+
+RDEPEND="virtual/glibc
+ sys-apps/groff"
src_unpack() {
unpack ${A}
cd ${S}
cp configure configure.orig
- sed -e 's/confdir=.*$/confdir=\/etc/' -e 's:/usr/lib/locale:$prefix/usr/lib/locale:g' -e 's!/bin:/usr/bin:/usr/ucb:/usr/local/bin:$PATH!/bin:/usr/bin:/usr/local/bin:$PATH!' configure.orig > configure
+ sed -e 's/confdir=.*$/confdir=\/etc/' \
+ -e 's:/usr/lib/locale:$prefix/usr/lib/locale:g' \
+ -e 's!/bin:/usr/bin:/usr/ucb:/usr/local/bin:$PATH!/bin:/usr/bin:/usr/local/bin:$PATH!' \
+ configure.orig > configure
local x
for x in / src/ man2html/ msgs/
do
cd ${S}/${x}
cp Makefile.in Makefile.in.orig
- sed -e '/inst.sh/d' -e '/^CC =/c\' -e "CC = gcc" -e '/^CFLAGS =/c\' -e "CFLAGS = $CFLAGS" Makefile.in.orig > Makefile.in
+ sed -e '/inst.sh/d' \
+ -e '/^CC =/c\' \
+ -e "CC = gcc" \
+ -e '/^CFLAGS =/c\' \
+ -e "CFLAGS = $CFLAGS" \
+ Makefile.in.orig > Makefile.in
done
}
src_compile() {
- ./configure +sgid +fhs +lang all || die
- #for FOOF in src man2html
+ ./configure +sgid +fhs +lang all || die
+ #for FOOF in src man2html
#do
# pmake ${FOOF}/Makefile MANCONFIG=/etc/man.conf || die
# cd ${S}/${FOOF}
@@ -36,21 +45,21 @@ src_compile() {
# sed -e "s/gcc -O/gcc ${CFLAGS}/" Makefile.orig > Makefile
# cd ${S}
#done
- make || die
+ make || die
}
src_install() {
- dodir /usr/sbin /usr/bin
+ dodir /usr/sbin /usr/bin
cd ${S}
make PREFIX=${D} install || die
cd ${S}/msgs
./inst.sh ?? ${D}/usr/share/locale/%L/%N
chmod 2555 ${D}/usr/bin/man
chown root.man ${D}/usr/bin/man
- insinto /etc
+ insinto /etc
doins ${FILESDIR}/man.conf
- cd ${S}
- dodoc COPYING LSM README* TODO
+ cd ${S}
+ dodoc COPYING LSM README* TODO
}