summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-30 01:35:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-30 01:35:57 +0000
commitaa727062f7ef4ad0e42b54acf606067846c1f6f3 (patch)
tree2a3dee0345fea5d79fab55c93cbd9a6a5c5de0d5 /sys-apps/parted
parentEbuild clean up (diff)
downloadgentoo-2-aa727062f7ef4ad0e42b54acf606067846c1f6f3.tar.gz
gentoo-2-aa727062f7ef4ad0e42b54acf606067846c1f6f3.tar.bz2
gentoo-2-aa727062f7ef4ad0e42b54acf606067846c1f6f3.zip
USE toggle use fixes
Diffstat (limited to 'sys-apps/parted')
-rw-r--r--sys-apps/parted/ChangeLog9
-rw-r--r--sys-apps/parted/files/digest-parted-1.4.24-r21
-rw-r--r--sys-apps/parted/parted-1.4.24-r2.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index 4246cb580aad..d5824d6f3a2f 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/parted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.2 2002/03/27 14:06:43 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.3 2002/03/30 01:35:57 seemant Exp $
+
+*parted-1.4.24-r2 (29 Mar 2002)
+
+ 29 Mar 2002; Seemant Kulleen <seemant@gentoo.org> parted-1.4.24-r2.ebuild :
+
+ Matthew Kennedy submitted some fixes for USE flag based compilation -- to
+ explicitly enable if in USE and explicitly disable if not.
*parted-1.4.24-r1 (27 Mar 2002)
diff --git a/sys-apps/parted/files/digest-parted-1.4.24-r2 b/sys-apps/parted/files/digest-parted-1.4.24-r2
new file mode 100644
index 000000000000..fe4a7ebada6c
--- /dev/null
+++ b/sys-apps/parted/files/digest-parted-1.4.24-r2
@@ -0,0 +1 @@
+MD5 1a0667bb4f0f167bcfd46bb1b72b8bee parted-1.4.24.tar.gz 872914
diff --git a/sys-apps/parted/parted-1.4.24-r2.ebuild b/sys-apps/parted/parted-1.4.24-r2.ebuild
new file mode 100644
index 000000000000..f31411498e68
--- /dev/null
+++ b/sys-apps/parted/parted-1.4.24-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Peter Gavin <pete@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.4.24-r2.ebuild,v 1.1 2002/03/30 01:35:57 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An advanced partition modification system"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/${PN}"
+
+DEPEND="virtual/glibc
+ >=sys-apps/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2-r5
+ readline? ( >=sys-libs/readline-4.1-r4 )
+ nls? ()"
+
+src_compile() {
+ local myconf
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ ./configure --prefix=/usr \
+ --target=${CHOST} \
+ --mandir=/usr/share/man \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ if [ -z "`use bootcd`" ]
+ then
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS \
+ README THANKS TODO
+ cd doc ; docinto doc
+ dodoc API COPYING.DOC FAQ FAT USER USER.jp
+ else
+ rm -rf ${D}/usr/share ${D}/usr/include ${D}/usr/lib/lib*.{a,la}
+ fi
+}