summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-01 23:47:25 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-01 23:47:25 +0000
commit7bb654e167f9bdb1891295464f952e376774b2a0 (patch)
treeb7f30084ea0bebb35549a5f19629d9882daa2058 /sys-apps/pciutils
parentAdded ppc to KEYWORDS. (diff)
downloadgentoo-2-7bb654e167f9bdb1891295464f952e376774b2a0.tar.gz
gentoo-2-7bb654e167f9bdb1891295464f952e376774b2a0.tar.bz2
gentoo-2-7bb654e167f9bdb1891295464f952e376774b2a0.zip
Version bump.
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.1.102
-rw-r--r--sys-apps/pciutils/files/pciutils-2.1.10-pcimodules.patch27
-rw-r--r--sys-apps/pciutils/pciutils-2.1.10.ebuild61
4 files changed, 96 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index fca97d9c9103..a9b02a7bf0b2 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pciutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.4 2002/07/14 19:20:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.5 2002/08/01 23:47:25 aliz Exp $
+
+*pciutils-2.1.10 (02 Aug 2002)
+
+ 02 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> pciutils-2.1.10.ebuild:
+ Version bump. Updates the pci.ids before compiling.
*pciutils-2.1.9-r1.ebuild (14 July 2002)
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.1.10 b/sys-apps/pciutils/files/digest-pciutils-2.1.10
new file mode 100644
index 000000000000..de6cdace75c7
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.1.10
@@ -0,0 +1,2 @@
+MD5 b589225945b445b0e4c5801a15b16b79 pciutils-2.1.10.tar.gz 111028
+MD5 7be1fd73b14feb79499c5117a3d05385 pcimodules-pciutils-2.1.8.diff.gz 4489
diff --git a/sys-apps/pciutils/files/pciutils-2.1.10-pcimodules.patch b/sys-apps/pciutils/files/pciutils-2.1.10-pcimodules.patch
new file mode 100644
index 000000000000..33308c199002
--- /dev/null
+++ b/sys-apps/pciutils/files/pciutils-2.1.10-pcimodules.patch
@@ -0,0 +1,27 @@
+--- /tmp/Makefile Fri Aug 2 09:40:43 2002
++++ Makefile Fri Aug 2 09:43:40 2002
+@@ -33,7 +33,7 @@
+
+ export
+
+-all: lib lspci setpci lspci.8 setpci.8 pci.ids
++all: lib lspci setpci lspci.8 setpci.8 pci.ids pcimodules pcimodules.8
+
+ lib: lib/config.h
+ $(MAKE) -C lib all
+@@ -61,13 +61,13 @@
+ install: all
+ # -c is ignored on Linux, but required on FreeBSD
+ $(DIRINSTALL) -m 755 $(ROOT)/sbin $(PREFIX)/share $(MANDIR)/man8
+- $(INSTALL) -c -m 755 -s lspci setpci $(ROOT)/sbin
++ $(INSTALL) -c -m 755 -s lspci setpci pcimodules $(ROOT)/sbin
+ if [ ! -f $(PREFIX)/share/pci.ids -o pci.ids -nt $(PREFIX)/share/pci.ids ] ; then \
+ $(INSTALL) -c -m 644 pci.ids $(PREFIX)/share ; \
+ elif [ -f $(PREFIX)/share/pci.ids ] ; then \
+ echo "$(PREFIX)/share/pci.ids is same or newer than the version to be installed, skipping." ; \
+ fi
+- $(INSTALL) -c -m 644 lspci.8 setpci.8 $(MANDIR)/man8
++ $(INSTALL) -c -m 644 lspci.8 setpci.8 pcimodules.8 $(MANDIR)/man8
+ # Remove relics from old versions
+ rm -f $(ROOT)/etc/pci.ids
+
diff --git a/sys-apps/pciutils/pciutils-2.1.10.ebuild b/sys-apps/pciutils/pciutils-2.1.10.ebuild
new file mode 100644
index 000000000000..8eab5781b52f
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.1.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.10.ebuild,v 1.1 2002/08/01 23:47:25 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various utilities dealing with the PCI bus"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz
+ ftp://ftp.yggdrasil.com/pub/dist/device_control/pcimodules/pcimodules-pciutils-2.1.8.diff.gz"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ net-misc/wget"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # this patch does apply cleanly to pciutils-2.1.9
+ # add pcimodules utility
+ gunzip -c ${DISTDIR}/pcimodules-pciutils-2.1.8.diff.gz | patch -p1
+ einfo "errors are expected"
+
+ patch -p0 < ${FILESDIR}/${P}-pcimodules.patch
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" -e "s:-Werror::g" Makefile.orig > Makefile
+
+ make update-ids
+
+ if [ ! -f pci.ids ] ; then mv pci.ids.orig pci.ids ; fi
+}
+
+src_compile() {
+ make PREFIX=/usr lib/config.h || die
+
+ cd ${S}/lib
+ cp config.h config.h.orig
+ sed -e "s:/usr/share/pci.ids:/usr/share/misc/pci.ids:" config.h.orig > config.h || die
+
+ cd ${S}
+ make PREFIX=/usr || die
+}
+
+src_install () {
+ into /
+ dosbin setpci lspci pcimodules
+ doman *.8
+
+ insinto /usr/share/misc
+ doins pci.ids
+
+ dolib lib/libpci.a
+
+ insinto /usr/include/pci
+ doins lib/*.h
+}