summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-06-03 00:12:54 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-06-03 00:12:54 +0000
commitba579278fb3a777770c62ab59c027bba0639d6ee (patch)
tree1844da68084127a0176b83bf5c732f2e7331b349 /sys-apps/pciutils
parentFixed type-o (sorry) and mask new support for GCC3.1 in pciutils until (diff)
downloadgentoo-2-ba579278fb3a777770c62ab59c027bba0639d6ee.tar.gz
gentoo-2-ba579278fb3a777770c62ab59c027bba0639d6ee.tar.bz2
gentoo-2-ba579278fb3a777770c62ab59c027bba0639d6ee.zip
Support for GCC3.1 in pciutils.
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog10
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.1.9-r22
-rw-r--r--sys-apps/pciutils/pciutils-2.1.9-r2.ebuild48
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 760bd8b55a11..5fe1b871aa4a 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/pciutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.2 2002/05/03 01:47:18 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.3 2002/06/03 00:12:54 mkennedy Exp $
+
+*pciutils-2.1.9-r2 (2 June 2002)
+
+ 2 June; Matthew Kennedy <mkennedy@gentoo.org>
+ pciutils-2.1.9-r2.ebuild, files/digest-pciutils-2.1.9-r2, ChangeLog :
+
+ Fixed -Werror breakage for GCC3.1. Thanks to
+ lostlogic@lostlogicx.com (Brandon Low) for the corrected ebuild.
*pciutils-2.1.9 (24 Feb 2002)
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.1.9-r2 b/sys-apps/pciutils/files/digest-pciutils-2.1.9-r2
new file mode 100644
index 000000000000..81273457a9db
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.1.9-r2
@@ -0,0 +1,2 @@
+MD5 2f3a604c137f5ff77461efed44a4b53a pciutils-2.1.9.tar.gz 100222
+MD5 7be1fd73b14feb79499c5117a3d05385 pcimodules-pciutils-2.1.8.diff.gz 4489
diff --git a/sys-apps/pciutils/pciutils-2.1.9-r2.ebuild b/sys-apps/pciutils/pciutils-2.1.9-r2.ebuild
new file mode 100644
index 000000000000..2e83192981ae
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.1.9-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.9-r2.ebuild,v 1.1 2002/06/03 00:12:54 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various utilities dealing with the PCI bus"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz
+ ftp://ftp.yggdrasil.com/pub/dist/device_control/pcimodules/pcimodules-pciutils-2.1.8.diff.gz"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # this patch does apply cleanly to pciutils-2.1.9
+ # add pcimodules utility
+ gunzip -c ${DISTDIR}/pcimodules-pciutils-2.1.8.diff.gz | patch -p1
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" -e "s:-Werror::g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ make PREFIX=/usr lib/config.h || die
+
+ cd ${S}/lib
+ cp config.h config.h.orig
+ sed -e "s:/usr/share/pci.ids:/usr/share/misc/pci.ids:" config.h.orig > config.h || die
+
+ cd ${S}
+ make PREFIX=/usr || die
+}
+
+src_install () {
+ into /
+ dosbin setpci lspci pcimodules
+ doman *.8
+
+ insinto /usr/share/misc
+ doins pci.ids
+
+ dolib lib/libpci.a
+
+ insinto /usr/include/pci
+ doins lib/*.h
+}