summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-21 19:19:02 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-21 19:19:02 +0000
commit0a79f91f2d0632aefa9597d47e7bb892957772f2 (patch)
tree90b17f0470e9b723d7e2d6e0ab7f119d42be53e8 /sys-apps/selinux-small
parentnew version (diff)
downloadgentoo-2-0a79f91f2d0632aefa9597d47e7bb892957772f2.tar.gz
gentoo-2-0a79f91f2d0632aefa9597d47e7bb892957772f2.tar.bz2
gentoo-2-0a79f91f2d0632aefa9597d47e7bb892957772f2.zip
patch to eliminate dependancy on yacc, thanks to sindian
Diffstat (limited to 'sys-apps/selinux-small')
-rw-r--r--sys-apps/selinux-small/ChangeLog6
-rw-r--r--sys-apps/selinux-small/files/selinux-small-2003011510-bison.diff12
-rw-r--r--sys-apps/selinux-small/selinux-small-2003011510-r2.ebuild8
3 files changed, 22 insertions, 4 deletions
diff --git a/sys-apps/selinux-small/ChangeLog b/sys-apps/selinux-small/ChangeLog
index 065a8e7e28ad..40daf2ee2c82 100644
--- a/sys-apps/selinux-small/ChangeLog
+++ b/sys-apps/selinux-small/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-apps/selinux-small
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/selinux-small/ChangeLog,v 1.2 2003/03/20 06:27:21 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/selinux-small/ChangeLog,v 1.3 2003/03/21 19:19:02 method Exp $
*selinux-small-2003011510-r2 (19 Mar 2003)
+ 21 Mar 2003; Joshua Brindle <method@gentoo.org> selinux-small-2003011510-r2.ebuild,
+ files/selinux-small-2003011510-bison.diff:
+ patch to eliminate dependancy on yacc, thanks to sindian
+
19 Mar 2003; Joshua Brindle <method@gentoo.org> selinux-small-2003011510-r2.ebuild:
This selinux-small actually works, installs the appropriate stuff, installs a
default policy and now labels the filesystem in pkg_config
diff --git a/sys-apps/selinux-small/files/selinux-small-2003011510-bison.diff b/sys-apps/selinux-small/files/selinux-small-2003011510-bison.diff
new file mode 100644
index 000000000000..ed2a256e7015
--- /dev/null
+++ b/sys-apps/selinux-small/files/selinux-small-2003011510-bison.diff
@@ -0,0 +1,12 @@
+diff -urN selinux/module/checkpolicy/Makefile selinux-patched/module/checkpolicy/Makefile
+--- selinux/module/checkpolicy/Makefile 2002-09-23 12:10:02.000000000 -0400
++++ selinux-patched/module/checkpolicy/Makefile 2003-03-20 14:26:01.000000000 -0500
+@@ -17,6 +17,8 @@
+ OPTIONS =
+ endif
+
++YACC = bison -y
++
+ CFLAGS = -g $(OPTIONS) -I$(LSMDIR)/include -Wall -O2 -pipe -include $(MODDIR)/ss/global.h -I$(MODDIR)/include -I$(MODDIR)/ss
+
+ OBJS = ebitmap.o queue.o hashtab.o symtab.o sidtab.o avtab.o policydb.o services.o y.tab.o lex.yy.o checkpolicy.o
diff --git a/sys-apps/selinux-small/selinux-small-2003011510-r2.ebuild b/sys-apps/selinux-small/selinux-small-2003011510-r2.ebuild
index 891bf536f8fa..b521cc5728c6 100644
--- a/sys-apps/selinux-small/selinux-small-2003011510-r2.ebuild
+++ b/sys-apps/selinux-small/selinux-small-2003011510-r2.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/selinux-small/selinux-small-2003011510-r2.ebuild,v 1.1 2003/03/20 06:27:21 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/selinux-small/selinux-small-2003011510-r2.ebuild,v 1.2 2003/03/21 19:19:02 method Exp $
DESCRIPTION="SELinux policy compiler and example policies"
HOMEPAGE="http://www.nsa.gov/selinux"
SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz
http://www.coker.com.au/selinux/selinux-small/selinux-small_2003011510-7.diff.gz
http://www.coker.com.au/selinux/policy.tgz"
+
LICENSE="GPL-1"
SLOT="0"
S="${WORKDIR}/selinux"
@@ -17,8 +18,7 @@ LIBSECURE="-I${S}/libsecure/include -L${S}/libsecure/src"
KEYWORDS="~x86"
IUSE="selinux"
DEPEND="<sys-libs/glibc-2.3.2
- >=selinux-sources-2.4.20-r1
- >=yacc-1.9.1"
+ >=selinux-sources-2.4.20-r1"
pkg_setup() {
use selinux || eend 1 "You must have selinux USE var"
@@ -33,7 +33,9 @@ src_compile() {
mv -f Makefile.new Makefile
cd ${S}
+
epatch ${WORKDIR}/selinux-small_2003011510-7.diff
+ epatch ${FILESDIR}/${P}-bison.diff
einfo "Compiling checkpolicy"
cd ${S}/module