summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-24 23:23:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-24 23:23:03 +0000
commitf5b2d27e5f093a24694c4974b628b1c092fdebf0 (patch)
tree1f07cd9a652bf6e48193cf7bcbe2dcd6eff29181 /sys-apps/util-linux/util-linux-2.12q.ebuild
parent(#92832) Fix misformatted patch. (diff)
downloadgentoo-2-f5b2d27e5f093a24694c4974b628b1c092fdebf0.tar.gz
gentoo-2-f5b2d27e5f093a24694c4974b628b1c092fdebf0.tar.bz2
gentoo-2-f5b2d27e5f093a24694c4974b628b1c092fdebf0.zip
dont build fdisk on m68k and fix a simple overflow (fixes from Debian)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.12q.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.12q.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/util-linux/util-linux-2.12q.ebuild b/sys-apps/util-linux/util-linux-2.12q.ebuild
index fad6e2e5daf7..9912de841c38 100644
--- a/sys-apps/util-linux/util-linux-2.12q.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12q.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12q.ebuild,v 1.5 2005/04/30 06:50:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12q.ebuild,v 1.6 2005/05/24 23:23:03 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -79,6 +79,12 @@ src_unpack() {
# swapon gets confused by symlinks in /dev #69162
epatch ${FILESDIR}/${PN}-2.12p-swapon-check-symlinks.patch
+ # fix simple buffer overflow (from Debian)
+ epatch ${FILESDIR}/${PN}-2.12q-debian-10cfdisk.patch
+
+ # don't build fdisk on m68k
+ epatch ${FILESDIR}/${PN}-2.12q-no-m68k-fdisk.patch
+
# Enable random features
local mconfigs="MCONFIG"
use old-crypt && mconfigs="${mconfigs} ${OLD_CRYPT_P}/MCONFIG"