summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-12-10 05:03:42 +0000
committerDonny Davies <woodchip@gentoo.org>2002-12-10 05:03:42 +0000
commit37f17fd3d77a030be9a5974a4de8d810209786ef (patch)
tree4b55a11968ac064728b49b80a592948c661f733c /sys-apps/xfsdump
parentadd a valid shell reminder (diff)
downloadgentoo-2-37f17fd3d77a030be9a5974a4de8d810209786ef.tar.gz
gentoo-2-37f17fd3d77a030be9a5974a4de8d810209786ef.tar.bz2
gentoo-2-37f17fd3d77a030be9a5974a4de8d810209786ef.zip
chase latest XFS utils
Diffstat (limited to 'sys-apps/xfsdump')
-rw-r--r--sys-apps/xfsdump/ChangeLog6
-rw-r--r--sys-apps/xfsdump/files/digest-xfsdump-2.2.41
-rw-r--r--sys-apps/xfsdump/xfsdump-2.2.4.ebuild42
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-apps/xfsdump/ChangeLog b/sys-apps/xfsdump/ChangeLog
index 7055684ec34f..63d4065cc44d 100644
--- a/sys-apps/xfsdump/ChangeLog
+++ b/sys-apps/xfsdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/xfsdump
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/ChangeLog,v 1.5 2002/10/05 08:25:36 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/ChangeLog,v 1.6 2002/12/10 05:03:42 woodchip Exp $
+
+*xfsdump-2.2.4 (09 Dec 2002)
+
+ 09 Dec 2002; Donny Davies <woodchip@gentoo.org> : Chase latest release.
*xfsdump-2.1.5 (27 Sep 2002)
diff --git a/sys-apps/xfsdump/files/digest-xfsdump-2.2.4 b/sys-apps/xfsdump/files/digest-xfsdump-2.2.4
new file mode 100644
index 000000000000..8bfff33003cb
--- /dev/null
+++ b/sys-apps/xfsdump/files/digest-xfsdump-2.2.4
@@ -0,0 +1 @@
+MD5 7a75c9797f7637e0c639fde8c5efae73 xfsdump-2.2.4.src.tar.gz 561490
diff --git a/sys-apps/xfsdump/xfsdump-2.2.4.ebuild b/sys-apps/xfsdump/xfsdump-2.2.4.ebuild
new file mode 100644
index 000000000000..21210605cd1e
--- /dev/null
+++ b/sys-apps/xfsdump/xfsdump-2.2.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/xfsdump-2.2.4.ebuild,v 1.1 2002/12/10 05:03:42 woodchip Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="xfs dump/restore utilities"
+
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+DEPEND="sys-apps/e2fsprogs sys-apps/xfsprogs sys-apps/dmapi sys-apps/attr"
+
+src_compile() {
+ OPTIMIZER="${CFLAGS}"
+ DEBUG=-DNDEBUG
+
+ autoconf || die
+
+ ./configure --prefix=/usr \
+ --libexecdir=/lib || die
+
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ # 5) We now fix some absolute path symlinks in various makefiles
+ local x
+ for x in dump restore
+ do
+ cp ${x}/Makefile ${x}/Makefile.orig
+ sed -e 's:$(INSTALL) -S $(PKG_.*_DIR)/\(.*\) \(.*/.*\):$(INSTALL) -S ../../sbin/\1 \2:' ${x}/Makefile.orig > ${x}/Makefile
+ done
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}