summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-28 05:22:59 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-28 05:22:59 +0000
commit242e40fac80efa772f51e293b4fa9bd3ccb93af1 (patch)
treef69eb54da74cb300f3e7a05c1760168fcdd17da9 /sys-apps
parentfixed ppc patch for nv and 4.3.0 (diff)
downloadgentoo-2-242e40fac80efa772f51e293b4fa9bd3ccb93af1.tar.gz
gentoo-2-242e40fac80efa772f51e293b4fa9bd3ccb93af1.tar.bz2
gentoo-2-242e40fac80efa772f51e293b4fa9bd3ccb93af1.zip
bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/module-init-tools/ChangeLog8
-rw-r--r--sys-apps/module-init-tools/files/digest-module-init-tools-0.9.102
-rw-r--r--sys-apps/module-init-tools/module-init-tools-0.9.10.ebuild118
3 files changed, 127 insertions, 1 deletions
diff --git a/sys-apps/module-init-tools/ChangeLog b/sys-apps/module-init-tools/ChangeLog
index f9460a1e9831..16dcce41d36f 100644
--- a/sys-apps/module-init-tools/ChangeLog
+++ b/sys-apps/module-init-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/module-init-tools
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.11 2003/02/17 23:31:11 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.12 2003/02/28 05:20:05 lostlogic Exp $
+
+*module-init-tools-0.9.10 (27 Feb 2003)
+
+ 27 Feb 2003; Brandon Low <lostlogic@gentoo.org>
+ module-init-tools-0.9.10.ebuild:
+ Bump, and drop a patch that is now merged mainline
*module-init-tools-0.9.9 (01 Feb 2003)
diff --git a/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.10 b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.10
new file mode 100644
index 000000000000..b1a08c3a2d21
--- /dev/null
+++ b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.10
@@ -0,0 +1,2 @@
+MD5 f8a88214e06d102a2044af3b95256f2a module-init-tools-0.9.10.tar.bz2 99143
+MD5 6c5d2a62ae98708f3ad0c57900d63919 modutils-2.4.22.tar.bz2 219457
diff --git a/sys-apps/module-init-tools/module-init-tools-0.9.10.ebuild b/sys-apps/module-init-tools/module-init-tools-0.9.10.ebuild
new file mode 100644
index 000000000000..51377546491a
--- /dev/null
+++ b/sys-apps/module-init-tools/module-init-tools-0.9.10.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.10.ebuild,v 1.1 2003/02/28 05:20:05 lostlogic Exp $
+
+# This includes backwards compatability for stable kernels
+IUSE=""
+
+inherit flag-o-matic
+
+inherit eutils
+
+MYP="${P/_pre1/-pre}"
+S="${WORKDIR}/${MYP}"
+MODUTILS_PV="2.4.22"
+DESCRIPTION="Kernel module tools for the development kernel >=2.5.48"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/rusty/modules/${MYP}.tar.bz2
+ http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.4/modutils-${MODUTILS_PV}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/rusty/modules"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-kernel/development-sources-2.5.48"
+
+src_compile() {
+ filter-flags -fPIC
+
+ einfo "Building modutils..."
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+
+ econf \
+ --disable-strip \
+ --prefix=/ \
+ --enable-insmod-static \
+ --disable-zlib \
+ ${myconf}
+ emake || die "emake modultils failed"
+
+ einfo "Building module-init-tools..."
+ cd ${S}
+
+ econf \
+ --prefix=/ \
+ ${myconf}
+
+ emake || die "emake module-init-tools failed"
+}
+
+src_install () {
+
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+ einstall prefix="${D}"
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+
+ cd ${S}
+ # This copies the old version of modutils to *.old so it still works
+ # with kernels <= 2.4
+ # This code was borrowed from the module-init-tools Makefile
+ for f in lsmod modprobe rmmod depmod insmod; do
+ if [ -L ${D}/sbin/${f} ]; then
+ ln -sf `ls -l ${D}/sbin/${f} | \
+ sed 's/.* -> //'`.old ${D}/sbin/${f};
+ fi;
+ mv ${D}/sbin/${f} ${D}/sbin/${f}.old;
+ done
+# make prefix=${D} move-old-targets || die "Renaming old bins to *.old failed"
+
+ einstall prefix=${D}
+
+ # Install the modules.conf2modprobe.conf tool, so we can update
+ # modprobe.conf.
+ into /
+ dosbin ${S}/generate-modprobe.conf
+
+ # Create the new modprobe.conf
+ dodir /etc
+
+ if [ -f /etc/modules.conf ]; then
+ einfo "Generating /etc/modprobe.conf ..."
+ PATH="${D}/sbin:${PATH}" \
+ ${S}/generate-modprobe.conf ${D}/etc/modprobe.conf \
+ || die "Could not create modprobe.conf"
+ fi
+ if [ ! -f ${ROOT}/etc/modprobe.devfs ]; then
+ # Support file for the devfs hack .. needed else modprobe borks.
+ # Baselayout-1.8.6.3 or there abouts will have a modules-update that
+ # will correctly generate /etc/modprobe.devfs ....
+ echo "### This file is automatically generated by modules-update" \
+ > ${D}/etc/modprobe.devfs
+ fi
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ # Notify user of evilness, hope for a better way ;-)
+ echo ""
+ einfo "This overwrites the modutils files, so if you remove this,"
+ einfo "remember to remerge modutils. However, this package has"
+ einfo "installed a copy of the modutils files with suffix .old"
+ einfo "in your /sbin directory, which will automatically be used"
+ einfo "when needed."
+ echo ""
+}
+
+
+
+pkg_postrm() {
+ if [ "$(best_version ${PN})" == "${CATEGORY}/${PF}" -a ! -f /sbin/insmod ]; then
+ ewarn "Uninstalling module-init-tools has left you"
+ ewarn "without a modutils installtion. we recommend"
+ ewarn "emerging modutils immediately or remerging"
+ ewarn "module-init-tools."
+ fi
+}
+