summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2004-07-23 12:51:27 +0000
committerAlexander Gabert <pappy@gentoo.org>2004-07-23 12:51:27 +0000
commit2c4dd86d2c1ce47ef0b53677fdc2308902155172 (patch)
tree3f5fd852fd4c66257b70684b97190a4060bfc197 /sys-apps
parentnew beta (Manifest recommit) (diff)
downloadgentoo-2-2c4dd86d2c1ce47ef0b53677fdc2308902155172.tar.gz
gentoo-2-2c4dd86d2c1ce47ef0b53677fdc2308902155172.tar.bz2
gentoo-2-2c4dd86d2c1ce47ef0b53677fdc2308902155172.zip
changed logic for filtering/suppressing PIE building, thanks to solar
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpufreqd/ChangeLog6
-rw-r--r--sys-apps/cpufreqd/Manifest10
-rw-r--r--sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild11
-rw-r--r--sys-apps/cpufreqd/cpufreqd-1.1.2.ebuild11
-rw-r--r--sys-apps/cpufreqd/cpufreqd-1.1.ebuild11
5 files changed, 22 insertions, 27 deletions
diff --git a/sys-apps/cpufreqd/ChangeLog b/sys-apps/cpufreqd/ChangeLog
index d76c960d5b89..92386b8f3fed 100644
--- a/sys-apps/cpufreqd/ChangeLog
+++ b/sys-apps/cpufreqd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/cpufreqd
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/ChangeLog,v 1.13 2004/07/21 23:54:03 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/ChangeLog,v 1.14 2004/07/23 12:51:27 pappy Exp $
+
+ 23 Jul 2004; Alexander Gabert <pappy@gentoo.org> cpufreqd-1.1.1.ebuild,
+ cpufreqd-1.1.2.ebuild, cpufreqd-1.1.ebuild:
+ changed logic for filtering/suppressing PIE building, thanks to solar
22 Jul 2004; Alexander Gabert <pappy@gentoo.org> cpufreqd-1.1.1.ebuild,
cpufreqd-1.1.2.ebuild, cpufreqd-1.1.ebuild:
diff --git a/sys-apps/cpufreqd/Manifest b/sys-apps/cpufreqd/Manifest
index abcb229740f2..53cdabe956a6 100644
--- a/sys-apps/cpufreqd/Manifest
+++ b/sys-apps/cpufreqd/Manifest
@@ -1,8 +1,8 @@
-MD5 7045e5b3c09538a974c3144419e2eb86 ChangeLog 1807
-MD5 b9e30168ef2e0e48446c567e5a16b61f cpufreqd-1.1.1.ebuild 1208
-MD5 21e679abfce49a30a8c1feec2470d945 cpufreqd-1.1.2.ebuild 1277
-MD5 133050722558abecbbd00ef6a28d2a41 cpufreqd-1.1.ebuild 1279
+MD5 032003cbae98474c87411209086767a6 cpufreqd-1.1.2.ebuild 1248
+MD5 c7d1a27d0204cebc944ffbf2c7917883 cpufreqd-1.1.ebuild 1252
+MD5 540d8a62cc1ca329c7e55716e944e062 cpufreqd-1.1.1.ebuild 1181
+MD5 178ae295f1abf3912ab939e04dc79e3a ChangeLog 2000
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 8917ce64fc2e2eb0da260929ea971f98 files/digest-cpufreqd-1.1 71
-MD5 82e5687ec7d54db66926a515248a0d72 files/digest-cpufreqd-1.1.1 66
MD5 d80d3c22801187272f72a7de7fbd1bb1 files/digest-cpufreqd-1.1.2 66
+MD5 82e5687ec7d54db66926a515248a0d72 files/digest-cpufreqd-1.1.1 66
diff --git a/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild b/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild
index 20e3f8316990..6d38c994b5e1 100644
--- a/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild
+++ b/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild,v 1.4 2004/07/21 23:54:03 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild,v 1.5 2004/07/23 12:51:27 pappy Exp $
inherit eutils flag-o-matic
@@ -12,18 +12,15 @@ DEPEND=">=sys-apps/sed-4"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE="pie hardened"
+IUSE=""
src_unpack() {
unpack ${A}
cd ${S}
sed -i '/^DAEMON=/s:/sbin/:/usr/sbin/:' scripts/gentoo/cpufreqd
- if ( use hardened || use pie )
- then
- append-flags "-fno-pie"
- append-ldflags "-fno-pie"
- fi
+ # cpufreqd segfaults when built as PIE
+ filter-flags "-fpie" "-fPIE" "-Wl,-pie"
}
src_install() {
diff --git a/sys-apps/cpufreqd/cpufreqd-1.1.2.ebuild b/sys-apps/cpufreqd/cpufreqd-1.1.2.ebuild
index 7fa6fbdbd3a6..0617554b18f8 100644
--- a/sys-apps/cpufreqd/cpufreqd-1.1.2.ebuild
+++ b/sys-apps/cpufreqd/cpufreqd-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/cpufreqd-1.1.2.ebuild,v 1.2 2004/07/21 23:54:03 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/cpufreqd-1.1.2.ebuild,v 1.3 2004/07/23 12:51:27 pappy Exp $
inherit eutils flag-o-matic
@@ -12,7 +12,7 @@ DEPEND=">=sys-apps/sed-4"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE="pie hardened"
+IUSE=""
src_unpack() {
unpack ${A}
@@ -23,11 +23,8 @@ src_unpack() {
src_compile() {
cd ${S}
- if ( use hardened || use pie )
- then
- append-flags "-fno-pie"
- append-ldflags "-fno-pie"
- fi
+ # cpufreqd segfaults when built as PIE
+ filter-flags "-fpie" "-fPIE" "-Wl,-pie"
econf || die "econf failed for ${P}"
}
diff --git a/sys-apps/cpufreqd/cpufreqd-1.1.ebuild b/sys-apps/cpufreqd/cpufreqd-1.1.ebuild
index 06e0cfd81dd5..170f03cdbeed 100644
--- a/sys-apps/cpufreqd/cpufreqd-1.1.ebuild
+++ b/sys-apps/cpufreqd/cpufreqd-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/cpufreqd-1.1.ebuild,v 1.4 2004/07/21 23:54:03 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/cpufreqd-1.1.ebuild,v 1.5 2004/07/23 12:51:27 pappy Exp $
inherit eutils flag-o-matic
@@ -13,7 +13,7 @@ DEPEND=">=sys-apps/sed-4"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* x86 ppc"
-IUSE="pie hardened"
+IUSE=""
src_unpack() {
unpack ${A}
@@ -21,11 +21,8 @@ src_unpack() {
#correct the init-script
sed -i -e s:/bin/cpufreqd:/usr/sbin/cpufreqd: ${S}/scripts/gentoo/cpufreqd
- if ( use hardened || use pie )
- then
- append-flags "-fno-pie"
- append-ldflags "-fno-pie"
- fi
+ # cpufreqd segfaults when built as PIE
+ filter-flags "-fpie" "-fPIE" "-Wl,-pie"
}
src_install() {