summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-06-12 00:28:49 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-06-12 00:28:49 +0000
commit303f1c658c9bf83132ad2c2bd90aebfc780ab7f3 (patch)
tree7bd550f7a5ee31d9c0a1c4d9d323c29920d2fd5d /sys-apps
parentNew hotplug for x86, fixing bug 21877 and generally updating hotplug function... (diff)
downloadgentoo-2-303f1c658c9bf83132ad2c2bd90aebfc780ab7f3.tar.gz
gentoo-2-303f1c658c9bf83132ad2c2bd90aebfc780ab7f3.tar.bz2
gentoo-2-303f1c658c9bf83132ad2c2bd90aebfc780ab7f3.zip
New hotplug for x86, fixing bug 21877 and generally updating hotplug functionality
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hotplug/ChangeLog10
-rw-r--r--sys-apps/hotplug/Manifest4
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-20030501-r22
-rw-r--r--sys-apps/hotplug/hotplug-20030501-r2.ebuild58
4 files changed, 69 insertions, 5 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 1870dc1978c3..ee21827517be 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.17 2003/06/11 00:23:02 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.18 2003/06/12 00:28:43 drobbins Exp $
+*hotplug-20030501-r2 (11 Jun 2003)
+
+ 11 Jun 2003; Daniel Robbins <drobbins@gentoo.org> hotplug-20030501-r2.ebuild:
+ Now creates /var/run/usb directory, closing bug #21877. Unmasking on x86.
+
10 Jun 2003; <msterret@gentoo.org> hotplug-20020826-r1.ebuild,
- hotplug-20020826-r2.ebuild, hotplug-20020826.ebuild:
- DEPEND on sed >= 4
+ hotplug-20020826-r2.ebuild, hotplug-20020826.ebuild: DEPEND on sed >= 4
*hotplug-20030501-r1 (27 May 2003)
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index 2a9309bbb370..4d3479d7f968 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -4,8 +4,8 @@ MD5 cede312e2783d607cb0dd3c594cd20e3 hotplug-20030501.ebuild 1488
MD5 4add5675ce1bf7372ff9189f27c2317a hotplug-20020114.ebuild 1492
MD5 77efe735c313997ccc11119d2a08713c hotplug-20020826-r1.ebuild 1552
MD5 ff4869e458ad17b4691293ed22b2fcc7 hotplug-20020401-r1.ebuild 1467
-MD5 8fbaa675299bbd9148e7233677d9bd17 hotplug-20030501-r2.ebuild 1515
-MD5 09e3a9ec63e1038cfaf5ff45fce21fd2 ChangeLog 3236
+MD5 d7db0885a4edefe3f3841e465394dfee hotplug-20030501-r2.ebuild 1517
+MD5 a3d5f743936c515a7aafd51ee6ca8085 ChangeLog 3236
MD5 dd670e698d3616cbfe662ce54e6511f5 hotplug-20020826.ebuild 1452
MD5 64aa2a1e7fb2526bb52c6fd4b5f24608 files/digest-hotplug-20020826-r1 221
MD5 0e5a1a005fcfa0e242be02e9ef99de7a files/digest-hotplug-20020826-r2 224
diff --git a/sys-apps/hotplug/files/digest-hotplug-20030501-r2 b/sys-apps/hotplug/files/digest-hotplug-20030501-r2
new file mode 100644
index 000000000000..65275d83c5b2
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20030501-r2
@@ -0,0 +1,2 @@
+MD5 bd3bd7de70dd06b37daf86feb5970c77 hotplug-2003_05_01.tar.gz 41930
+MD5 89835f43f1568b40db98759b0ad7380a hotplug-20030501-r1-gentoo-patches.tar.bz2 3308
diff --git a/sys-apps/hotplug/hotplug-20030501-r2.ebuild b/sys-apps/hotplug/hotplug-20030501-r2.ebuild
new file mode 100644
index 000000000000..a7997a95d3bb
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20030501-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20030501-r2.ebuild,v 1.1 2003/06/12 00:28:43 drobbins Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-20030501-r1-gentoo-patches.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~hppa"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/etc/hotplug
+ epatch ${WORKDIR}/hotplug-patches/
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+ dodir /var/run/usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}
+