summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-05 12:48:55 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-05 12:48:55 +0000
commit36596a516a7d607d6b4bfc733ed68533f1d87302 (patch)
tree2dad1bb2a5410c1661cfdcb25429f18b04288763 /sys-apps
parentMasked util-linux 2.11t (diff)
downloadgentoo-2-36596a516a7d607d6b4bfc733ed68533f1d87302.tar.gz
gentoo-2-36596a516a7d607d6b4bfc733ed68533f1d87302.tar.bz2
gentoo-2-36596a516a7d607d6b4bfc733ed68533f1d87302.zip
Version bump.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.11t2
-rw-r--r--sys-apps/util-linux/util-linux-2.11t.ebuild75
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 9e25f978d70a..1ea1fa002100 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.10 2002/07/25 15:32:59 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.11 2002/08/05 12:48:55 aliz Exp $
+
+*util-linux-2.11t (05 Aug 2002)
+
+ 05 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> util-linux-2.11t.ebuild:
+ Version bump.
*util-linux-2.11r-r1 (9 Jul 2002)
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.11t b/sys-apps/util-linux/files/digest-util-linux-2.11t
new file mode 100644
index 000000000000..ac3462081f77
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.11t
@@ -0,0 +1,2 @@
+MD5 52afadbeaca00dfe8870f73bf7b833a1 util-linux-2.11t.tar.gz 1560981
+MD5 16a8654556dcd1ea21d00c14291ecb28 util-linux-2.11r.patch.gz 18744
diff --git a/sys-apps/util-linux/util-linux-2.11t.ebuild b/sys-apps/util-linux/util-linux-2.11t.ebuild
new file mode 100644
index 000000000000..7c3e272ce7a6
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.11t.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11t.ebuild,v 1.1 2002/08/05 12:48:55 aliz Exp $
+
+CRYPT_PATCH_P=${PN}-${PV/1t/1r}
+S=${WORKDIR}/${P}
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
+ crypt? ( http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${CRYPT_PATCH_P}.patch.gz )"
+HOMEPAGE=""
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ sys-apps/pam-login"
+
+RDEPEND="$DEPEND sys-devel/perl
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+
+ if [ ! -z "`use crypt`" ]
+ then
+ gunzip -c ${DISTDIR}/${CRYPT_PATCH_P}.patch.gz | patch -p1 || die
+ fi
+
+ cp MCONFIG MCONFIG.orig
+ sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
+ MCONFIG.orig > MCONFIG
+}
+
+src_compile() {
+
+ ./configure || die
+
+ if [ -z "`use nls`" ]
+ then
+ cp defines.h defines.h.orig
+ grep -v "ENABLE_NLS" \
+ defines.h.orig > defines.h
+ cp defines.h defines.h.orig
+ grep -v "HAVE_libintl_h" \
+ defines.h.orig > defines.h
+
+ cp Makefile Makefile.orig
+ sed -e "s:SUBDIRS=po \\\:SUBDIRS= \\\:g" \
+ Makefile.orig > Makefile
+ fi
+
+ emake LDFLAGS="" || die
+ cd sys-utils; makeinfo *.texi || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto licenses
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}
+