summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-28 15:44:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-28 15:44:24 +0000
commit7c82019c5c6f08a7bcf2882d8e1cdc98257f793c (patch)
treebe029ed27145300e2c56e9095affee9e70a973f5 /sys-apps
parentVersion bump: new stable series. Removed 2.1.x development series. (Manifest ... (diff)
downloadgentoo-2-7c82019c5c6f08a7bcf2882d8e1cdc98257f793c.tar.gz
gentoo-2-7c82019c5c6f08a7bcf2882d8e1cdc98257f793c.tar.bz2
gentoo-2-7c82019c5c6f08a7bcf2882d8e1cdc98257f793c.zip
use tc-getCC
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/baselayout-1.10.3.ebuild6
-rw-r--r--sys-apps/baselayout/baselayout-1.10.4.ebuild6
-rw-r--r--sys-apps/baselayout/baselayout-1.11.4.ebuild6
-rw-r--r--sys-apps/baselayout/baselayout-1.9.4-r3.ebuild8
-rw-r--r--sys-apps/baselayout/baselayout-1.9.4-r4.ebuild8
-rw-r--r--sys-apps/baselayout/baselayout-1.9.4-r5.ebuild8
-rw-r--r--sys-apps/baselayout/baselayout-1.9.4-r6.ebuild8
7 files changed, 25 insertions, 25 deletions
diff --git a/sys-apps/baselayout/baselayout-1.10.3.ebuild b/sys-apps/baselayout/baselayout-1.10.3.ebuild
index 3b848c8ace07..3be4406ce631 100644
--- a/sys-apps/baselayout/baselayout-1.10.3.ebuild
+++ b/sys-apps/baselayout/baselayout-1.10.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.3.ebuild,v 1.8 2004/10/16 17:05:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.3.ebuild,v 1.9 2004/10/28 15:44:24 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
SV=1.5.2 # rc-scripts version
SVREV= # rc-scripts rev
@@ -43,7 +43,7 @@ src_unpack() {
src_compile() {
use static && append-ldflags -static
- make -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die
}
diff --git a/sys-apps/baselayout/baselayout-1.10.4.ebuild b/sys-apps/baselayout/baselayout-1.10.4.ebuild
index 0add8b9f3b74..7dc31ebb4ab7 100644
--- a/sys-apps/baselayout/baselayout-1.10.4.ebuild
+++ b/sys-apps/baselayout/baselayout-1.10.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.4.ebuild,v 1.8 2004/10/16 17:05:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.4.ebuild,v 1.9 2004/10/28 15:44:24 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
SV=1.5.3 # rc-scripts version
SVREV= # rc-scripts rev
@@ -43,7 +43,7 @@ src_unpack() {
src_compile() {
use static && append-ldflags -static
- make -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die
}
diff --git a/sys-apps/baselayout/baselayout-1.11.4.ebuild b/sys-apps/baselayout/baselayout-1.11.4.ebuild
index a0a14fb381c3..0d9853d9078d 100644
--- a/sys-apps/baselayout/baselayout-1.11.4.ebuild
+++ b/sys-apps/baselayout/baselayout-1.11.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.11.4.ebuild,v 1.1 2004/10/26 02:23:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.11.4.ebuild,v 1.2 2004/10/28 15:44:24 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
SV=1.6.4 # rc-scripts version
SVREV= # rc-scripts rev
@@ -40,7 +40,7 @@ src_unpack() {
src_compile() {
use static && append-ldflags -static
- make -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die
}
diff --git a/sys-apps/baselayout/baselayout-1.9.4-r3.ebuild b/sys-apps/baselayout/baselayout-1.9.4-r3.ebuild
index 843b1f3ce6fa..cb2e196fa2a7 100644
--- a/sys-apps/baselayout/baselayout-1.9.4-r3.ebuild
+++ b/sys-apps/baselayout/baselayout-1.9.4-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r3.ebuild,v 1.6 2004/10/16 17:05:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r3.ebuild,v 1.7 2004/10/28 15:44:24 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
SV=1.4.16 # rc-scripts version
SVREV= # rc-scripts rev
@@ -81,7 +81,7 @@ src_compile() {
echo "${ROOT}" > ${T}/ROOT
einfo "Building utilities..."
- make -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
if ! use build; then
@@ -94,7 +94,7 @@ src_compile() {
# the shared obj by default anyway! The other option is to
# refrain from building sulogin, but that isn't a good option.
# (09 Jul 2004 agriffis)
- emake -C ${S2}/src CC="${CC:-gcc}" LD="${CC:-gcc}" \
+ emake -C ${S2}/src CC="$(tc-getCC)" LD="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} -D_GNU_SOURCE" \
LCRYPT="-lcrypt" || die "problem compiling sysvinit"
else
diff --git a/sys-apps/baselayout/baselayout-1.9.4-r4.ebuild b/sys-apps/baselayout/baselayout-1.9.4-r4.ebuild
index 398d11452464..f24ea74085ca 100644
--- a/sys-apps/baselayout/baselayout-1.9.4-r4.ebuild
+++ b/sys-apps/baselayout/baselayout-1.9.4-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r4.ebuild,v 1.5 2004/10/16 17:05:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r4.ebuild,v 1.6 2004/10/28 15:44:24 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
SV=1.4.16 # rc-scripts version
SVREV= # rc-scripts rev
@@ -81,7 +81,7 @@ src_compile() {
echo "${ROOT}" > ${T}/ROOT
einfo "Building utilities..."
- make -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
if ! use build; then
@@ -94,7 +94,7 @@ src_compile() {
# the shared obj by default anyway! The other option is to
# refrain from building sulogin, but that isn't a good option.
# (09 Jul 2004 agriffis)
- emake -C ${S2}/src CC="${CC:-gcc}" LD="${CC:-gcc}" \
+ emake -C ${S2}/src CC="$(tc-getCC)" LD="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} -D_GNU_SOURCE" \
LCRYPT="-lcrypt" || die "problem compiling sysvinit"
else
diff --git a/sys-apps/baselayout/baselayout-1.9.4-r5.ebuild b/sys-apps/baselayout/baselayout-1.9.4-r5.ebuild
index 6253a7943b56..dcc6a01e0243 100644
--- a/sys-apps/baselayout/baselayout-1.9.4-r5.ebuild
+++ b/sys-apps/baselayout/baselayout-1.9.4-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r5.ebuild,v 1.2 2004/10/19 20:16:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r5.ebuild,v 1.3 2004/10/28 15:44:24 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
SV=1.4.16 # rc-scripts version
SVREV= # rc-scripts rev
@@ -86,7 +86,7 @@ src_compile() {
echo "${ROOT}" > ${T}/ROOT
einfo "Building utilities..."
- make -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
if ! use build; then
@@ -99,7 +99,7 @@ src_compile() {
# the shared obj by default anyway! The other option is to
# refrain from building sulogin, but that isn't a good option.
# (09 Jul 2004 agriffis)
- emake -C ${S2}/src CC="${CC:-gcc}" LD="${CC:-gcc}" \
+ emake -C ${S2}/src CC="$(tc-getCC)" LD="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} -D_GNU_SOURCE" \
LCRYPT="-lcrypt" || die "problem compiling sysvinit"
else
diff --git a/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild b/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild
index 1838a17cc1a1..2520236d83d7 100644
--- a/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild
+++ b/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild,v 1.1 2004/10/22 04:08:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild,v 1.2 2004/10/28 15:44:24 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
SV=1.4.16 # rc-scripts version
SVREV= # rc-scripts rev
@@ -87,7 +87,7 @@ src_compile() {
echo "${ROOT}" > ${T}/ROOT
einfo "Building utilities..."
- make -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
+ make -C ${S}/src CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
if ! use build; then
@@ -100,7 +100,7 @@ src_compile() {
# the shared obj by default anyway! The other option is to
# refrain from building sulogin, but that isn't a good option.
# (09 Jul 2004 agriffis)
- emake -C ${S2}/src CC="${CC:-gcc}" LD="${CC:-gcc}" \
+ emake -C ${S2}/src CC="$(tc-getCC)" LD="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} -D_GNU_SOURCE" \
LCRYPT="-lcrypt" || die "problem compiling sysvinit"
else