summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-30 00:31:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-30 00:31:05 +0000
commit8d3c30a9b31bfc2ce18a26707bd0bccfb05a38aa (patch)
tree01bc93e5cbdc58a04574b59613125583accfb2f2 /sys-apps
parentPass command-line arguments to the qcad binary. (diff)
downloadgentoo-2-8d3c30a9b31bfc2ce18a26707bd0bccfb05a38aa.tar.gz
gentoo-2-8d3c30a9b31bfc2ce18a26707bd0bccfb05a38aa.tar.bz2
gentoo-2-8d3c30a9b31bfc2ce18a26707bd0bccfb05a38aa.zip
Fix memleak in chmod #87490 and update DIR_COLORS with stuff from Fedora and #104087.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog9
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r7.ebuild159
-rw-r--r--sys-apps/coreutils/files/DIR_COLORS35
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.2.1-r72
4 files changed, 189 insertions, 16 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 73dc8c4d8aaa..4f8954253733 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.137 2005/08/18 13:08:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.138 2005/08/30 00:31:05 vapier Exp $
+
+*coreutils-5.2.1-r7 (30 Aug 2005)
+
+ 30 Aug 2005; Mike Frysinger <vapier@gentoo.org> files/DIR_COLORS,
+ +coreutils-5.2.1-r7.ebuild:
+ Fix memleak in chmod #87490 and update DIR_COLORS with stuff from Fedora and
+ #104087.
18 Aug 2005; Mike Frysinger <vapier@gentoo.org> coreutils-5.2.1-r6.ebuild:
Merge support for using coreutils on non-GNU systems by Diego Pettenò
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild
new file mode 100644
index 000000000000..2cd0a5a59dfe
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r7.ebuild,v 1.1 2005/08/30 00:31:05 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+PATCH_VER=1.0
+PATCHDIR="${WORKDIR}/patch"
+
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="acl build nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ acl? ( sys-apps/acl sys-apps/attr )
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.49
+ =sys-devel/automake-1.8*
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/m4-1.4-r1
+ !elibc_uclibc? ( sys-apps/help2man )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ EPATCH_MULTI_MSG="Applying patches from Mandrake ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/mandrake
+
+ # Apply the ACL/SELINUX patches.
+ if ! use selinux && use acl ; then
+ EPATCH_MULTI_MSG="Applying ACL patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/extra
+
+ # Make sure test is +x #87795
+ chmod a+rx tests/sort/sort-mb-tests
+
+ if use selinux ; then
+ EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
+ fi
+
+ # Sparc32 SMP bug fix -- see bug #46593
+ use sparc && echo -ne "\n\n" >> "${S}"/src/pr.c
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ tc-is-cross-compiler && touch man/*.1
+
+ ebegin "Reconfiguring configure scripts (be patient)"
+ export WANT_AUTOMAKE=1.8
+ export WANT_AUTOCONF=2.5
+
+ mv m4/inttypes.m4 m4/inttypes-eggert.m4
+ touch aclocal.m4 configure config.hin \
+ Makefile.in */Makefile.in */*/Makefile.in
+
+ aclocal -I m4 || die "aclocal"
+ autoconf || die "autoconf"
+ automake || die "automake"
+ eend $?
+}
+
+src_compile() {
+ if ! type -p cvs > /dev/null ; then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+
+ local myconf=""
+ [[ ${USERLAND} == "GNU" ]] \
+ && myconf="${myconf} --bindir=/bin" \
+ || myconf="${myconf} --program-prefix=g"
+
+ econf \
+ --enable-largefile \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ ${myconf} \
+ || die "econf"
+
+ use static && append-ldflags -static
+ emake LDFLAGS="${LDFLAGS}" || die "emake"
+}
+
+src_test() {
+ # Non-root tests will fail if the full path isnt
+ # accessible to non-root users
+ chmod a+rx "${WORKDIR}"
+ addwrite /dev/full
+ export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ make check || die "make check failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ # remove files provided by other packages
+ rm "${D}"/bin/{kill,uptime} # procps
+ rm "${D}"/bin/{groups,su} # shadow
+ rm "${D}"/bin/hostname # net-tools
+ rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
+ # provide by the man-pages package
+ rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
+ rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
+ rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
+
+ insinto /etc
+ doins "${FILESDIR}"/DIR_COLORS
+
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # move non-critical packages into /usr
+ cd "${D}"
+ dodir /usr/bin
+ mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
+ mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
+ mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
+ cd bin
+ local x
+ for x in * ; do
+ dosym /bin/${x} /usr/bin/${x}
+ done
+ fi
+
+ if ! use build ; then
+ cd "${S}"
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+ else
+ rm -r "${D}"/usr/share
+ fi
+}
+
+pkg_postinst() {
+ [[ ${USERLAND} != "GNU" ]] && return 0
+
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [[ -e ${ROOT}/usr/bin/hostname && ! -L ${ROOT}/usr/bin/hostname ]] ; then
+ rm -f "${ROOT}"/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/DIR_COLORS b/sys-apps/coreutils/files/DIR_COLORS
index f9732be03943..2bb98888116e 100644
--- a/sys-apps/coreutils/files/DIR_COLORS
+++ b/sys-apps/coreutils/files/DIR_COLORS
@@ -4,7 +4,7 @@
# You can copy this file to .dir_colors in your $HOME directory to override
# the system defaults.
#
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/files/DIR_COLORS,v 1.11 2005/07/27 22:01:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/files/DIR_COLORS,v 1.12 2005/08/30 00:31:05 vapier Exp $
# COLOR needs one of these arguments: 'tty' colorizes output to ttys, but not
# pipes. 'all' adds color characters to all output. 'none' shuts colorization
@@ -18,10 +18,9 @@ COLOR tty
OPTIONS -F -T 0
# Below, there should be one TERM entry for each termtype that is colorizable
-TERM linux
-TERM linux-c
-TERM mach-color
-TERM console
+TERM ansi
+TERM color-xterm
+TERM color_xterm
TERM con132x25
TERM con132x30
TERM con132x43
@@ -33,22 +32,28 @@ TERM con80x43
TERM con80x50
TERM con80x60
TERM cons25
+TERM console
+TERM dtterm
+TERM Eterm
TERM gnome
-TERM xterm
-TERM xterm-color
-TERM xterm-256color
-TERM xterm-debian
-TERM color-xterm
-TERM color_xterm
+TERM kon
+TERM konsole
+TERM kterm
+TERM linux
+TERM linux-c
+TERM mach-color
TERM rxvt
+TERM rxvt-cygwin
+TERM rxvt-cygwin-native
TERM rxvt-unicode
TERM screen
-TERM screen.linux
TERM screen-w
+TERM screen.linux
TERM vt100
-TERM dtterm
-TERM ansi
-TERM Eterm
+TERM xterm
+TERM xterm-256color
+TERM xterm-color
+TERM xterm-debian
# EIGHTBIT, followed by '1' for on, '0' for off. (8-bit output)
EIGHTBIT 1
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.2.1-r7 b/sys-apps/coreutils/files/digest-coreutils-5.2.1-r7
new file mode 100644
index 000000000000..175c9f23a35f
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.2.1-r7
@@ -0,0 +1,2 @@
+MD5 172ee3c315af93d3385ddfbeb843c53f coreutils-5.2.1.tar.bz2 4270776
+MD5 be2482637daad316beb36d4a78533e72 coreutils-5.2.1-patches-1.0.tar.bz2 66693