summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-18 22:22:55 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-18 22:22:55 +0000
commitf9083f89d7739323d394f2b1ab2585f85746978e (patch)
treed773912b644bd335b43571c7716036758ff18751 /sys-apps
parentalso highlight diropts (diff)
downloadgentoo-2-f9083f89d7739323d394f2b1ab2585f85746978e.tar.gz
gentoo-2-f9083f89d7739323d394f2b1ab2585f85746978e.tar.bz2
gentoo-2-f9083f89d7739323d394f2b1ab2585f85746978e.zip
ver bump #45353
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fcron/ChangeLog7
-rw-r--r--sys-apps/fcron/fcron-2.9.4.ebuild105
-rw-r--r--sys-apps/fcron/files/2.9.4-braindead-configure-check.patch16
-rw-r--r--sys-apps/fcron/files/digest-fcron-2.9.41
-rw-r--r--sys-apps/fcron/files/fcron.conf-2.9.423
-rw-r--r--sys-apps/fcron/files/fcron.pam11
-rw-r--r--sys-apps/fcron/files/fcrontab.pam18
7 files changed, 180 insertions, 1 deletions
diff --git a/sys-apps/fcron/ChangeLog b/sys-apps/fcron/ChangeLog
index baf51885af22..a87b0135fd57 100644
--- a/sys-apps/fcron/ChangeLog
+++ b/sys-apps/fcron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/fcron
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/ChangeLog,v 1.22 2004/04/18 21:18:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/ChangeLog,v 1.23 2004/04/18 22:22:55 vapier Exp $
+
+*fcron-2.9.4 (18 Apr 2004)
+
+ 18 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage #45353 by Martin Ehmsen.
18 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
Change the default fcron.{allow,deny} files to allow everyone so that
diff --git a/sys-apps/fcron/fcron-2.9.4.ebuild b/sys-apps/fcron/fcron-2.9.4.ebuild
new file mode 100644
index 000000000000..86530cd92194
--- /dev/null
+++ b/sys-apps/fcron/fcron-2.9.4.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/fcron-2.9.4.ebuild,v 1.1 2004/04/18 22:22:55 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+SRC_URI="http://fcron.free.fr/archives/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~hppa ~amd64"
+IUSE="pam doc selinux"
+
+DEPEND="virtual/editor
+ doc? ( >=app-text/docbook-dsssl-stylesheets-1.77 )
+ selinux? ( sys-libs/libselinux )
+ pam? ( >=sys-libs/pam-0.77 )"
+RDEPEND="!virtual/cron
+ >=sys-apps/cronbase-0.2.1-r3
+ virtual/mta"
+PROVIDE="virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-braindead-configure-check.patch
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ local myconf=
+ use pam \
+ && myconf="${myconf} --with-pam=yes" \
+ || myconf="${myconf} --with-pam=no"
+ use doc && myconf="${myconf} --with-dsssl-dir=/usr/share/sgml/stylesheets/dsssl/docbook"
+ use selinux \
+ && myconf="${myconf} --with-selinux=yes" \
+ || myconf="${myconf} --with-selinux=no"
+ econf \
+ --with-username=cron \
+ --with-groupname=cron \
+ --with-piddir=/var/run \
+ --with-etcdir=/etc/fcron \
+ --with-spooldir=/var/spool/cron \
+ --with-fifodir=/var/run \
+ --with-sendmail=/usr/sbin/sendmail \
+ --with-fcrondyn=yes \
+ --with-editor=${EDITOR} \
+ --with-cflags="${CFLAGS}" \
+ ${myconf} \
+ || die "Configure problem"
+
+ emake || die "Compile problem"
+}
+
+src_install() {
+ dodir /var/spool
+ diropts -m 0770 -o cron -g cron
+ keepdir /var/spool/cron/fcrontabs
+
+ insinto /usr/sbin
+ insopts -o root -g root -m0110 ; doins fcron
+ insinto /usr/bin
+ insopts -o cron -g cron -m6110 ; doins fcrontab fcrondyn
+ insopts -o root -g cron -m6110 ; doins fcronsighup
+ dosym fcrontab /usr/bin/crontab
+
+ insinto /etc/fcron
+ insopts -m 640 -o root -g cron
+ doins ${FILESDIR}/{fcron.allow,fcron.deny,fcron.conf}
+
+ insopts -m 644 -o root -g root
+ if use pam ; then
+ insinto /etc/pam.d
+ newins ${FILESDIR}/fcron.pam fcron
+ newins ${FILESDIR}/fcrontab.pam fcrontab
+ fi
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/fcron.rc6 fcron
+
+ dodoc MANIFEST VERSION doc/txt/*.txt
+ newdoc ${FILESDIR}/fcron.conf-${PV} fcron.conf.sample
+ if use doc ; then
+ docinto html ; dohtml doc/HTML/*.html
+ fi
+ dodoc ${FILESDIR}/crontab
+
+ doman doc/man/*.{1,3,5,8}
+}
+
+pkg_postinst() {
+ einfo "Each user who uses fcron should be added to the cron group"
+ einfo "in /etc/group and also be added in /etc/fcron/fcron.allow"
+ einfo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ einfo
+ einfo "!!! That will replace root's current crontab !!!"
+ einfo
+}
diff --git a/sys-apps/fcron/files/2.9.4-braindead-configure-check.patch b/sys-apps/fcron/files/2.9.4-braindead-configure-check.patch
new file mode 100644
index 000000000000..f12273022f72
--- /dev/null
+++ b/sys-apps/fcron/files/2.9.4-braindead-configure-check.patch
@@ -0,0 +1,16 @@
+--- configure.in.orig 2004-04-18 18:14:37.944027760 -0400
++++ configure.in 2004-04-18 18:14:57.447062848 -0400
+@@ -254,13 +254,8 @@
+ fi
+ ;;
+ *)
+- if test -d "$withval"; then
+ etcdir="$withval"
+ AC_MSG_RESULT($withval)
+- else
+- AC_MSG_ERROR([
+-Directory $withval does not exist])
+- fi
+ ;;
+ esac ],
+ if test -d "/etc"; then
diff --git a/sys-apps/fcron/files/digest-fcron-2.9.4 b/sys-apps/fcron/files/digest-fcron-2.9.4
new file mode 100644
index 000000000000..5e1329187072
--- /dev/null
+++ b/sys-apps/fcron/files/digest-fcron-2.9.4
@@ -0,0 +1 @@
+MD5 4bfcff1002a7231f374591511bacadb2 fcron-2.9.4.src.tar.gz 378987
diff --git a/sys-apps/fcron/files/fcron.conf-2.9.4 b/sys-apps/fcron/files/fcron.conf-2.9.4
new file mode 100644
index 000000000000..24bb86a81b48
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.conf-2.9.4
@@ -0,0 +1,23 @@
+# fcron.conf - Configuration file for fcron(8) and fcrontab(1).
+# See fcron.conf(5) for syntax and explanations.
+#
+# WARNING : this file must be owned by root:cron and 640.
+#
+
+# The spool directory where fcron stores its files
+fcrontabs = /var/spool/cron/fcrontabs
+
+# The locations of the pid file and the fifo file
+pidfile = /var/run/fcron.pid
+fifofile = /var/run/fcron.fifo
+
+# allow/deny files to determine which users are allowed to use fcrontab
+fcronallow = /etc/fcron/fcron.allow
+fcrondeny = /etc/fcron/fcron.deny
+
+# Location of the programs used by fcron
+shell = /bin/sh
+sendmail = /usr/sbin/sendmail
+
+# Location of the default editor for "fcrontab -e"
+editor = /bin/nano
diff --git a/sys-apps/fcron/files/fcron.pam b/sys-apps/fcron/files/fcron.pam
new file mode 100644
index 000000000000..756ffc3492f4
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.pam
@@ -0,0 +1,11 @@
+#
+# The PAM configuration file for fcron daemon
+#
+
+account required pam_unix.so
+# Warning : fcron has no way to prompt user for a password !
+auth required pam_permit.so
+#auth required pam_unix.so nullok
+#auth required pam_env.so
+session required pam_permit.so
+#session required pam_unix.so
diff --git a/sys-apps/fcron/files/fcrontab.pam b/sys-apps/fcron/files/fcrontab.pam
new file mode 100644
index 000000000000..b9ada666cf53
--- /dev/null
+++ b/sys-apps/fcron/files/fcrontab.pam
@@ -0,0 +1,18 @@
+#
+# The PAM configuration file for fcrontab
+#
+
+# WARNING : you cannot use every modules here, as some
+# (such as pam_unix_acct.so) require the program to be run
+# by root or suid root, and fcrontab is *not* suid root.
+
+### By default we do not ask user for a password
+auth required pam_permit.so
+#auth required pam_unix.so nullok
+#auth required pam_env.so
+
+account required pam_permit.so
+#account required pam_time.so
+
+session required pam_permit.so
+#session required pam_unix.so