summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-10-04 00:29:57 +0000
committerMichael Januszewski <spock@gentoo.org>2008-10-04 00:29:57 +0000
commit6bcdd6e03da46b408321e188a6117e3276ffd274 (patch)
treef674b79039c580ef9f65afca198180bbd35e12db /sys-apps
parentSparc stable --- Bug #230919 and Bug #239368. (diff)
downloadgentoo-2-6bcdd6e03da46b408321e188a6117e3276ffd274.tar.gz
gentoo-2-6bcdd6e03da46b408321e188a6117e3276ffd274.tar.bz2
gentoo-2-6bcdd6e03da46b408321e188a6117e3276ffd274.zip
Version bump.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/v86d/ChangeLog7
-rw-r--r--sys-apps/v86d/v86d-0.1.9.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index 55ebfe90946b..dbf3eda7a6be 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/v86d
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.25 2008/09/27 20:54:16 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.26 2008/10/04 00:29:57 spock Exp $
+
+*v86d-0.1.9 (04 Oct 2008)
+
+ 04 Oct 2008; Michał Januszewski <spock@gentoo.org> +v86d-0.1.9.ebuild:
+ Version bump.
27 Sep 2008; Michał Januszewski <spock@gentoo.org> v86d-0.1.3-r1.ebuild:
Fix concurrent build in the current stable version of v86d.
diff --git a/sys-apps/v86d/v86d-0.1.9.ebuild b/sys-apps/v86d/v86d-0.1.9.ebuild
new file mode 100644
index 000000000000..4020c788db89
--- /dev/null
+++ b/sys-apps/v86d/v86d-0.1.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.9.ebuild,v 1.1 2008/10/04 00:29:57 spock Exp $
+
+inherit eutils linux-info multilib
+
+DESCRIPTION="A daemon to run x86 code in an emulated environment."
+HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
+SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug x86emu"
+
+DEPEND="dev-libs/klibc"
+RDEPEND=""
+
+S="${WORKDIR}/${P//_*/}"
+
+pkg_setup() {
+ if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
+ eerror "You need to compile klibc against a kernel tree patched with uvesafb"
+ eerror "prior to merging this package."
+ die "Kernel not patched with uvesafb."
+ fi
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ ./configure --with-klibc $(use_with debug) $(use_with x86emu)
+ make KDIR="${KV_DIR}" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins misc/initramfs
+}
+
+pkg_postinst() {
+ elog "If you wish to place v86d into an initramfs image, you might want to use"
+ elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
+}