summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-21 19:20:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-21 19:20:30 +0000
commita49115039ccbdad59ad7c86965efd971f273d13a (patch)
treec962481c3b39eaaf7397b9c8d2225aca78f63f75 /sys-auth/consolekit
parentFix bug 467588. EAPI bump. Remove old. (diff)
downloadgentoo-2-a49115039ccbdad59ad7c86965efd971f273d13a.tar.gz
gentoo-2-a49115039ccbdad59ad7c86965efd971f273d13a.tar.bz2
gentoo-2-a49115039ccbdad59ad7c86965efd971f273d13a.zip
Introduce USE="systemd" to force installation of systemd unit files despite of systemd-logind making it more or less obsolete (and remove SystemdService= line from the .service file when required) wrt #478258
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-auth/consolekit')
-rw-r--r--sys-auth/consolekit/ChangeLog8
-rw-r--r--sys-auth/consolekit/consolekit-0.4.6.ebuild20
-rw-r--r--sys-auth/consolekit/metadata.xml6
3 files changed, 28 insertions, 6 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index 0db5348eec3e..96b1515ed97d 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.162 2013/08/18 13:44:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.163 2013/08/21 19:20:30 ssuominen Exp $
+
+ 21 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> consolekit-0.4.6.ebuild,
+ metadata.xml:
+ Introduce USE="systemd" to force installation of systemd unit files despite of
+ systemd-logind making it more or less obsolete (and remove SystemdService=
+ line from the .service file when required) wrt #478258
18 Aug 2013; Agostino Sarubbo <ago@gentoo.org> consolekit-0.4.6.ebuild:
Stable for x86, wrt bug #480028
diff --git a/sys-auth/consolekit/consolekit-0.4.6.ebuild b/sys-auth/consolekit/consolekit-0.4.6.ebuild
index bf590b5628c6..5f506330b655 100644
--- a/sys-auth/consolekit/consolekit-0.4.6.ebuild
+++ b/sys-auth/consolekit/consolekit-0.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.6.ebuild,v 1.8 2013/08/18 13:44:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.6.ebuild,v 1.9 2013/08/21 19:20:30 ssuominen Exp $
EAPI=5
inherit autotools eutils linux-info pam systemd
@@ -15,7 +15,7 @@ SRC_URI="http://www.freedesktop.org/software/${MY_PN}/dist/${MY_P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="acl debug doc kernel_linux pam policykit selinux test"
+IUSE="acl debug doc kernel_linux pam policykit selinux systemd test"
COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=dev-libs/glib-2.22:2=
@@ -60,10 +60,21 @@ src_prepare() {
"${FILESDIR}"/${PN}-udev-acl-install_to_usr.patch \
"${FILESDIR}"/${PN}-0.4.5-polkit-automagic.patch
+ if ! use systemd; then
+ sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
+ fi
+
eautoreconf
}
src_configure() {
+ local myconf
+ if use systemd; then
+ myconf="$(systemd_with_unitdir)"
+ else
+ myconf="--with-systemdsystemunitdir=/tmp"
+ fi
+
econf \
XMLTO_FLAGS='--skip-validation' \
--libexecdir="${EPREFIX}"/usr/lib/${MY_PN} \
@@ -76,7 +87,7 @@ src_configure() {
$(use_enable acl udev-acl) \
--with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
--with-pam-module-dir="$(getpam_mod_dir)" \
- "$(systemd_with_unitdir)"
+ ${myconf}
}
src_install() {
@@ -102,6 +113,7 @@ src_install() {
exeinto /usr/lib/ConsoleKit/run-session.d
doexe "${FILESDIR}"/pam-foreground-compat.ck
- rm -rf "${ED}"/usr/lib/systemd # avoid collision with systemd-logind
prune_libtool_files --all # --all for pam_ck_connector.la
+
+ use systemd || rm -rf "${ED}"/tmp
}
diff --git a/sys-auth/consolekit/metadata.xml b/sys-auth/consolekit/metadata.xml
index 0271f0b98d50..2d5f0be57f55 100644
--- a/sys-auth/consolekit/metadata.xml
+++ b/sys-auth/consolekit/metadata.xml
@@ -3,9 +3,13 @@
<pkgmetadata>
<herd>freedesktop</herd>
<use>
- <flag name="policykit">
+ <flag name='policykit'>
Use the PolicyKit framework (<pkg>sys-auth/polkit</pkg>) to get
authorization for suspend/shutdown.
</flag>
+ <flag name='systemd'>
+ Install systemd unit files despite <pkg>sys-apps/systemd</pkg>
+ and systemd-logind. Not recommended.
+ </flag>
</use>
</pkgmetadata>