summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-02-06 15:05:19 +0000
committerRoy Marples <uberlord@gentoo.org>2007-02-06 15:05:19 +0000
commit632a88a141b575295db56e3f97e3f2386c5d180c (patch)
tree776ba75ce949c132947fdaa1e1f4abb349bfa79a /sys-auth/openpam
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-632a88a141b575295db56e3f97e3f2386c5d180c.tar.gz
gentoo-2-632a88a141b575295db56e3f97e3f2386c5d180c.tar.bz2
gentoo-2-632a88a141b575295db56e3f97e3f2386c5d180c.zip
Added a patch so that services don't fail if they list a missing module as
"optional" or "sufficient". (Portage version: 2.1.2-r8)
Diffstat (limited to 'sys-auth/openpam')
-rw-r--r--sys-auth/openpam/ChangeLog11
-rw-r--r--sys-auth/openpam/files/digest-openpam-20050616-r13
-rw-r--r--sys-auth/openpam/files/openpam-20050616-optional.patch28
-rw-r--r--sys-auth/openpam/openpam-20050616-r1.ebuild55
4 files changed, 95 insertions, 2 deletions
diff --git a/sys-auth/openpam/ChangeLog b/sys-auth/openpam/ChangeLog
index a42e9c369260..5d3c86cd6d56 100644
--- a/sys-auth/openpam/ChangeLog
+++ b/sys-auth/openpam/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/openpam
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.7 2006/10/30 09:54:57 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.8 2007/02/06 15:05:19 uberlord Exp $
+
+*openpam-20050616-r1 (06 Feb 2007)
+
+ 06 Feb 2007; Roy Marples <uberlord@gentoo.org>
+ +files/openpam-20050616-optional.patch, +openpam-20050616-r1.ebuild:
+ Added a patch so that services don't fail if they list a missing module as
+ "optional" or "sufficient".
30 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
openpam-20050616.ebuild:
diff --git a/sys-auth/openpam/files/digest-openpam-20050616-r1 b/sys-auth/openpam/files/digest-openpam-20050616-r1
new file mode 100644
index 000000000000..e2691009c523
--- /dev/null
+++ b/sys-auth/openpam/files/digest-openpam-20050616-r1
@@ -0,0 +1,3 @@
+MD5 e82a48944d7080e7a3fb343afd5d8b0a openpam-20050616.tar.gz 375459
+RMD160 4506364a65ea1bf8f7aa80254f593c1cad64ebbd openpam-20050616.tar.gz 375459
+SHA256 2d8b552e9354c107dbbb49b61f6718911d031e8276a18a457039f29cc223deca openpam-20050616.tar.gz 375459
diff --git a/sys-auth/openpam/files/openpam-20050616-optional.patch b/sys-auth/openpam/files/openpam-20050616-optional.patch
new file mode 100644
index 000000000000..8610cdf0efe6
--- /dev/null
+++ b/sys-auth/openpam/files/openpam-20050616-optional.patch
@@ -0,0 +1,28 @@
+diff -ur openpam-20050616.orig/lib/openpam_configure.c openpam-20050616/lib/openpam_configure.c
+--- openpam-20050616.orig/lib/openpam_configure.c 2005-06-15 23:00:00 +0100
++++ openpam-20050616/lib/openpam_configure.c 2007-02-06 14:55:20 +0000
+@@ -220,8 +220,14 @@
+ goto syserr;
+ this->module = openpam_load_module(name);
+ FREE(name);
+- if (this->module == NULL)
++ if (this->module == NULL) {
++ if (this->flag == PAM_OPTIONAL ||
++ this->flag == PAM_SUFFICIENT) {
++ free(this);
++ continue;
++ }
+ goto fail;
++ }
+
+ /* module options */
+ p = q = next_word(p);
+@@ -249,7 +255,7 @@
+ /* next please... */
+ FREE(line);
+ }
+- if (!feof(f))
++ if (!feof(f) || count == 0)
+ goto syserr;
+ fclose(f);
+ return (count);
diff --git a/sys-auth/openpam/openpam-20050616-r1.ebuild b/sys-auth/openpam/openpam-20050616-r1.ebuild
new file mode 100644
index 000000000000..822417b9b4e8
--- /dev/null
+++ b/sys-auth/openpam/openpam-20050616-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20050616-r1.ebuild,v 1.1 2007/02/06 15:05:19 uberlord Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit multilib flag-o-matic autotools
+
+DESCRIPTION="Open source PAM library."
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+IUSE="debug vim-syntax"
+
+RDEPEND="!virtual/pam"
+DEPEND="sys-devel/make
+ dev-lang/perl"
+PDEPEND="|| ( sys-freebsd/freebsd-pam-modules sys-netbsd/netbsd-pam-modules )
+ vim-syntax? ( app-vim/pam-syntax )"
+
+PROVIDE="virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-20050201-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-20050201-nbsd.patch"
+ epatch "${FILESDIR}/${P}-redef.patch"
+ epatch "${FILESDIR}/${P}-optional.patch"
+
+ sed -i -e 's:-Werror::' "${S}/configure.ac"
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --with-modules-dir=/$(get_libdir)/security \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc CREDITS HISTORY MANIFEST RELNOTES README
+}