summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-04-22 14:04:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-04-22 14:04:02 +0000
commitc3b497ab566274f5c77eeb172f98abf080fdb42f (patch)
tree266f8044a96445562e5aae8c63e8d4007f7fcf0f /sys-auth/openpam
parentMove from deprecated qt4 eclass to qt4-r2, bump EAPI, add missing dep by Mich... (diff)
downloadgentoo-2-c3b497ab566274f5c77eeb172f98abf080fdb42f.tar.gz
gentoo-2-c3b497ab566274f5c77eeb172f98abf080fdb42f.tar.bz2
gentoo-2-c3b497ab566274f5c77eeb172f98abf080fdb42f.zip
version bump
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/openpam')
-rw-r--r--sys-auth/openpam/ChangeLog10
-rw-r--r--sys-auth/openpam/files/openpam-20111218-nomajor.patch19
-rw-r--r--sys-auth/openpam/openpam-20111218.ebuild48
3 files changed, 75 insertions, 2 deletions
diff --git a/sys-auth/openpam/ChangeLog b/sys-auth/openpam/ChangeLog
index 49d6d0a4a708..504e8f842875 100644
--- a/sys-auth/openpam/ChangeLog
+++ b/sys-auth/openpam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/openpam
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.18 2011/07/05 15:42:44 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.19 2012/04/22 14:04:01 aballier Exp $
+
+*openpam-20111218 (22 Apr 2012)
+
+ 22 Apr 2012; Alexis Ballier <aballier@gentoo.org> +openpam-20111218.ebuild,
+ +files/openpam-20111218-nomajor.patch:
+ version bump
05 Jul 2011; Alexis Ballier <aballier@gentoo.org> openpam-20071221.ebuild:
force automake 1.9 for bug #318121
diff --git a/sys-auth/openpam/files/openpam-20111218-nomajor.patch b/sys-auth/openpam/files/openpam-20111218-nomajor.patch
new file mode 100644
index 000000000000..6f67b9a02fef
--- /dev/null
+++ b/sys-auth/openpam/files/openpam-20111218-nomajor.patch
@@ -0,0 +1,19 @@
+Check only for the .so: it spits out 'No such file or directory' warnings if the .so.MAJOR isnt found and tries the .so anyway, so this avoids the warnings.
+
+--- lib/openpam_dynamic.c.old 2012-04-21 17:03:28.000000000 +0000
++++ lib/openpam_dynamic.c 2012-04-21 17:05:11.000000000 +0000
+@@ -94,12 +94,9 @@
+ prefix = "";
+
+ /* try versioned module first, then unversioned module */
+- if (asprintf(&vpath, "%s%s.%d", prefix, path, LIB_MAJ) < 0)
++ if (asprintf(&vpath, "%s%s", prefix, path) < 0)
+ goto err;
+- if ((dlh = try_dlopen(vpath)) == NULL && errno == ENOENT) {
+- *strrchr(vpath, '.') = '\0';
+- dlh = try_dlopen(vpath);
+- }
++ dlh = try_dlopen(vpath);
+ serrno = errno;
+ FREE(vpath);
+ errno = serrno;
diff --git a/sys-auth/openpam/openpam-20111218.ebuild b/sys-auth/openpam/openpam-20111218.ebuild
new file mode 100644
index 000000000000..80d7e4243b2c
--- /dev/null
+++ b/sys-auth/openpam/openpam-20111218.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20111218.ebuild,v 1.1 2012/04/22 14:04:01 aballier Exp $
+
+EAPI="2"
+# https://bugs.gentoo.org/show_bug.cgi?id=318121
+WANT_AUTOMAKE=1.9
+inherit multilib autotools
+
+DESCRIPTION="Open source PAM library."
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+IUSE="debug vim-syntax"
+
+RDEPEND="!sys-libs/pam"
+DEPEND="sys-devel/make
+ dev-lang/perl"
+PDEPEND="sys-auth/pambase
+ vim-syntax? ( app-vim/pam-syntax )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-20071221-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-20050201-nbsd.patch"
+ epatch "${FILESDIR}/${PN}-20111218-nomajor.patch"
+
+ sed -i -e 's:-Werror::' "${S}/configure.ac"
+
+ mkdir "${S}/m4" # Otherwise aclocal fails since ACLOCAL_AMFLAGS is set in Makefile.am
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf ${myconf} \
+ --disable-dependency-tracking \
+ --with-modules-dir=/$(get_libdir)/security/
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dodoc CREDITS HISTORY RELNOTES README || die
+
+ find "${D}" -name '*.la' -delete || die
+}