summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-06-13 01:47:26 +0000
committerSebastian Pipping <sping@gentoo.org>2011-06-13 01:47:26 +0000
commit4d6d06896ccc93994dcfa30be19d4946663fd69a (patch)
treef5d59fde78808ebe741794e1d04effdcc20d6819 /sys-block
parentVersion bump. (diff)
downloadgentoo-2-4d6d06896ccc93994dcfa30be19d4946663fd69a.tar.gz
gentoo-2-4d6d06896ccc93994dcfa30be19d4946663fd69a.tar.bz2
gentoo-2-4d6d06896ccc93994dcfa30be19d4946663fd69a.zip
sys-block/open-iscsi: Fix version check for Linux 3 (bug #340425
(Portage version: 2.1.10.2/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/ChangeLog8
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.870.3-r1.ebuild4
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild6
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild6
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.ebuild6
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.872.ebuild4
6 files changed, 20 insertions, 14 deletions
diff --git a/sys-block/open-iscsi/ChangeLog b/sys-block/open-iscsi/ChangeLog
index d74772811710..a449e6e3894e 100644
--- a/sys-block/open-iscsi/ChangeLog
+++ b/sys-block/open-iscsi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/open-iscsi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.32 2011/06/07 14:32:38 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.33 2011/06/13 01:47:26 sping Exp $
+
+ 13 Jun 2011; Sebastian Pipping <sping@gentoo.org>
+ open-iscsi-2.0.870.3-r1.ebuild, open-iscsi-2.0.871.ebuild,
+ open-iscsi-2.0.871-r1.ebuild, open-iscsi-2.0.871.3.ebuild,
+ open-iscsi-2.0.872.ebuild:
+ Fix version check for Linux 3
*open-iscsi-2.0.872 (07 Jun 2011)
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.870.3-r1.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.870.3-r1.ebuild
index 0abe849f6a8b..cbed463b5c0d 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.870.3-r1.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.870.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.870.3-r1.ebuild,v 1.2 2011/04/24 21:04:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.870.3-r1.ebuild,v 1.3 2011/06/13 01:47:26 sping Exp $
inherit versionator linux-mod eutils flag-o-matic
@@ -28,7 +28,7 @@ ERROR_CFG="open-iscsi needs CRC32C support in your kernel."
src_unpack() {
unpack ${A}
export EPATCH_OPTS="-d${S}"
- if [ $KV_PATCH -lt 15 ]; then
+ if kernel_is -lt 2 6 16; then
die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
fi
epatch "${FILESDIR}"/CVE-2009-1297.patch
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
index faf03a6c6bbb..5a09c82ca48f 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.6 2010/03/31 23:19:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.7 2011/06/13 01:47:26 sping Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -22,7 +22,7 @@ S="${WORKDIR}/${MY_PV}"
pkg_setup() {
linux-info_pkg_setup
- if [ $KV_PATCH -lt 15 ]; then
+ if kernel_is -lt 2 6 16; then
die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
fi
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
index 953611fcf31e..0df0607ec5b2 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.3 2010/08/24 13:48:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.4 2011/06/13 01:47:26 sping Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -19,7 +19,7 @@ RDEPEND="${DEPEND}
pkg_setup() {
linux-info_pkg_setup
- if [ $KV_PATCH -lt 15 ]; then
+ if kernel_is -lt 2 6 16; then
die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
fi
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
index ef63365d35e9..2c2e17941b52 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild,v 1.2 2009/10/28 16:49:50 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild,v 1.3 2011/06/13 01:47:26 sping Exp $
inherit versionator linux-mod eutils flag-o-matic
@@ -43,7 +43,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
export EPATCH_OPTS="-d${S}"
- if [ $KV_PATCH -lt 15 ]; then
+ if kernel_is -lt 2 6 16; then
die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
fi
epatch "${FILESDIR}"/CVE-2009-1297.patch
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
index df4a71864fce..8b548e46b393 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild,v 1.1 2011/06/07 14:32:38 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild,v 1.2 2011/06/13 01:47:26 sping Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -22,7 +22,7 @@ S="${WORKDIR}/${MY_PV}"
pkg_setup() {
linux-info_pkg_setup
- if [ $KV_PATCH -lt 15 ]; then
+ if kernel_is -lt 2 6 16; then
die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
fi